aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/kqemu-kmod
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2009-03-29 02:12:38 +0800
committernox <nox@FreeBSD.org>2009-03-29 02:12:38 +0800
commitd2cc2b0039110ba29eee8c5787998714903890eb (patch)
treeae6777a8e50d7dd14fda38c790dd0721d6cefb85 /emulators/kqemu-kmod
parent99f0b58d2f24ce3487661c0dc18201231199466d (diff)
downloadfreebsd-ports-gnome-d2cc2b0039110ba29eee8c5787998714903890eb.tar.gz
freebsd-ports-gnome-d2cc2b0039110ba29eee8c5787998714903890eb.tar.zst
freebsd-ports-gnome-d2cc2b0039110ba29eee8c5787998714903890eb.zip
- Only add the tss fixup code on OSVERSIONs where its still needed.
(It _should_ do nothing elsewhere but still would be unnecessary cycles...) - Bump PORTREVISIONs.
Diffstat (limited to 'emulators/kqemu-kmod')
-rw-r--r--emulators/kqemu-kmod/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index d2987124dc17..31c025bfbfed 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.3.0.p11
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -68,6 +68,13 @@ post-extract:
@${ECHO_MSG} "then please define NOKSE."
.endif
+# 7.1 and head have seperate gdts also on amd64 now so the tss fixup code
+# is no longer needed there
+post-patch:
+.if ${OSVERSION} >= 701100 && (${OSVERSION} < 800000 || ${OSVERSION} >= 800046)
+ @cd ${WRKSRC} && ${PATCH} -R --quiet < ${FILESDIR}/patch-tssworkaround
+.endif
+
do-build:
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})