aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux-pete-mesagpu
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-05-20 16:35:19 +0800
committerbsam <bsam@FreeBSD.org>2013-05-20 16:35:19 +0800
commit83d8206376f52e3487f75b69985bcec73ede7d9d (patch)
tree5b436640807b0b013ef5f4127069cff83ff27395 /emulators/linux-pete-mesagpu
parent62375be4c9cff92829f41af6ad6993678df955ef (diff)
downloadfreebsd-ports-gnome-83d8206376f52e3487f75b69985bcec73ede7d9d.tar.gz
freebsd-ports-gnome-83d8206376f52e3487f75b69985bcec73ede7d9d.tar.zst
freebsd-ports-gnome-83d8206376f52e3487f75b69985bcec73ede7d9d.zip
. update to version 1.77;
. trim Makefile headers; . lang maintainership to the submitter. While I'm here: remove the indefinite article from COMMENT. PR: ports/173464 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com>
Diffstat (limited to 'emulators/linux-pete-mesagpu')
-rw-r--r--emulators/linux-pete-mesagpu/Makefile40
-rw-r--r--emulators/linux-pete-mesagpu/distinfo6
-rw-r--r--emulators/linux-pete-mesagpu/pkg-plist3
3 files changed, 26 insertions, 23 deletions
diff --git a/emulators/linux-pete-mesagpu/Makefile b/emulators/linux-pete-mesagpu/Makefile
index 4d8baae4ece4..e31fb20f7731 100644
--- a/emulators/linux-pete-mesagpu/Makefile
+++ b/emulators/linux-pete-mesagpu/Makefile
@@ -1,34 +1,28 @@
-# New ports collection makefile for: linux-pete-mesagpu
-# Date created: 23 Dec 2002
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= pete-mesagpu
-PORTVERSION= 1.76
-PORTREVISION= 1
+PORTVERSION= ${MESAGPU_VERSION}
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
-DISTNAME= gpupetemesagl${MAJOR}${MINOR}
+DISTFILES= gpupetemesagl${MAJOR}${MINOR}${EXTRACT_SUFX} \
+ ${CFG_DISTFILE}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A PSEmu Pro GPU plugin using an OpenGL renderer (Linux version)
-
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-USE_LINUX_APPS+=dri
-.endif
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= PSEmu Pro GPU plugin using an OpenGL renderer (Linux version)
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
USE_LINUX_APPS= gtk xorglibs
+PORTDOCS= *
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS_DEFINE= NVIDIA_GL
+NVIDIA_GL_DESC= Use nVidia OpenGL driver
+
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
@@ -37,17 +31,27 @@ PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
+.include <bsd.port.options.mk>
+
+.include "${.CURDIR}/../linux-pete-xgl2gpu/Makefile.inc"
+
+.if ${PORT_OPTIONS:MNVIDIA_GL}
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+USE_LINUX_APPS+=dri
+.endif
+
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeteMesaGL.so.${MAJOR}.0.${MINOR} ${PSEMUPRO_PLUGINS_DIR}
${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/cfgPeteMesaGL ${PSEMUPRO_CFGBINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/cfg/cfgPeteMesaGL ${PSEMUPRO_CFGBINS_DIR}
${MKDIR} ${PSEMUPRO_CFGFILES_DIR}
${INSTALL_DATA} ${WRKSRC}/gpuPeteMesaGL.cfg ${PSEMUPRO_CFGFILES_DIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
.endif
diff --git a/emulators/linux-pete-mesagpu/distinfo b/emulators/linux-pete-mesagpu/distinfo
index 8fefad99371c..87f7f7e037a0 100644
--- a/emulators/linux-pete-mesagpu/distinfo
+++ b/emulators/linux-pete-mesagpu/distinfo
@@ -1,2 +1,4 @@
-SHA256 (gpupetemesagl176.tar.gz) = b974caf7798fdf8e8f024dea97cadcbb0d34d6f7e871517e03fc1c6d5a6b56c6
-SIZE (gpupetemesagl176.tar.gz) = 198545
+SHA256 (gpupetemesagl177.tar.gz) = c37238973f00625cdc6798cbeab0b78d62c5e041eb1e7cb0a4bc09006873126d
+SIZE (gpupetemesagl177.tar.gz) = 182012
+SHA256 (petegpucfg_V2-9_V1-77_V1-18.tar.gz) = 1488750fb2f158b68ef11b693fc1f45948ec41e84b1329315703adc91679fd91
+SIZE (petegpucfg_V2-9_V1-77_V1-18.tar.gz) = 59589
diff --git a/emulators/linux-pete-mesagpu/pkg-plist b/emulators/linux-pete-mesagpu/pkg-plist
index c96f4524d26e..66f5f3437f2e 100644
--- a/emulators/linux-pete-mesagpu/pkg-plist
+++ b/emulators/linux-pete-mesagpu/pkg-plist
@@ -7,6 +7,3 @@ share/psemupro/cfg/gpuPeteMesaGL.cfg
@dirrmtry libexec/psemupro
@dirrmtry share/psemupro/cfg
@dirrmtry share/psemupro
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/version.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%