aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux-vmware-toolbox2
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2003-04-19 15:14:17 +0800
committermatusita <matusita@FreeBSD.org>2003-04-19 15:14:17 +0800
commit2bd883adc1fa26e582b70c705130a46b920adc39 (patch)
tree28ca6b2102ce9b6a2b9f6e2aadd390fd394bf269 /emulators/linux-vmware-toolbox2
parent5ee6da0bde10b7ad89790cacdbc5cbd15e40dfc4 (diff)
downloadfreebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.tar.gz
freebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.tar.zst
freebsd-ports-gnome-2bd883adc1fa26e582b70c705130a46b920adc39.zip
Cosmetic fixes for old VMware guest tools to sync with the latest one.
* Update pkg-descr to point a new ports location. * Update RUN_DEPENDS to point a new ports location. * Sync COMMENT message to all versions. * Use INSTALL_PROGRAM instead of CP since it installs a program. * Wrap interactive-related script with .if !defined(BATCH) appropriately. * Unhide UMOUNT command and users will know what's happened.
Diffstat (limited to 'emulators/linux-vmware-toolbox2')
-rw-r--r--emulators/linux-vmware-toolbox2/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/emulators/linux-vmware-toolbox2/Makefile b/emulators/linux-vmware-toolbox2/Makefile
index ee82e72ab6a9..6c1d2a63dbc5 100644
--- a/emulators/linux-vmware-toolbox2/Makefile
+++ b/emulators/linux-vmware-toolbox2/Makefile
@@ -13,13 +13,15 @@ PKGNAMEPREFIX= linux-
DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
+COMMENT=VMware toolbox for guest OS (for VMware 2.x, Linux version)
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
@@ -40,6 +42,8 @@ MOUNT_DEV?= vn0
.else
MOUNT_DEV?= fd0
.endif
+STRIP=
+
VMWARE_VER= 2.0.4
BUILD_VER= 1142
@@ -58,6 +62,7 @@ pre-fetch:
@${ECHO} "========================================================================"
@${ECHO} ""
@${ECHO} -n "Are ready to install this ports? [Y/n]: "
+.if !defined(BATCH)
@(read line; \
case "$${line}" in \
[Nn]*) \
@@ -66,16 +71,17 @@ pre-fetch:
${TRUE} ;; \
esac)
.endif
+.endif
do-fetch:
.if exists("${DISTDIR}/${DISTFILES}")
@${ECHO} "Found ${DISTDIR}/${DISTFILES}."
.else
${MKDIR} ${MOUNT_PT}
- -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
- -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
+ -${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
.if exists(${LINUX_FLP})
- -@${DEV_DETACH} 2>&1 >/dev/null
+ -${DEV_DETACH} 2>&1 >/dev/null
${DEV_ATTACH}
.endif
${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
@@ -87,6 +93,6 @@ do-fetch:
.endif
do-install:
- ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+ ${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
.include <bsd.port.post.mk>