aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux-xjoypad
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-21 21:19:00 +0800
committermiwi <miwi@FreeBSD.org>2008-06-21 21:19:00 +0800
commitb8641b3a0545c2efbcfb0de9a3f90c5b16a440b8 (patch)
tree46a0ad114083ba3fa08134f64db2886b322c6335 /emulators/linux-xjoypad
parent852beea359510a2011933c99b70b5dcf121379f4 (diff)
downloadfreebsd-ports-gnome-b8641b3a0545c2efbcfb0de9a3f90c5b16a440b8.tar.gz
freebsd-ports-gnome-b8641b3a0545c2efbcfb0de9a3f90c5b16a440b8.tar.zst
freebsd-ports-gnome-b8641b3a0545c2efbcfb0de9a3f90c5b16a440b8.zip
- Remove USE_LINUX
- Remove USE_X_PREFIX - Remove BUILD_DEPENDS - Fix USE_XORG - Fix LDFLAGS - Fix CATEGORIES PR: 124520 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua> Approved by: maintainer
Diffstat (limited to 'emulators/linux-xjoypad')
-rw-r--r--emulators/linux-xjoypad/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/emulators/linux-xjoypad/Makefile b/emulators/linux-xjoypad/Makefile
index 08431cc8f01f..dca78bd60f38 100644
--- a/emulators/linux-xjoypad/Makefile
+++ b/emulators/linux-xjoypad/Makefile
@@ -7,8 +7,8 @@
PORTNAME= xjoypad
PORTVERSION= 1
-PORTREVISION= 1
-CATEGORIES= emulators linux
+PORTREVISION= 2
+CATEGORIES= emulators
MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/down/
PKGNAMEPREFIX= linux-
DISTNAME= xjoypad
@@ -16,23 +16,18 @@ DISTNAME= xjoypad
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Joy-Device to X mapping (lets you play Linux games with a joypad)
-BUILD_DEPENDS= ${X11BASE}/lib/libX11.a:${PORTSDIR}/x11/libX11
RUN_DEPENDS= /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
-USE_XORG= x11
+USE_XORG= x11 xau xdmcp
WRKSRC= ${WRKDIR}/xjoypad/
-USE_LINUX= yes
-USE_X_PREFIX= yes
USE_ZIP= yes
FILES= xjoypad.c sendevent.c
-CFLAGS+= -I ${PREFIX}/include
-LIB_X11= ${PREFIX}/lib/libX11.a
-LIB_XAU= ${PREFIX}/lib/libXau.a
-LIB_XDMCP= ${PREFIX}/lib/libXdmcp.a
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lcompat -lX11 -lXau -lXdmcp
do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -o xjoypad ${FILES} -lcompat -lm ${LIB_X11} ${LIB_XAU} ${LIB_XDMCP})
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -o xjoypad ${FILES} ${LDFLAGS} )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xjoypad ${PREFIX}/bin