aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/linux_base-f8
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2006-06-24 01:07:39 +0800
committerbsam <bsam@FreeBSD.org>2006-06-24 01:07:39 +0800
commit77b1207a208c43bb8777d906d58d8461bee6613f (patch)
tree8bead7bfddc2c765ef0a1ede6e714d34cb686447 /emulators/linux_base-f8
parent1cd979b00fbae25ab100ebe09e1c9c02e0355240 (diff)
downloadfreebsd-ports-gnome-77b1207a208c43bb8777d906d58d8461bee6613f.tar.gz
freebsd-ports-gnome-77b1207a208c43bb8777d906d58d8461bee6613f.tar.zst
freebsd-ports-gnome-77b1207a208c43bb8777d906d58d8461bee6613f.zip
First do "brandelf -t Linux" at WRKSRC and then do install. This
makes impossible to shoot oneself to the foot if PREFIX is set to /usr/local. Reported by: consumidor <consumidor@mundinho.com.br> at emulation@ ML Approved by: netchild (mentor)
Diffstat (limited to 'emulators/linux_base-f8')
-rw-r--r--emulators/linux_base-f8/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/emulators/linux_base-f8/Makefile b/emulators/linux_base-f8/Makefile
index 05e228822016..dc791aeb6691 100644
--- a/emulators/linux_base-f8/Makefile
+++ b/emulators/linux_base-f8/Makefile
@@ -172,6 +172,11 @@ do-build:
#
@${MV} ${WRKSRC}/etc/nsswitch.conf ${WRKSRC}/etc/nsswitch.conf.dist
+ @${FIND} ${WRKSRC}/bin ${WRKSRC}/sbin/ ${WRKSRC}/usr/bin \
+ ${WRKSRC}/usr/sbin -type f -print0 | ${XARGS} -0 ${FILE} \
+ | ${GREP} ELF | ${CUT} -d : -f 1 \
+ | ${XARGS} ${BRANDELF} -t Linux
+
do-install:
#
# Handle the loading of the linux loadable kernel module if required.
@@ -184,10 +189,6 @@ do-install:
@cd ${WRKSRC} && ${FIND} * ! -type d \
| ${CPIO} -pm -R root:wheel ${PREFIX}
- @${FIND} ${PREFIX}/bin ${PREFIX}/sbin/ ${PREFIX}/usr/bin \
- ${PREFIX}/usr/sbin -type f -print0 | ${XARGS} -0 ${FILE} \
- | ${GREP} ELF | ${CUT} -d : -f 1 \
- | ${XARGS} ${BRANDELF} -t Linux
@${LN} -sf /var/tmp ${PREFIX}/usr/tmp
@${CHOWN} root:wheel ${PREFIX}/var/lock ${PREFIX}/var/spool/mail
@${CHMOD} 755 ${PREFIX}/var/lock ${PREFIX}/var/spool/mail