aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mame
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-06-08 19:58:48 +0800
committermadpilot <madpilot@FreeBSD.org>2012-06-08 19:58:48 +0800
commit0a6caca62b2abf7af8fb9f0abf78b6b32e9705de (patch)
tree030fe0f2f5fc18df107efae9c3e3599827a2ca0d /emulators/mame
parent7cb53877528a4a47cb6365a93b880755742cb9a9 (diff)
downloadfreebsd-ports-gnome-0a6caca62b2abf7af8fb9f0abf78b6b32e9705de.tar.gz
freebsd-ports-gnome-0a6caca62b2abf7af8fb9f0abf78b6b32e9705de.tar.zst
freebsd-ports-gnome-0a6caca62b2abf7af8fb9f0abf78b6b32e9705de.zip
Convert to new options framework.
Approved by: tabthorpe (mentor)
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 542ef9c8d1a8..d563a3140794 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -25,7 +25,9 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= liberation-fonts-ttf>=0:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
-OPTIONS= BUILTIN_DEBUGGER "Enable builtin debugger support" off
+OPTIONS_DEFINE= BUILTIN_DEBUGGER DOCS
+
+BUILTIN_DEBUGGER_DESCR= Enable builtin debugger support
ONLY_FOR_ARCHS= i386 amd64
@@ -54,7 +56,7 @@ UPDATE_PATCHES!= /usr/bin/jot -s " " \
.include <bsd.port.options.mk>
-.if defined(WITH_BUILTIN_DEBUGGER)
+.if ${PORT_OPTIONS:MBUILTIN_DEBUGGER}
USE_GNOME= gtk20 gconf2
MAKE_ENV+= GTK_INCPATH="$$(pkg-config --cflags-only-I gtk+-2.0 gconf-2.0)" \
GTK_CCOMFLAGS="$$(pkg-config --cflags-only-other gtk+-2.0 gconf-2.0)" \
@@ -114,12 +116,12 @@ do-install:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${DATADIR})
@(cd ${WRKSRC} && ${COPYTREE_SHARE} hash ${DATADIR})
@(cd ${WRKSRC}/src/osd/sdl && ${COPYTREE_SHARE} keymaps ${DATADIR})
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mame.ini ${EXAMPLESDIR}
.endif