aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mupen64-sdlaudio
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-12 13:05:50 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-12 13:05:50 +0800
commit8caf15350c38845097439c9f5fffc412ee9b3e6f (patch)
tree6fcc3251856378bd4653be5599fa3e8668675009 /emulators/mupen64-sdlaudio
parentc3a08bea5ac453be1ee44ba6c9fd593d1ac057ab (diff)
downloadfreebsd-ports-gnome-8caf15350c38845097439c9f5fffc412ee9b3e6f.tar.gz
freebsd-ports-gnome-8caf15350c38845097439c9f5fffc412ee9b3e6f.tar.zst
freebsd-ports-gnome-8caf15350c38845097439c9f5fffc412ee9b3e6f.zip
JttL SDL sound plugin for Mupen64
- Mupen64 is a highly portable Nintendo 64 emulator. It has been developed on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Diffstat (limited to 'emulators/mupen64-sdlaudio')
-rw-r--r--emulators/mupen64-sdlaudio/Makefile52
-rw-r--r--emulators/mupen64-sdlaudio/distinfo2
-rw-r--r--emulators/mupen64-sdlaudio/files/patch-Makefile18
-rw-r--r--emulators/mupen64-sdlaudio/pkg-descr15
-rw-r--r--emulators/mupen64-sdlaudio/pkg-message9
5 files changed, 96 insertions, 0 deletions
diff --git a/emulators/mupen64-sdlaudio/Makefile b/emulators/mupen64-sdlaudio/Makefile
new file mode 100644
index 000000000000..848f46b282b1
--- /dev/null
+++ b/emulators/mupen64-sdlaudio/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: mupen64-sdlaudio
+# Date created: 12.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 1.2
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PKGNAMESUFFIX= -sdlaudio
+DISTNAME= jttl_sound-${PORTVERSION}
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= JttL's SDL audio plugin for Mupen64
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GNOME= gtk12
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= jttl_audio
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_FILES+= share/mupen64/jttl_audio.conf
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+ ${INSTALL_DATA} ${WRKSRC}/${PLUGIN_NAME}.conf \
+ ${PREFIX}/share/mupen64/${PLUGIN_NAME}.conf
+
+.include <bsd.port.pre.mk>
+
+CFLAGS+= `${SDL_CONFIG} --cflags`
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -shared -Wl,-Bsymbolic `${GTK_CONFIG} --libs` -lm
+LDFLAGS+= `${SDL_CONFIG} --libs` -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CC}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-sdlaudio/distinfo b/emulators/mupen64-sdlaudio/distinfo
new file mode 100644
index 000000000000..b4b616a904f1
--- /dev/null
+++ b/emulators/mupen64-sdlaudio/distinfo
@@ -0,0 +1,2 @@
+MD5 (jttl_sound-1.2.tar.bz2) = 7bb104cf6ca94c0e761027eb9895fcbe
+SIZE (jttl_sound-1.2.tar.bz2) = 10015
diff --git a/emulators/mupen64-sdlaudio/files/patch-Makefile b/emulators/mupen64-sdlaudio/files/patch-Makefile
new file mode 100644
index 000000000000..eaf2a4ef8b6e
--- /dev/null
+++ b/emulators/mupen64-sdlaudio/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Sun Mar 28 20:09:45 2004
++++ Makefile Thu Aug 12 15:25:07 2004
+@@ -1,11 +1,11 @@
+-CC = gcc
++#CC = gcc
+ #CFLAGS = -g -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags` -lm `sdl-config --libs`
+-CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags`
++#CFLAGS = -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall `sdl-config --cflags`
+
+ #CFLAGS = -g -O3 -fomit-frame-pointer -funroll-loops -ffast-math -mcpu=athlon `gtk-config --cflags` -DUSE_GTK -Wall
+
+-LD = gcc
+-LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread -lm `sdl-config --libs`
++#LD = gcc
++#LDFLAGS = -shared -Wl,-Bsymbolic `gtk-config --libs` -lpthread -lm `sdl-config --libs`
+
+ OBJECTS = main.o
+
diff --git a/emulators/mupen64-sdlaudio/pkg-descr b/emulators/mupen64-sdlaudio/pkg-descr
new file mode 100644
index 000000000000..8522e9606191
--- /dev/null
+++ b/emulators/mupen64-sdlaudio/pkg-descr
@@ -0,0 +1,15 @@
+JttL SDL sound plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-sdlaudio/pkg-message b/emulators/mupen64-sdlaudio/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-sdlaudio/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------