aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mupen64/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-10-12 13:08:52 +0800
committerdinoex <dinoex@FreeBSD.org>2004-10-12 13:08:52 +0800
commitb96a5b71b28f36cf43c50fb602aec95bb48b6072 (patch)
treebc676e68f6461f556fee207dfa13faee58ec7b6e /emulators/mupen64/Makefile
parent9b778027671703b3dd9b39f626e19eb3eac630fe (diff)
downloadfreebsd-ports-gnome-b96a5b71b28f36cf43c50fb602aec95bb48b6072.tar.gz
freebsd-ports-gnome-b96a5b71b28f36cf43c50fb602aec95bb48b6072.tar.zst
freebsd-ports-gnome-b96a5b71b28f36cf43c50fb602aec95bb48b6072.zip
Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
on/for Linux originally but has already been ported successfully to other operating systems. The program can easily be ported to all operating systems supported by the SDL library. In its current state, the emulator is highly compatible and uses a plugin system. With the correct plugins ("correct" can be computer dependent), it can achieve nearly perfect graphics and sound in many games. WWW: http://mupen64.emulation64.com/ PR: 71895 Submitted by: Travis Poppe
Diffstat (limited to 'emulators/mupen64/Makefile')
-rw-r--r--emulators/mupen64/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/emulators/mupen64/Makefile b/emulators/mupen64/Makefile
new file mode 100644
index 000000000000..68bbc22cca98
--- /dev/null
+++ b/emulators/mupen64/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mupen64
+# Date created: 17.Sep 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.4
+CATEGORIES+= emulators
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Mupen64 is a Nintendo 64 emulator with plugins
+
+RUN_DEPENDS+= ${LOCALBASE}/bin/mupen64:${PORTSDIR}/${PKGCATEGORY}/mupen64-base
+RUN_DEPENDS+= ${PLUGINDIR}/dummyaudio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-dummyaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_audio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sound
+RUN_DEPENDS+= ${PLUGINDIR}/jttl_audio.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sdlaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_input.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-input
+RUN_DEPENDS+= ${PLUGINDIR}/blight_input.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-sdlinput
+RUN_DEPENDS+= ${PLUGINDIR}/ricedaedalus.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-rice
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_hle_rsp_azimer.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-rsp
+RUN_DEPENDS+= ${PLUGINDIR}/Glide64.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-glide
+RUN_DEPENDS+= ${PLUGINDIR}/glN64-0.4.1.so:${PORTSDIR}/${PKGCATEGORY}/mupen64-gln64
+
+NO_MTREE= yes
+NO_BUILD= yes
+
+do-install: # empty
+
+PLUGINDIR= ${LOCALBASE}/share/mupen64/plugins
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>