aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/mupen64plus-video-rice
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2010-12-17 13:47:55 +0800
committeracm <acm@FreeBSD.org>2010-12-17 13:47:55 +0800
commit82103ee6aacc3dd9be5804f9c61dd9ff46a4342e (patch)
tree606b063cba7c28d8bbeb0aa946fd0456e81d8fe5 /emulators/mupen64plus-video-rice
parente16092d2ecf36a9d4aedd3502fa3830131d1b73c (diff)
downloadfreebsd-ports-gnome-82103ee6aacc3dd9be5804f9c61dd9ff46a4342e.tar.gz
freebsd-ports-gnome-82103ee6aacc3dd9be5804f9c61dd9ff46a4342e.tar.zst
freebsd-ports-gnome-82103ee6aacc3dd9be5804f9c61dd9ff46a4342e.zip
- Fix build on i386
- Install plugins to ${LOCALBASE}/lib/mupen64plus directory. This is default directory used by emulator - Bump PORTREVISION Reported by: David Demelier <demelier.david@ at gmail.com>
Diffstat (limited to 'emulators/mupen64plus-video-rice')
-rw-r--r--emulators/mupen64plus-video-rice/Makefile2
-rw-r--r--emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile14
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/mupen64plus-video-rice/Makefile b/emulators/mupen64plus-video-rice/Makefile
index 30c3a277b005..5805644e3e01 100644
--- a/emulators/mupen64plus-video-rice/Makefile
+++ b/emulators/mupen64plus-video-rice/Makefile
@@ -5,6 +5,8 @@
# $FreeBSD$
#
+PORTREVISION= 1
+
PKGNAMESUFFIX= -video-rice
COMMENT= The rice graphics plugin for Mupen64plus
diff --git a/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile b/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile
new file mode 100644
index 000000000000..942bcf807051
--- /dev/null
+++ b/emulators/mupen64plus-video-rice/files/patch-source_mupen64plus-video-rice_projects_unix_Makefile
@@ -0,0 +1,14 @@
+--- source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:32:33.000000000 -0500
++++ source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:34:09.000000000 -0500
+@@ -111,6 +111,11 @@
+ ifeq ($(OS),FREEBSD)
+ LDFLAGS += -lGL $(shell pkg-config --libs libpng)
+ CFLAGS += $(shell pkg-config --cflags libpng)
++ ifeq ($(CPU), X86)
++ ifeq ($(ARCH_DETECTED), 32BITS)
++ CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer
++ endif
++ endif
+ endif
+ ifeq ($(OS), LINUX)
+ LDFLAGS += -ldl -lGL