aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/pearpc
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-04-16 22:10:33 +0800
committernovel <novel@FreeBSD.org>2006-04-16 22:10:33 +0800
commit1bcd5c299d406a7fb2c602500bdc1571ba31b918 (patch)
tree8832513bb65939cb4ab763c0e0cc0753a3235625 /emulators/pearpc
parent98bd7c0294e2207b62ab7fd393b3350050e2fa2a (diff)
downloadfreebsd-ports-gnome-1bcd5c299d406a7fb2c602500bdc1571ba31b918.tar.gz
freebsd-ports-gnome-1bcd5c299d406a7fb2c602500bdc1571ba31b918.tar.zst
freebsd-ports-gnome-1bcd5c299d406a7fb2c602500bdc1571ba31b918.zip
- Fix build on -CURRENT
- Pet portlint Reported by: pointyhat via kris
Diffstat (limited to 'emulators/pearpc')
-rw-r--r--emulators/pearpc/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 512c51e5ac72..e2ae8774befa 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= novel@FreeBSD.org
COMMENT= PowerPC emulator
USE_XLIB= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -58,7 +57,7 @@ CONFIGURE_ARGS+= --disable-debug
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
-BROKEN= "Internal compiler error on ia64"
+BROKEN= Internal compiler error on ia64
.endif
# jitc_x86 is avaible only on x86
@@ -76,7 +75,7 @@ CONFIGURE_ARGS+= --enable-cpu=generic
.if ${OSVERSION} < 503001
#USE_GCC= 3.4
#CFLAGS+= -DFREEBSD_MB_SUPPORT
-BROKEN= "Missing truncf()"
+BROKEN= Missing truncf()
.endif
pre-everything::
@@ -89,6 +88,11 @@ pre-everything::
post-extract:
@${REINPLACE_CMD} -e 's|-g -O2||;s|-O2||' ${WRKSRC}/configure
+pre-configure:
+.if ${OSVERSION} > 700000
+ @${REINPLACE_CMD} -e 's|clock_settime\ ()|foobar()|' ${WRKSRC}/configure
+.endif
+
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile