aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2014-11-24 05:43:52 +0800
committernox <nox@FreeBSD.org>2014-11-24 05:43:52 +0800
commit4ba3358508d0f1e0a897cd450da0251c7731de65 (patch)
tree2296a3f7d5cfafa33b05da311b0daa75b851b468 /emulators/qemu-devel
parentfb9e0d0a3ea769c9481c7cecd44de9ccc41cd40f (diff)
downloadfreebsd-ports-gnome-4ba3358508d0f1e0a897cd450da0251c7731de65.tar.gz
freebsd-ports-gnome-4ba3358508d0f1e0a897cd450da0251c7731de65.tar.zst
freebsd-ports-gnome-4ba3358508d0f1e0a897cd450da0251c7731de65.zip
- bsd-user: Convert signal number for thr_kill() to host signum.
- Bump PORTREVISION. Submitted by: sson Obtained from: https://github.com/seanbruno/qemu-bsd-user/commit/cab0d36ffd4e70b1879dc2cf860c975a7965afc3
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile3
-rw-r--r--emulators/qemu-devel/files/extra-patch-cab0d36ffd4e70b1879dc2cf860c975a7965afc329
2 files changed, 31 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 135fd582798a..83fd92b8f59f 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.0.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -97,6 +97,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-72f0a64c7dd7be796dc2d8f2b0dab340309800e2
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-9ed0e07e2e07791858339874eb4d20daca858c8a
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-a8dc4de7f73bc6f8363c0fc81c4c6e53733c444b
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-freebsd-os-socket.h
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cab0d36ffd4e70b1879dc2cf860c975a7965afc3
.endif
CONFIGURE_ARGS+= --localstatedir=/var
diff --git a/emulators/qemu-devel/files/extra-patch-cab0d36ffd4e70b1879dc2cf860c975a7965afc3 b/emulators/qemu-devel/files/extra-patch-cab0d36ffd4e70b1879dc2cf860c975a7965afc3
new file mode 100644
index 000000000000..166f97b4b53d
--- /dev/null
+++ b/emulators/qemu-devel/files/extra-patch-cab0d36ffd4e70b1879dc2cf860c975a7965afc3
@@ -0,0 +1,29 @@
+From cab0d36ffd4e70b1879dc2cf860c975a7965afc3 Mon Sep 17 00:00:00 2001
+From: Stacey Son <sson@FreeBSD.org>
+Date: Sat, 22 Nov 2014 19:59:32 +0000
+Subject: [PATCH] Convert signal number for thr_kill() to host signum.
+
+---
+ bsd-user/freebsd/os-thread.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bsd-user/freebsd/os-thread.h b/bsd-user/freebsd/os-thread.h
+index eef58fb..a41fde5 100644
+--- a/bsd-user/freebsd/os-thread.h
++++ b/bsd-user/freebsd/os-thread.h
+@@ -85,13 +85,13 @@ static abi_long do_freebsd_thr_exit(CPUArchState *cpu_env, abi_ulong tid_addr)
+ static abi_long do_freebsd_thr_kill(long id, int sig)
+ {
+
+- return get_errno(thr_kill(id, sig));
++ return get_errno(thr_kill(id, target_to_host_signal(sig)));
+ }
+
+ static abi_long do_freebsd_thr_kill2(pid_t pid, long id, int sig)
+ {
+
+- return get_errno(thr_kill2(pid, id, sig));
++ return get_errno(thr_kill2(pid, id, target_to_host_signal(sig)));
+ }
+
+ static abi_long do_freebsd_thr_suspend(abi_ulong target_ts)