aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2010-05-31 03:22:32 +0800
committernox <nox@FreeBSD.org>2010-05-31 03:22:32 +0800
commit30469a2bf05ea40c7dcecfda6422c243f96d1e3e (patch)
tree878005ae3ed85d2a2a87ca843995e019f8256930 /emulators/qemu
parentbbca608da13f2231f6983fc715109ab25584f5f3 (diff)
downloadfreebsd-ports-gnome-30469a2bf05ea40c7dcecfda6422c243f96d1e3e.tar.gz
freebsd-ports-gnome-30469a2bf05ea40c7dcecfda6422c243f96d1e3e.tar.zst
freebsd-ports-gnome-30469a2bf05ea40c7dcecfda6422c243f96d1e3e.zip
- Avoid using mmap MAP_ANON with a non-zero offset. [1]
- Bump PORTREVISION. PR: kern/71258 [1]
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile2
-rw-r--r--emulators/qemu/files/patch-osdep.c9
2 files changed, 9 insertions, 2 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index d45f44cd59d4..ae7bb243c0cd 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.11.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://bellard.org/qemu/
diff --git a/emulators/qemu/files/patch-osdep.c b/emulators/qemu/files/patch-osdep.c
index 984c63bdbbcb..a1b7cadcb08a 100644
--- a/emulators/qemu/files/patch-osdep.c
+++ b/emulators/qemu/files/patch-osdep.c
@@ -1,5 +1,5 @@
Index: qemu/osdep.c
-@@ -179,7 +179,9 @@
+@@ -179,13 +179,15 @@ static void *kqemu_vmalloc(size_t size)
}
unlink(phys_ram_file);
}
@@ -9,3 +9,10 @@ Index: qemu/osdep.c
ftruncate(phys_ram_fd, phys_ram_size + size);
#endif /* !(__OpenBSD__ || __FreeBSD__ || __DragonFly__) */
ptr = mmap(NULL,
+ size,
+ PROT_WRITE | PROT_READ, map_anon | MAP_SHARED,
+- phys_ram_fd, phys_ram_size);
++ phys_ram_fd, map_anon ? 0 : phys_ram_size);
+ if (ptr == MAP_FAILED) {
+ fprintf(stderr, "Could not map physical memory\n");
+ exit(1);