aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/qemu
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2006-12-26 03:49:52 +0800
committernox <nox@FreeBSD.org>2006-12-26 03:49:52 +0800
commita6b726774c1b5b9fa15bb0f469db5ec48952eb83 (patch)
tree89ea7a352f5e2e8a090d221337b86a466e1f6d97 /emulators/qemu
parentb26d8795823d5cffc07cdbe3d7fb2b78369f0804 (diff)
downloadfreebsd-ports-gnome-a6b726774c1b5b9fa15bb0f469db5ec48952eb83.tar.gz
freebsd-ports-gnome-a6b726774c1b5b9fa15bb0f469db5ec48952eb83.tar.zst
freebsd-ports-gnome-a6b726774c1b5b9fa15bb0f469db5ec48952eb83.zip
update qemu to 20061225 snapshot:
- Enable TCP_NODELAY, by Daniel Jacobowitz. [speeding up slirp] - Run monitor over unix domain sockets, by Anthony Liguori. - Unix domain socket support for VNC, by Anthony Liguori. - Daemonize option, by Anthony Liguori. - SCSI emulation improvements, by Chuck Brazie. [adding scsi disk/cdrom emulation to i386/amd64 guests using new -disk syntax - quoting /usr/local/share/doc/qemu/qemu-doc.html: "-disk scsi,img=file[,sdx=a..g][,type=disk|cdrom][,id=n]" Use file as the SCSI disk/CD-ROM image. The defaults are: sdx=a,type= disk,id='auto assign' doing a quick test with a FreeBSD guest I was able to mount and look at a ufs partition; doesn't seem to quite work with (some?) linux guests yet tho, will post about this on the qemu list...] - and a few bug fixes. Approved by: miwi (mentor)
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile4
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/patch-bg25
-rw-r--r--emulators/qemu/files/patch-block-raw.c13
-rw-r--r--emulators/qemu/files/patch-vl.c2
5 files changed, 24 insertions, 26 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index ad3c412abc67..dd567cfe04ee 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.8.2s.20061216
+PORTVERSION= 0.8.2s.20061225
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.qemu.org/:release \
http://www.volny.cz/xnavara/qemu/:snapshot \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
-DISTNAME= ${PORTNAME}-snapshot-2006-12-16_05
+DISTNAME= ${PORTNAME}-snapshot-2006-12-25_05
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index a31990655ffc..bf414272147f 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,6 +1,6 @@
-MD5 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 95be2bf3a0a76506bef0d71de025014f
-SHA256 (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1e431b37ce64ba1c982e620eb2f89bc653f891fbf6a99edc28b27726eb92ac8d
-SIZE (qemu/qemu-snapshot-2006-12-16_05.tar.bz2) = 1502556
+MD5 (qemu/qemu-snapshot-2006-12-25_05.tar.bz2) = 2d1b1ab8d36467e5d4b6b382516273b8
+SHA256 (qemu/qemu-snapshot-2006-12-25_05.tar.bz2) = 98c2f8a4f629b59d40ad09a168dc546927a3c70ea14a8d35e82456cfd9e726d2
+SIZE (qemu/qemu-snapshot-2006-12-25_05.tar.bz2) = 1507659
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu/files/patch-bg b/emulators/qemu/files/patch-bg
index 57a9ef32df97..52ac15628020 100644
--- a/emulators/qemu/files/patch-bg
+++ b/emulators/qemu/files/patch-bg
@@ -4,22 +4,21 @@ Index: qemu/Makefile.target
#########################################################
-DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-+DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD=\"${LOCALBASE}/sbin/smbd\"
++DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\"
LIBS+=-lm
ifndef CONFIG_USER_ONLY
LIBS+=-lz
Index: qemu/vl.c
-@@ -1560,8 +1560,13 @@
- fclose(f);
- atexit(smb_exit);
+@@ -89,10 +89,12 @@
+ #include "exec-all.h"
-+#ifdef __FreeBSD__
-+ snprintf(smb_cmdline, sizeof(smb_cmdline), SMBD " -s %s",
-+ smb_conf);
-+#else
- snprintf(smb_cmdline, sizeof(smb_cmdline), "/usr/sbin/smbd -s %s",
- smb_conf);
+ #define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
++#ifndef SMBD_COMMAND
+ #ifdef __sun__
+ #define SMBD_COMMAND "/usr/sfw/sbin/smbd"
+ #else
+ #define SMBD_COMMAND "/usr/sbin/smbd"
+#endif
-
- slirp_add_exec(0, smb_cmdline, 4, 139);
- }
+ #endif
+
+ //#define DEBUG_UNUSED_IOPORT
diff --git a/emulators/qemu/files/patch-block-raw.c b/emulators/qemu/files/patch-block-raw.c
index e4690530bf43..de3e8b712f0d 100644
--- a/emulators/qemu/files/patch-block-raw.c
+++ b/emulators/qemu/files/patch-block-raw.c
@@ -1,15 +1,14 @@
Index: qemu/block-raw.c
-@@ -51,6 +51,9 @@
+@@ -51,7 +51,7 @@
#include <linux/cdrom.h>
#include <linux/fd.h>
#endif
+-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) && __FreeBSD__ > 4
-+#include <sys/disk.h>
-+#endif
-
- //#define DEBUG_FLOPPY
+ #include <sys/disk.h>
+ #endif
-@@ -164,9 +164,20 @@
+@@ -167,9 +167,20 @@
static int aio_sig_num = SIGUSR2;
static RawAIOCB *first_aio; /* AIO issued */
static int aio_initialized = 0;
@@ -30,7 +29,7 @@ Index: qemu/block-raw.c
#ifndef QEMU_TOOL
CPUState *env = cpu_single_env;
if (env) {
-@@ -281,9 +292,17 @@
+@@ -284,9 +295,17 @@
if (qemu_bh_poll())
return;
#endif
diff --git a/emulators/qemu/files/patch-vl.c b/emulators/qemu/files/patch-vl.c
index 53d8063f7a31..437dafe471b2 100644
--- a/emulators/qemu/files/patch-vl.c
+++ b/emulators/qemu/files/patch-vl.c
@@ -5,7 +5,7 @@ Index: qemu/vl.c
-#if defined(__linux__)
+#if defined(__linux__) || defined(__FreeBSD__)
- CharDriverState *qemu_chr_open_pty(void)
+ static CharDriverState *qemu_chr_open_pty(void)
{
struct termios tty;
@@ -1665,6 +1665,7 @@