aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/rpcs3
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /emulators/rpcs3
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'emulators/rpcs3')
-rw-r--r--emulators/rpcs3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 17cd12e9d198..63acd0820b31 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -36,9 +36,9 @@ GH_TUPLE= RPCS3:hidapi:hidapi-0.8.0-rc1-25-gca39ce8:hidapi/3rdparty/hidapi \
zeux:pugixml:v1.9:pugixml/3rdparty/pugixml
USES= cmake:outsource compiler:c++14-lang iconv:wchar_t localbase:ldflags \
- openal:soft pkgconfig
+ openal:soft pkgconfig qt:5
USE_GL= gl glew
-USE_QT5= qmake_build buildtools_build core dbus gui network widgets qml
+USE_QT= qmake_build buildtools_build core dbus gui network widgets qml
USE_XORG= x11
CMAKE_ON= CMAKE_SKIP_RPATH USE_SYSTEM_FFMPEG USE_SYSTEM_LIBPNG
CMAKE_OFF= USE_NATIVE_INSTRUCTIONS