aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/rtc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-24 22:51:20 +0800
committerknu <knu@FreeBSD.org>2000-08-24 22:51:20 +0800
commit5aa4cac60f3d2699b137e74b58902ca7333c2222 (patch)
treecdcaf3116cb2f1b3b1af8ceb48b3ca3abec338c1 /emulators/rtc
parent5d3459372748f80f49a14320379a5063d70d3bcd (diff)
downloadfreebsd-ports-gnome-5aa4cac60f3d2699b137e74b58902ca7333c2222.tar.gz
freebsd-ports-gnome-5aa4cac60f3d2699b137e74b58902ca7333c2222.tar.zst
freebsd-ports-gnome-5aa4cac60f3d2699b137e74b58902ca7333c2222.zip
Chase the recent moving of linux_ioctl.h.
PR: ports/20818 Submitted by: Sean-Paul Rees <sean@dreamfire.net>
Diffstat (limited to 'emulators/rtc')
-rw-r--r--emulators/rtc/Makefile8
-rw-r--r--emulators/rtc/files/rtc_linux.c2
2 files changed, 8 insertions, 2 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index 8d3ab9b85f36..0e3ca74c995d 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rtc
-PORTVERSION= 2000.05.05
+PORTVERSION= 2000.08.24
CATEGORIES= emulators linux
MASTER_SITES= # none
DISTFILES= # none
@@ -44,6 +44,12 @@ do-extract:
${FILESDIR}/${STARTUP} > ${WRKDIR}/${STARTUP}
@cd ${FILESDIR} && ${CP} Makefile *.[ch] ${WRKSRC}/
+post-patch:
+.if !exists(/sys/compat/linux/linux_ioctl.h)
+ ${PERL} -i -pe 's,compat(/linux/linux_ioctl\.h),i386$$1,' \
+ ${WRKSRC}/rtc_linux.c
+.endif
+
pre-install:
${MKDIR} ${KMODDIR}
${MKDIR} ${DEVDIR}
diff --git a/emulators/rtc/files/rtc_linux.c b/emulators/rtc/files/rtc_linux.c
index 2eb04a433890..df112d87212d 100644
--- a/emulators/rtc/files/rtc_linux.c
+++ b/emulators/rtc/files/rtc_linux.c
@@ -33,7 +33,7 @@
#include <i386/linux/linux.h>
#include <i386/linux/linux_proto.h>
-#include <i386/linux/linux_ioctl.h>
+#include <compat/linux/linux_ioctl.h>
#include "rtc.h"