aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/sim
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-01-26 17:32:57 +0800
committergarga <garga@FreeBSD.org>2006-01-26 17:32:57 +0800
commitc9cf87ed7be3489ddf056774207b0848974273f0 (patch)
tree02d41b9620b07583f1cf9db29740e87a8f859316 /emulators/sim
parent5a3c9d7bc9f308853f9615fb7680b70a9d0687e0 (diff)
downloadfreebsd-ports-gnome-c9cf87ed7be3489ddf056774207b0848974273f0.tar.gz
freebsd-ports-gnome-c9cf87ed7be3489ddf056774207b0848974273f0.tar.zst
freebsd-ports-gnome-c9cf87ed7be3489ddf056774207b0848974273f0.zip
- Update to V3.5-2
- Add OPTIONS for network support - Clean-up Makefile - Update descriptions to cover new support PR: ports/92300 Submitted by: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net> Approved by: maintainer
Diffstat (limited to 'emulators/sim')
-rw-r--r--emulators/sim/Makefile43
-rw-r--r--emulators/sim/distinfo6
-rw-r--r--emulators/sim/pkg-descr18
3 files changed, 41 insertions, 26 deletions
diff --git a/emulators/sim/Makefile b/emulators/sim/Makefile
index 9a3bc513851d..11b2b8d12744 100644
--- a/emulators/sim/Makefile
+++ b/emulators/sim/Makefile
@@ -6,48 +6,55 @@
#
PORTNAME= sim
-PORTVERSION= 3.5.1
+PORTVERSION= 3.5.2
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
-DISTNAME= ${PORTNAME}hv35-1
+DISTNAME= ${PORTNAME}hv35-2
MAINTAINER= mmendez@gmail.com
-COMMENT= PDP-8, PDP-11, PDP-1, other 18b PDP, Nova, and IBM 1401 simulators
+COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
USE_ZIP= yes
+EXTRACT_BEFORE_ARGS= -qoa
USE_GMAKE= yes
-RESTRICTED= "Non-commercial use only"
+RESTRICTED= Non-commercial use only
MAKEFILE= makefile
NO_WRKSUBDIR= yes
SHELL=${SH}
-BIN_FILES= pdp1 pdp4 pdp7 pdp8 pdp9 \
- pdp15 pdp11 pdp10 vax nova \
- eclipse h316 hp2100 i1401 \
- i1620 s3 altair altairz80 \
- gri ibm1130 id16 id32 sds lgp
+OPTIONS= NETWORK "Enable Sim_Ether module (and ports libpcap)" on
+
+BIN_FILES= altair h316 ibm1130 nova pdp15 pdp9 vax780 \
+ altairz80 hp2100 id16 pdp1 pdp4 s3 \
+ eclipse i1401 id32 pdp10 pdp7 sds \
+ gri i1620 lgp pdp11 pdp8 vax
PORTDOCS= 0readme_35.txt simh_doc.txt simh_swre.txt \
0readme_ethernet.txt simh_faq.txt
-PLIST_FILES= ${BIN_FILES:S/^/bin\//g} share/sim/ka655.bin share/sim/ka655x.bin
-PLIST_DIRS= share/sim
+PLIST_FILES= ${BIN_FILES:S/^/bin\//g} ${DATADIR}/ka655x.bin
+PLIST_DIRS= ${DATADIR}
+
+.include <bsd.port.pre.mk>
+
+# XXX How do we know that libpcap.a is really the correct >0.9.x version?!
+.if defined (WITH_NETWORK)
+RUN_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+BUILD_DEPENDS= ${RUN_DEPENDS}
+MAKE_ENV= USE_NETWORK=1
+.endif
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
- @for i in ${WRKSRC}/makefile `${FIND} ${WRKSRC} -name "*.[hc]"`; do \
- ${CAT} $$i | ${TR} -d '\r' > $$i.new; \
- ${MV} $$i.new $$i; \
- done
do-install:
.for file in ${BIN_FILES}
${INSTALL_PROGRAM} ${WRKDIR}/BIN/${file} ${PREFIX}/bin
.endfor
- @${MKDIR} ${PREFIX}/share/sim
- ${INSTALL_DATA} ${WRKDIR}/VAX/ka655*.bin ${PREFIX}/share/sim
+ @${MKDIR} ${PREFIX}/${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/VAX/ka655x.bin ${PREFIX}/${DATADIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -59,4 +66,4 @@ do-install:
post-install:
@${CAT} pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/sim/distinfo b/emulators/sim/distinfo
index c914afcf067c..a022b298d967 100644
--- a/emulators/sim/distinfo
+++ b/emulators/sim/distinfo
@@ -1,3 +1,3 @@
-MD5 (simhv35-1.zip) = ead371c802d6a7feba99031bf55895fe
-SHA256 (simhv35-1.zip) = 5828c754cc46f3f9e7cdf5637e5e348684c4c22265b71ef3904fd5321f67a20c
-SIZE (simhv35-1.zip) = 2236017
+MD5 (simhv35-2.zip) = e3d2a168f2da62e10e0013f1f9111d82
+SHA256 (simhv35-2.zip) = 12c6e6290b599b7f131027a533ee12add8d68735128805e012309db46f2ab9fb
+SIZE (simhv35-2.zip) = 2259795
diff --git a/emulators/sim/pkg-descr b/emulators/sim/pkg-descr
index fc904651ca4a..039169280298 100644
--- a/emulators/sim/pkg-descr
+++ b/emulators/sim/pkg-descr
@@ -1,9 +1,17 @@
-PDP-8, PDP-11, PDP-1, other 18b PDP, Nova, and IBM 1401 simulators.
+SIMH is a higly portable, multi-system simulator.
-The simulators have been tested on VAX VMS, Alpha VMS, Alpha UNIX, Intel
-FreeBSD and Intel LINUX; a port to Windows 95 and Windows NT is in progress
-but lacks terminal emulation code. Porting to other environments will
-require changes to the operating system dependent code in scp_tty.c.
+SIMH implements simulators for:
+ - Data General Nova, Eclipse
+ - Digital Equipment Corporation PDP-1, PDP-4, PDP-7, PDP-8, PDP-9,
+ PDP-10, PDP-11, PDP-15, VAX
+ - GRI Corporation GRI-909
+ - IBM 1401, 1620, 1130, System 3
+ - Interdata (Perkin-Elmer) 16b and 32b systems
+ - Hewlett-Packard 2116, 2100, 21MX
+ - Honeywell H316/H516
+ - MITS Altair 8800, with both 8080 and Z80
+ - Royal-Mcbee LGP-30, LGP-21
+ - Scientific Data Systems SDS 940
These simulators are capable of running the Unix V5, V6 and V7 binaries
licenced for non-commercial use by SCO. See ${WRKDIR}/simh_doc.txt for