aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/simh
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-07-02 11:08:57 +0800
committerlinimon <linimon@FreeBSD.org>2018-07-02 11:08:57 +0800
commita3584ef01f826922b53df0d4006400529d28375f (patch)
treed31d8117224f04de3bb6c2c2d79ee00d7ad8ff95 /emulators/simh
parent46dc4a6b26b6fefae27b4f323ffe5b176d4aaf5d (diff)
downloadfreebsd-ports-gnome-a3584ef01f826922b53df0d4006400529d28375f.tar.gz
freebsd-ports-gnome-a3584ef01f826922b53df0d4006400529d28375f.tar.zst
freebsd-ports-gnome-a3584ef01f826922b53df0d4006400529d28375f.zip
Attempt to see if the build can be fixed on non-clang-based archs.
Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'emulators/simh')
-rw-r--r--emulators/simh/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 6f735ad010bc..03070f68f9e4 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -17,13 +17,11 @@ COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
LICENSE= BSD3CLAUSE
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option "-Wno-logical-op-parentheses"
-
NO_WRKSUBDIR= yes
USES= gmake dos2unix zip
DOS2UNIX_GLOB= *.c *.h *.txt *.mak *.ini makefile
-CFLAGS+= -Wno-format-extra-args -Wno-comment -Wno-logical-op-parentheses -Wno-bitwise-op-parentheses -Wno-shift-negative-value
+CFLAGS+= -Wno-format-extra-args -Wno-comment
MAKE_ENV= GCC="${CC}" CFLAGS_O="${CFLAGS}" USE_NETWORK=1
MAKEFILE= makefile
@@ -34,6 +32,12 @@ PORTDOCS= ${READMES} pdf/*
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == i386
+CFLAGS+= -Wno-logical-op-parentheses -Wno-bitwise-op-parentheses -Wno-shift-negative-value
+.endif
+
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
@@ -61,4 +65,4 @@ do-install-DOCS-on:
(cd ${WRKSRC} && ${INSTALL_DATA} ${READMES} ${STAGEDIR}${DOCSDIR})
(cd ${WRKSRC} && ${COPYTREE_SHARE} pdf ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>