aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/skyeye
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-09-03 11:36:41 +0800
committervanilla <vanilla@FreeBSD.org>2014-09-03 11:36:41 +0800
commit235417788aa5dfc98abede158b270a03da1c63ec (patch)
treed639dbb956a8b02d40355a5b6a16980a2e4944fa /emulators/skyeye
parent4bd6d29c8bf50f45b070f311c606a64bdf049116 (diff)
downloadfreebsd-ports-gnome-235417788aa5dfc98abede158b270a03da1c63ec.tar.gz
freebsd-ports-gnome-235417788aa5dfc98abede158b270a03da1c63ec.tar.zst
freebsd-ports-gnome-235417788aa5dfc98abede158b270a03da1c63ec.zip
Upgrade to 1.2.5.
PR: ports/193155 Submitted by: Ports Fury.
Diffstat (limited to 'emulators/skyeye')
-rw-r--r--emulators/skyeye/Makefile30
-rw-r--r--emulators/skyeye/distinfo4
-rw-r--r--emulators/skyeye/files/patch-Makefile64
-rw-r--r--emulators/skyeye/files/patch-arch__bfin__common__bfin-dis.c65
-rw-r--r--emulators/skyeye/files/patch-arch_coldfire_Makefile18
-rw-r--r--emulators/skyeye/files/patch-device__nandflash__nadflash_smallblock.c11
-rw-r--r--emulators/skyeye/files/patch-utils__main__skyeye.c10
-rw-r--r--emulators/skyeye/files/patch-utils__profile__symbol.h10
-rw-r--r--emulators/skyeye/pkg-descr14
-rw-r--r--emulators/skyeye/pkg-plist1
10 files changed, 115 insertions, 112 deletions
diff --git a/emulators/skyeye/Makefile b/emulators/skyeye/Makefile
index bfe5fce3b0d5..5f58b5bdbc71 100644
--- a/emulators/skyeye/Makefile
+++ b/emulators/skyeye/Makefile
@@ -2,31 +2,21 @@
# $FreeBSD$
PORTNAME= skyeye
-PORTVERSION= 1.2
-PORTREVISION= 6
-DISTVERSIONPREFIX=v
-DISTVERSIONSUFFIX=_Rel
+PORTVERSION= 1.2.5
+DISTVERSIONSUFFIX= _REL
CATEGORIES= emulators
-MASTER_SITES= http://download.gro.clinux.org/skyeye/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Environment simulates typical ARM-base embedded computer systems
-BUILD_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/gnulibiberty \
- ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd
-RUN_DEPENDS= ${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/gnulibiberty \
- ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd
+LICENSE= GPLv2
-USES= gmake pkgconfig tar:bzip2
-USE_GNOME= gtk20
-WRKSRC= ${WRKDIR}/${PORTNAME}-v1
+USE_BINUTILS= yes
+USE_GCC= any
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_func_working_mktime=yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/skyeye
-ONLY_FOR_ARCHS= i386
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/binary/skyeye ${PREFIX}/bin
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/skyeye/distinfo b/emulators/skyeye/distinfo
index aea33a5680c5..ddc30379fb48 100644
--- a/emulators/skyeye/distinfo
+++ b/emulators/skyeye/distinfo
@@ -1,2 +1,2 @@
-SHA256 (skyeye-v1.2_Rel.tar.bz2) = 4eaa26efe36ba036d3c7cab51466972d1178c1dd6141e430e4e7f4a76eb3f15b
-SIZE (skyeye-v1.2_Rel.tar.bz2) = 428488
+SHA256 (skyeye-1.2.5_REL.tar.gz) = 2eca1ad7f8f11e72e332944c9c41470861c337da3d3ddf535fb0efc610a2a08b
+SIZE (skyeye-1.2.5_REL.tar.gz) = 1069422
diff --git a/emulators/skyeye/files/patch-Makefile b/emulators/skyeye/files/patch-Makefile
deleted file mode 100644
index 5e68c94a567c..000000000000
--- a/emulators/skyeye/files/patch-Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
---- Makefile.orig 2006-12-16 12:12:09.000000000 -0500
-+++ Makefile 2014-07-29 21:02:50.000000000 -0400
-@@ -20,7 +20,7 @@
- # Author Chen Yu <yuchen@tsinghua.edu.cn>
-
-
--prefix = /usr/local
-+prefix = ${PREFIX}
- exec_prefix = ${prefix}
-
- host_alias = i686-pc-cygwin
-@@ -48,14 +48,14 @@
- INSTALL_DATA = ${INSTALL} -m 644
-
- #CC = gcc-3.3
--CC = gcc
-+CC ?= gcc
- #CC = gcc-4.0
- CC_FOR_BUILD = $(CC)
-
- AR = ar
- AR_FLAGS = rc
- RANLIB = ranlib
--MAKEINFO = makeinfo
-+MAKEINFO ?= makeinfo
-
- SUPPORT_ARCH_DEF = -DARM
-
-@@ -85,7 +85,7 @@
- endif
- endif
-
--CFLAGS = -g -O2 -D_FILE_OFFSET_BITS=64 -DSTANDALONE -DDEFAULT_INLINE=0 -DMODET $(EXTRA_CFLAGS) $(SIM_EXTRA_CFLAGS) $(SUPPORT_ARCH_DEF) -I.
-+CFLAGS += -g -fno-strict-aliasing -D_FILE_OFFSET_BITS=64 -DSTANDALONE -DDEFAULT_INLINE=0 -DMODET $(EXTRA_CFLAGS) $(SIM_EXTRA_CFLAGS) $(SUPPORT_ARCH_DEF) -I. -I$(LOCALBASE)/include
-
- ARM_COMMON_PATH= arch/arm/common
- ARM_DBCT_PATH= arch/arm/dbct
-@@ -238,7 +238,7 @@
- rm -f binary/*.o
- rm -f binary/*.a
- rm -f binary/skyeye
-- make -C arch/coldfire clean
-+ $(MAKE) -C arch/coldfire clean
-
- distclean mostlyclean maintainer-clean realclean: clean
- rm -f TAGS tags
-@@ -276,7 +276,7 @@
- CF_COMMON_PATH = arch/coldfire/common/
- COLDFIRE_FLAG = -I arch/coldire/tracer
- binary/libcoldfire.a:$(SIM_CF_OBJS)
-- make -C arch/coldfire
-+ $(MAKE) -C arch/coldfire
- $(AR) $(AR_FLAGS) binary/libcoldfire.a $(SIM_CF_OBJS) $(CF_COMMON_PATH)/*.o $(CF_PATH)/tracer/tracer.o $(CF_PATH)/i_5206/i.o
- $(RANLIB) binary/libcoldfire.a
-
-@@ -285,7 +285,7 @@
- PPC_COMMON_PATH = arch/ppc/common/
- POWERPC_FLAG = -I arch/ppc/common/
- binary/libppc.a:
-- make -C arch/ppc
-+ $(MAKE) -C arch/ppc
- $(AR) $(AR_FLAGS) binary/libppc.a $(PPC_COMMON_PATH)/*.o
- $(RANLIB) binary/ppc.a
-
diff --git a/emulators/skyeye/files/patch-arch__bfin__common__bfin-dis.c b/emulators/skyeye/files/patch-arch__bfin__common__bfin-dis.c
new file mode 100644
index 000000000000..1126e25f7c2e
--- /dev/null
+++ b/emulators/skyeye/files/patch-arch__bfin__common__bfin-dis.c
@@ -0,0 +1,65 @@
+--- arch/bfin/common/bfin-dis.c.orig
++++ arch/bfin/common/bfin-dis.c
+@@ -310,7 +310,7 @@
+ REG_RL7,
+ REG_RH0, REG_RH1, REG_RH2, REG_RH3, REG_RH4, REG_RH5, REG_RH6,
+ REG_RH7,
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_R1_0, REG_R3_2, REG_R5_4, REG_R7_6, REG_P0, REG_P1, REG_P2,
+ REG_P3,
+ REG_P4, REG_P5, REG_SP, REG_FP, REG_A0x, REG_A1x, REG_A0w, REG_A1w,
+@@ -401,7 +401,7 @@
+
+ /* R(0..7) */
+ static enum machine_registers decode_dregs[] = {
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ };
+
+ #define dregs(x) REGNAME(decode_dregs[(x) & 7])
+@@ -497,7 +497,7 @@
+
+ /* dregs pregs */
+ static enum machine_registers decode_dpregs[] = {
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_P0, REG_P1, REG_P2, REG_P3, REG_P4, REG_P5, REG_SP, REG_FP,
+ };
+
+@@ -505,7 +505,7 @@
+
+ /* [dregs pregs] */
+ static enum machine_registers decode_gregs[] = {
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_P0, REG_P1, REG_P2, REG_P3, REG_P4, REG_P5, REG_SP, REG_FP,
+ };
+
+@@ -513,7 +513,7 @@
+
+ /* [dregs pregs (iregs mregs) (bregs lregs)] */
+ static enum machine_registers decode_regs[] = {
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_P0, REG_P1, REG_P2, REG_P3, REG_P4, REG_P5, REG_SP, REG_FP,
+ REG_I0, REG_I1, REG_I2, REG_I3, REG_M0, REG_M1, REG_M2, REG_M3,
+ REG_B0, REG_B1, REG_B2, REG_B3, REG_L0, REG_L1, REG_L2, REG_L3,
+@@ -626,7 +626,7 @@
+
+ /* [dregs pregs (iregs mregs) (bregs lregs) dregs2_sysregs1 open sysregs2 sysregs3] */
+ static enum machine_registers decode_allregs[] = {
+- REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_P0, REG_P1, REG_P2, REG_P3, REG_P4, REG_P5, REG_SP, REG_FP,
+ REG_I0, REG_I1, REG_I2, REG_I3, REG_M0, REG_M1, REG_M2, REG_M3,
+ REG_B0, REG_B1, REG_B2, REG_B3, REG_L0, REG_L1, REG_L2, REG_L3,
+@@ -685,7 +685,7 @@
+ get_allreg (int grp, int reg)
+ {
+ int fullreg = (grp << 3) | reg;
+- /* REG_R0, REG_R1, REG_R2, REG_R3, REG_R4, REG_R5, REG_R6, REG_R7,
++ /* REG_RR0, REG_RR1, REG_RR2, REG_RR3, REG_RR4, REG_RR5, REG_RR6, REG_RR7,
+ REG_P0, REG_P1, REG_P2, REG_P3, REG_P4, REG_P5, REG_SP, REG_FP,
+ REG_I0, REG_I1, REG_I2, REG_I3, REG_M0, REG_M1, REG_M2, REG_M3,
+ REG_B0, REG_B1, REG_B2, REG_B3, REG_L0, REG_L1, REG_L2, REG_L3,
diff --git a/emulators/skyeye/files/patch-arch_coldfire_Makefile b/emulators/skyeye/files/patch-arch_coldfire_Makefile
deleted file mode 100644
index 083c919e1bab..000000000000
--- a/emulators/skyeye/files/patch-arch_coldfire_Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- arch/coldfire/Makefile.orig Sun Aug 27 14:26:21 2006
-+++ arch/coldfire/Makefile Sun Aug 27 14:26:47 2006
-@@ -1,9 +1,9 @@
- all:
-- make -C i_5206/
-- make -C tracer/
-- make -C common/
-+ $(MAKE) -C i_5206/
-+ $(MAKE) -C tracer/
-+ $(MAKE) -C common/
- clean:
-- make -C tracer/ clean
-- make -C i_5206/ clean
-- make -C common/ clean
-+ $(MAKE) -C tracer/ clean
-+ $(MAKE) -C i_5206/ clean
-+ $(MAKE) -C common/ clean
- rm -f tags
diff --git a/emulators/skyeye/files/patch-device__nandflash__nadflash_smallblock.c b/emulators/skyeye/files/patch-device__nandflash__nadflash_smallblock.c
new file mode 100644
index 000000000000..d1aa1d5b3bfb
--- /dev/null
+++ b/emulators/skyeye/files/patch-device__nandflash__nadflash_smallblock.c
@@ -0,0 +1,11 @@
+--- device/nandflash/nandflash_smallblock.c.orig
++++ device/nandflash/nandflash_smallblock.c
+@@ -516,7 +516,7 @@
+ #endif
+ nf->writebuffer=(u8*)malloc(dev->pagedumpsize);
+ //nf->memsize=528*32*4096;
+- if ((nf->fdump= open(dev->dump, FILE_FLAG)) < 0)
++ if ((nf->fdump= open(dev->dump, FILE_FLAG, S_IRUSR | S_IWUSR)) < 0)
+ {
+ free(nf);
+ printf("error open nandflash dump!\n");
diff --git a/emulators/skyeye/files/patch-utils__main__skyeye.c b/emulators/skyeye/files/patch-utils__main__skyeye.c
new file mode 100644
index 000000000000..a6c585b2f5c2
--- /dev/null
+++ b/emulators/skyeye/files/patch-utils__main__skyeye.c
@@ -0,0 +1,10 @@
+--- utils/main/skyeye.c.orig
++++ utils/main/skyeye.c
+@@ -46,6 +46,7 @@
+
+ #include <setjmp.h>
+ #include "code_cov.h"
++#include "symbol.h"
+
+ /**
+ * A global variable , point to the current archtecture
diff --git a/emulators/skyeye/files/patch-utils__profile__symbol.h b/emulators/skyeye/files/patch-utils__profile__symbol.h
new file mode 100644
index 000000000000..2fb82d9c2d53
--- /dev/null
+++ b/emulators/skyeye/files/patch-utils__profile__symbol.h
@@ -0,0 +1,10 @@
+--- utils/profile/symbol.h.orig
++++ utils/profile/symbol.h
+@@ -73,6 +73,7 @@
+ ARMword ARMul_TaskCreate(ARMul_State *state);
+ void ARMul_ReportEnergy(ARMul_State *state, FILE* pf);
+ void ARMul_Consolidate(ARMul_State *state);
++char *get_sym(ARMword address);
+
+ #endif
+ #endif
diff --git a/emulators/skyeye/pkg-descr b/emulators/skyeye/pkg-descr
index c5f6c0568d06..bf95b994304f 100644
--- a/emulators/skyeye/pkg-descr
+++ b/emulators/skyeye/pkg-descr
@@ -1,9 +1,9 @@
-SkyEye is an Open Source Software Project. The goal of SkyEye is to provide an
-integrated simulation environment in Linux and Windows. SkyEye environment
-simulates typical Embedded Computer Systems (Now it supports Atmel AT91 board
-based on ARM7TDMI CPU, board based on ARM720T CPU, board based on StrongARM
-(SA1100/SA1110). You can run some Embedded Operation System such as ARM Linux,
-uClinux, uc/OS-II (ucos-ii) etc in SkyEye, and analyze or debug them at source
-level.
+SkyEye is an Open Source Software Project. The goal of SkyEye is to
+provide an integrated simulation environment in Linux and Windows.
+SkyEye environment simulates typical Embedded Computer Systems (Now it
+supports Atmel AT91 board based on ARM7TDMI CPU, board based on ARM720T
+CPU, board based on StrongARM (SA1100/SA1110). You can run some Embedded
+Operation System such as ARM Linux, uClinux, uc/OS-II (ucos-ii) etc in
+SkyEye, and analyze or debug them at source level.
WWW: http://www.skyeye.org/
diff --git a/emulators/skyeye/pkg-plist b/emulators/skyeye/pkg-plist
deleted file mode 100644
index 9a56c7995065..000000000000
--- a/emulators/skyeye/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/skyeye