aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/stonx
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-01 19:23:57 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-01 19:23:57 +0800
commit481e0f1a7c4727876dff8a5cdb84c60934758d6e (patch)
treef6d97f7a921c2bb38fb666cc03ff933242411f7e /emulators/stonx
parent8bb09d769b53949331365f055c1fb46e6c5b5040 (diff)
downloadfreebsd-ports-gnome-481e0f1a7c4727876dff8a5cdb84c60934758d6e.tar.gz
freebsd-ports-gnome-481e0f1a7c4727876dff8a5cdb84c60934758d6e.tar.zst
freebsd-ports-gnome-481e0f1a7c4727876dff8a5cdb84c60934758d6e.zip
- fix build on FreeBSD 6.x
Diffstat (limited to 'emulators/stonx')
-rw-r--r--emulators/stonx/Makefile5
-rw-r--r--emulators/stonx/files/patch-audio.c11
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
index c160e73e3f2a..91e253327d76 100644
--- a/emulators/stonx/Makefile
+++ b/emulators/stonx/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= mkfontdir:${X_CLIENTS_PORT}
RESTRICTED= "tos.img is copyrighted"
TOSIMG?= tos.img
+#USE_XLIB= yes
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
@@ -87,4 +88,8 @@ IGNORE="Please get a ROM dump from your AtariST and save it as"\
"\"${TOSIMG}\" in \"${DISTDIR}\" manually, and then make install again"
.endif
+.if ${X_WINDOW_SYSTEM:L} == xorg
+BUILD_DEPENDS+= ${X11BASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/stonx/files/patch-audio.c b/emulators/stonx/files/patch-audio.c
new file mode 100644
index 000000000000..28a63044dd47
--- /dev/null
+++ b/emulators/stonx/files/patch-audio.c
@@ -0,0 +1,11 @@
+--- audio.c.orig Mon May 5 03:07:05 1997
++++ audio.c Wed Oct 25 19:33:27 2006
+@@ -36,7 +36,7 @@
+ #include <linux/unistd.h>
+ #endif
+ #else /* FreeBSD? */
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #endif
+ #include <unistd.h>
+ #define LINUX_DEFAULT_FREQ (22050)