aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/tpm-emulator
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-05-18 21:53:45 +0800
committerhrs <hrs@FreeBSD.org>2016-05-18 21:53:45 +0800
commit3ca42eeadd5e889f5f9309f8a44308e658ddb0b9 (patch)
treeda9b2df572c6ff11d9931e782ac0888832e1445c /emulators/tpm-emulator
parent94776214869d5ad65097da218da08d89b367d071 (diff)
downloadfreebsd-ports-gnome-3ca42eeadd5e889f5f9309f8a44308e658ddb0b9.tar.gz
freebsd-ports-gnome-3ca42eeadd5e889f5f9309f8a44308e658ddb0b9.tar.zst
freebsd-ports-gnome-3ca42eeadd5e889f5f9309f8a44308e658ddb0b9.zip
security/trousers:
- Update to 0.3.13. - Remove CONFLICTS with emulators/tpm-emulator. Two separate binaries, sbin/tcsd (for actual TPM device) and sbin/tcsd_emu (for TPM emulator) are now installed. rc.d/tcsd chooses one of them depending on $tcsd_mode. When tcsd_mode="native" (default) it runs sbin/tcsd, and when tcsd_mode="emulator" it runs sbin/tcsd_emu. Note that sbin/tcsd_emu depends on tpmd in emulators/tpm-emulator. - Simplify @sample. emulators/tpm-emulator: - Remove CONFLICTS with security/trousers. - Simplify rc.d/tpmd.
Diffstat (limited to 'emulators/tpm-emulator')
-rw-r--r--emulators/tpm-emulator/Makefile6
-rw-r--r--emulators/tpm-emulator/files/patch-CMakeLists.txt7
-rw-r--r--emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt15
-rw-r--r--emulators/tpm-emulator/files/patch-tpmd-CMakeLists.txt6
-rw-r--r--emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt6
-rw-r--r--emulators/tpm-emulator/files/tpmd.in8
-rw-r--r--emulators/tpm-emulator/pkg-plist8
7 files changed, 31 insertions, 25 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index b8a991b43a43..5c1870085b4f 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -3,23 +3,23 @@
PORTNAME= tpm-emulator
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= emulators security
MASTER_SITES= SF/${PORTNAME}.berlios
DISTNAME= ${PORTNAME:S,-,_,}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= Trusted Platform Module (TPM) emulator
LICENSE= GPLv2
LIB_DEPENDS= libgmp.so:math/gmp
-CONFLICTS= trousers-tddl-[0-9]*
-
USES= cmake:outsource
USE_RC_SUBR= tpmd
CONFIGURE_ENV= PREFIX="${PREFIX}"
CMAKE_ARGS= -DTPM_INCLUDE_DIRS:STRING="${LOCALBASE}/include" \
+ -DTDDL_LIBRARY_DIRS:STRING="${LOCALBASE}/lib/tddl_emu" \
-DTPM_LIBRARY_DIRS:STRING="${LOCALBASE}/lib"
USE_LDCONFIG= yes
USERS= _tss
diff --git a/emulators/tpm-emulator/files/patch-CMakeLists.txt b/emulators/tpm-emulator/files/patch-CMakeLists.txt
index ef820c86c15e..450f95aca2dc 100644
--- a/emulators/tpm-emulator/files/patch-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2010-07-06 06:21:20.000000000 +0900
-+++ CMakeLists.txt 2010-12-15 07:33:54.234887143 +0900
-@@ -36,19 +36,19 @@
+--- CMakeLists.txt.orig 2011-12-20 18:30:06 UTC
++++ CMakeLists.txt
+@@ -36,19 +36,20 @@ set(TPM_DEVICE_NAME "/dev/tpm")
else()
set(TPM_LOG_FILE "/var/log/tpmd.log")
set(TPM_SOCKET_NAME "/var/run/tpm/tpmd_socket:0")
@@ -20,6 +20,7 @@
-include_directories("/opt/local/include")
-link_directories("/opt/local/lib")
+include_directories(${TPM_INCLUDE_DIRS})
++link_directories(${TDDL_LIBRARY_DIRS})
+link_directories(${TPM_LIBRARY_DIRS})
# configure CPack
diff --git a/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt b/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
index a4866364efb9..831069e38908 100644
--- a/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-tddl-CMakeLists.txt
@@ -1,6 +1,6 @@
---- tddl/CMakeLists.txt.orig 2011-12-21 03:30:06.000000000 +0900
-+++ tddl/CMakeLists.txt 2012-10-10 01:01:00.000000000 +0900
-@@ -7,13 +7,13 @@
+--- tddl/CMakeLists.txt.orig 2011-12-20 18:30:06 UTC
++++ tddl/CMakeLists.txt
+@@ -7,16 +7,16 @@ set(tddl_SRCS "tddl.c" "tddl.h")
add_library(tddl SHARED ${tddl_SRCS})
add_library(tddl_static STATIC ${tddl_SRCS})
if(UNIX)
@@ -14,5 +14,10 @@
-endif()
+endif(UNIX)
- install(TARGETS tddl DESTINATION lib)
- install(TARGETS tddl_static DESTINATION lib)
+-install(TARGETS tddl DESTINATION lib)
+-install(TARGETS tddl_static DESTINATION lib)
++install(TARGETS tddl DESTINATION lib/tddl_emu)
++install(TARGETS tddl_static DESTINATION lib/tddl_emu)
+ install(FILES "tddl.h" DESTINATION include)
+
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR})
diff --git a/emulators/tpm-emulator/files/patch-tpmd-CMakeLists.txt b/emulators/tpm-emulator/files/patch-tpmd-CMakeLists.txt
index 8c1f00c2c879..fb503a5ef2a5 100644
--- a/emulators/tpm-emulator/files/patch-tpmd-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-tpmd-CMakeLists.txt
@@ -1,6 +1,6 @@
---- tpmd/CMakeLists.txt.orig 2010-07-06 06:21:20.000000000 +0900
-+++ tpmd/CMakeLists.txt 2010-10-25 02:56:43.624559116 +0900
-@@ -11,5 +11,5 @@
+--- tpmd/CMakeLists.txt.orig 2011-12-20 18:30:06 UTC
++++ tpmd/CMakeLists.txt
+@@ -11,5 +11,5 @@ elseif(WIN32)
add_subdirectory(windows)
diff --git a/emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt b/emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt
index 763d9cf925dc..31e12e51b279 100644
--- a/emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-tpmd-unix-CMakeLists.txt
@@ -1,6 +1,6 @@
---- tpmd/unix/CMakeLists.txt.orig 2011-12-21 03:30:06.000000000 +0900
-+++ tpmd/unix/CMakeLists.txt 2012-10-10 01:03:34.000000000 +0900
-@@ -10,8 +10,8 @@
+--- tpmd/unix/CMakeLists.txt.orig 2011-12-20 18:30:06 UTC
++++ tpmd/unix/CMakeLists.txt
+@@ -10,8 +10,8 @@ add_executable(tpmd ${tpmd_SRCS})
if(MTM_EMULATOR)
add_definitions(-DMTM_EMULATOR)
target_link_libraries(tpmd mtm tpm tpm_crypto)
diff --git a/emulators/tpm-emulator/files/tpmd.in b/emulators/tpm-emulator/files/tpmd.in
index 42e07df28575..cb8c36cd724d 100644
--- a/emulators/tpm-emulator/files/tpmd.in
+++ b/emulators/tpm-emulator/files/tpmd.in
@@ -16,14 +16,14 @@
. /etc/rc.subr
name=tpmd
-rcvar=tpmd_enable
+rcvar="${name}_enable"
command="%%PREFIX%%/bin/${name}"
load_rc_config $name
-tpmd_enable=${tpmd_enable-"NO"}
-tpmd_user=${tpmd_user-"%%USERS%%"}
-tpmd_group=${tpmd_group-"%%GROUPS%%"}
+: ${tpmd_enable:="NO"}
+: ${tpmd_user:="%%USERS%%"}
+: ${tpmd_group:="%%GROUPS%%"}
command_args="-o ${tpmd_user} -g ${tpmd_group}"
unset tpmd_user tpmd_group
diff --git a/emulators/tpm-emulator/pkg-plist b/emulators/tpm-emulator/pkg-plist
index e2c62b605496..cf7ca0e261bf 100644
--- a/emulators/tpm-emulator/pkg-plist
+++ b/emulators/tpm-emulator/pkg-plist
@@ -1,8 +1,8 @@
bin/tpmd
include/tddl.h
-lib/libtddl.a
-lib/libtddl.so
-lib/libtddl.so.1
-lib/libtddl.so.1.2.0.7
+lib/tddl_emu/libtddl.a
+lib/tddl_emu/libtddl.so
+lib/tddl_emu/libtddl.so.1
+lib/tddl_emu/libtddl.so.1.2.0.7
@dir(%%USERS%%,%%GROUPS%%,0700) var/db/tpm
@dir(%%USERS%%,%%GROUPS%%,0700) /var/run/tpm