aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/tpm-emulator
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-27 21:28:00 +0800
committermarino <marino@FreeBSD.org>2014-07-27 21:28:00 +0800
commit5b1f79a7ce2087ac3e6c37c507f495418dc8d8be (patch)
tree2cf47062cd9cb3e857f084ed802e27922773acf6 /emulators/tpm-emulator
parent44c045f9a476bd3c3814fbaa6005744b8fc6f6f8 (diff)
downloadfreebsd-ports-gnome-5b1f79a7ce2087ac3e6c37c507f495418dc8d8be.tar.gz
freebsd-ports-gnome-5b1f79a7ce2087ac3e6c37c507f495418dc8d8be.tar.zst
freebsd-ports-gnome-5b1f79a7ce2087ac3e6c37c507f495418dc8d8be.zip
stage emulators/tpm-emulator
While here, simplify powerpc breakage, remove reference to BERLIOS PR: 191727 Submitted by: Dan Lukes
Diffstat (limited to 'emulators/tpm-emulator')
-rw-r--r--emulators/tpm-emulator/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index fdc871820174..18b8d2982fb4 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -4,7 +4,6 @@
PORTNAME= tpm-emulator
PORTVERSION= 0.7.4
CATEGORIES= emulators security
-#MASTER_SITES= BERLIOS
MASTER_SITES= SF/${PORTNAME}.berlios
DISTNAME= ${PORTNAME:S,-,_,}-${PORTVERSION}
@@ -27,21 +26,13 @@ USERS= _tss
GROUPS= _tss
SUB_LIST= USERS="${USERS}" GROUPS="${GROUPS}"
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+BROKEN_powerpc= Does not compile on powerpc
post-install:
- @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 ${PREFIX}/var/db/tpm
- @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
-
-add-plist-post:
- @(${ECHO_CMD} "@cwd /"; \
- ${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true"; \
- ${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm"; \
- ) >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm" >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}/var/run/tpm
+ @${ECHO_CMD} "@dirrmtry /var/run/tpm" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 %D/var/db/tpm" >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}/${PREFIX}/var/db/tpm
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>