aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vice
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-06-12 22:50:13 +0800
committerdinoex <dinoex@FreeBSD.org>2007-06-12 22:50:13 +0800
commit1c78e7610d98308b68e74191576ce2e219d10fd5 (patch)
treed09efccf2e3d74da459d08db599710bf32251001 /emulators/vice
parent53d30eea86a6fdf923bead5f4b36078c0fc762a3 (diff)
downloadfreebsd-ports-gnome-1c78e7610d98308b68e74191576ce2e219d10fd5.tar.gz
freebsd-ports-gnome-1c78e7610d98308b68e74191576ce2e219d10fd5.tar.zst
freebsd-ports-gnome-1c78e7610d98308b68e74191576ce2e219d10fd5.zip
- fix display problems with xorg7
PR: 113617 Obtained from: debian
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--emulators/vice/files/patch-xorg22
2 files changed, 23 insertions, 1 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index db05a743dbd4..fbc0cfc7598d 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vice
PORTVERSION= 1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
http://fresh.t-systems-sfr.com/linux/src/ \
diff --git a/emulators/vice/files/patch-xorg b/emulators/vice/files/patch-xorg
new file mode 100644
index 000000000000..6ced0d1e1e33
--- /dev/null
+++ b/emulators/vice/files/patch-xorg
@@ -0,0 +1,22 @@
+--- src/arch/unix/x11/xaw/uicolor.c 2003-06-24 15:17:32.000000000 +0200
++++ vice-1.20.pigi4/src/arch/unix/x11/xaw/uicolor.c 2007-04-08 22:58:25.000000000 +0200
+@@ -121,7 +121,7 @@
+ /* This is a kludge to map pixels to zimage values. Is there a better
+ way to do this? //tvr */
+ im = XCreateImage(display, visual, x11ui_get_display_depth(),
+- ZPixmap, 0, (char *)data, 1, 1, 8, 1);
++ ZPixmap, 0, (char *)data, 1, 1, 8, 0);
+ if (!im) {
+ log_error(LOG_DEFAULT, _("XCreateImage failed."));
+ free(data);
+--- src/arch/unix/x11/gnome/uicolor.c 2006-07-22 18:28:40.000000000 +0200
++++ vice-1.20.pigi4/src/arch/unix/x11/gnome/uicolor.c 2007-04-08 22:58:26.000000000 +0200
+@@ -167,7 +167,7 @@
+ way to do this? //tvr */
+ im = XCreateImage(display, GDK_VISUAL_XVISUAL(visual),
+ x11ui_get_display_depth(),
+- ZPixmap, 0, (char *)data, 1, 1, 8, 1);
++ ZPixmap, 0, (char *)data, 1, 1, 8, 0);
+ if (!im) {
+ log_error(LOG_DEFAULT, _("XCreateImage failed."));
+ free(data);