aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vice
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2018-12-17 16:13:15 +0800
committerdinoex <dinoex@FreeBSD.org>2018-12-17 16:13:15 +0800
commit7b3bb32fe7d56570ad47e1ab0ae5bd5b034d947d (patch)
tree300a928773d98ef5623e6eaab70d6d4294a68118 /emulators/vice
parent849484e4fce054b62f28e07bffe0eff8ad35226c (diff)
downloadfreebsd-ports-gnome-7b3bb32fe7d56570ad47e1ab0ae5bd5b034d947d.tar.gz
freebsd-ports-gnome-7b3bb32fe7d56570ad47e1ab0ae5bd5b034d947d.tar.zst
freebsd-ports-gnome-7b3bb32fe7d56570ad47e1ab0ae5bd5b034d947d.zip
- workaround USES=iconv does not support patch and lib depends at the same time.
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 8cbdc21fa139..4894dd78503c 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -115,18 +115,16 @@ INFO+= vice
USE_SDL= sdl2
.endif
-post-patch:
-.for i in da.po de.po fr.po
- ${MV} "${WRKSRC}/po/${i}" "${WRKSRC}/po/${i}.latin"
- ${ICONV_CMD} -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
- ${REINPLACE_CMD} -e 's|ISO-8859-1|UTF-8|' ${WRKSRC}/Makefile.in
-.endfor
-
pre-configure:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/man/vice.1
${REINPLACE_CMD} -e 's|^localedir.*|localedir = $$(DESTDIR)${LOCALBASE}/share/locale|' \
${WRKSRC}/po/Makefile.in.in
+.for i in da.po de.po fr.po
+ ${MV} "${WRKSRC}/po/${i}" "${WRKSRC}/po/${i}.latin"
+ ${ICONV_CMD} -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
+ ${REINPLACE_CMD} -e 's|ISO-8859-1|UTF-8|' ${WRKSRC}/Makefile.in
+.endfor
.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif