aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/vmware2
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-04-15 05:01:58 +0800
committerknu <knu@FreeBSD.org>2000-04-15 05:01:58 +0800
commit429aacdf47b359d45f5e7046ec8a07789ebdcbe8 (patch)
tree0a2f1e19afa4844fd5b621464ab9feb2668aae7e /emulators/vmware2
parent48f215609be4f3d6e296423cf8d32278725c604b (diff)
downloadfreebsd-ports-gnome-429aacdf47b359d45f5e7046ec8a07789ebdcbe8.tar.gz
freebsd-ports-gnome-429aacdf47b359d45f5e7046ec8a07789ebdcbe8.tar.zst
freebsd-ports-gnome-429aacdf47b359d45f5e7046ec8a07789ebdcbe8.zip
Prepare ${LINUX_DIR}/dev/null for use of the plain disk technique.
Suggested by: Nick Sayer
Diffstat (limited to 'emulators/vmware2')
-rw-r--r--emulators/vmware2/Makefile2
-rw-r--r--emulators/vmware2/pkg-plist4
-rw-r--r--emulators/vmware2/scripts/pre-install2
3 files changed, 6 insertions, 2 deletions
diff --git a/emulators/vmware2/Makefile b/emulators/vmware2/Makefile
index 5a21a0e5fe01..deb68861d206 100644
--- a/emulators/vmware2/Makefile
+++ b/emulators/vmware2/Makefile
@@ -27,7 +27,7 @@ PATCHFILES= vmmon-freebsd-0.95.tar.gz \
MAINTAINER= freebsd-emulation@FreeBSD.org
RUN_DEPENDS= ${LINUX_DIR}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
- /dev/rtc:${PORTSDIR}/emulators/rtc
+ ${LINUX_DIR}/dev/rtc:${PORTSDIR}/emulators/rtc
RESTRICTED= "Not sure if we can redistribute it"
diff --git a/emulators/vmware2/pkg-plist b/emulators/vmware2/pkg-plist
index e29983ac38c5..35122c42a73d 100644
--- a/emulators/vmware2/pkg-plist
+++ b/emulators/vmware2/pkg-plist
@@ -116,12 +116,14 @@ share/doc/vmware/SAMBA-LICENSE
@exec mkdir -p /compat/linux/dev;for n in 0 1 2 3 4 5 6 7 8 9; do ln -s /dev/ttyv$n /compat/linux/dev/tty$n;done
@exec ln -s /dev/ttyva /compat/linux/dev/tty10
@exec ln -s /dev/ttyvb /compat/linux/dev/tty11
+@exec mknod /compat/linux/dev/null c 2 2
+@exec chmod 666 /compat/linux/dev/null
@exec mknod /compat/linux/dev/hda b 0 0x00010002
@exec mknod /compat/linux/dev/hdb b 0 0x0001000a
@exec ln -s %D/etc/vmware /etc/vmware
@exec mknod /dev/vmmon c 200 0
@exec mknod /dev/vmnet1 c 201 1
-@unexec rm -f /etc/vmware /dev/vmmon /dev/vmnet1 /compat/linux/bin/df /compat/linux/dev/tty[0-9]* /compat/linux/dev/hd?
+@unexec rm -f /etc/vmware /dev/vmmon /dev/vmnet1 /compat/linux/bin/df /compat/linux/dev/tty[0-9]* /compat/linux/dev/hd? /compat/linux/dev/null
@dirrm etc/vmware
@dirrm lib/vmware/bin
@dirrm lib/vmware/lib/floppies
diff --git a/emulators/vmware2/scripts/pre-install b/emulators/vmware2/scripts/pre-install
index 771445b0ac01..2ac0bc85a983 100644
--- a/emulators/vmware2/scripts/pre-install
+++ b/emulators/vmware2/scripts/pre-install
@@ -15,6 +15,8 @@ done
ln -s /dev/ttyva ${linux_dev}/tty11
ln -s /dev/ttyvb ${linux_dev}/tty12
ln -s ${linux_dev}/tty1 ${linux_dev}/tty0
+mknod ${linux_dev}/null c 2 2
+chmod 666 ${linux_dev}/null
echo Creating $linux_dev/hd\?
mknod ${linux_dev}/hda b 0 0x00010002
mknod ${linux_dev}/hdb b 0 0x0001000a