aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine-devel/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2007-07-16 01:09:08 +0800
committergerald <gerald@FreeBSD.org>2007-07-16 01:09:08 +0800
commit21a4fd543823214f04c29ea9eca6e63c54545b42 (patch)
treec662adfa561c25e7a2b8cab9b392de299b681b20 /emulators/wine-devel/Makefile
parent37a563eb59cc437c1d7f77068d3afb8c23ce030d (diff)
downloadfreebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.tar.gz
freebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.tar.zst
freebsd-ports-gnome-21a4fd543823214f04c29ea9eca6e63c54545b42.zip
Update to Wine 0.9.41. Among others, this brings the following changes:
- A number of gdiplus functions. - More complete pdh.dll implementation. - Support for MSI remote calls. - Messaging support in crypt32.dll. - Lots of bug fixes. Handle the wineg++.1 man page via MLINK instead of removing it. Make ${PREFIX}/lib/libwine.so a relative link. Refer to LOCALBASE instead of PREFIX in setting CONFIGURE_ENV. Remove LIBS=-Wl,-rpath,${PREFIX}/lib/wine which was added in revision 1.86 for PR19562 but is not needed any longer. [1] Support DATADIR. Submitted by: Tijl Coosemans <tijl@ulyssis.org> [1]
Diffstat (limited to 'emulators/wine-devel/Makefile')
-rw-r--r--emulators/wine-devel/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index b4740151b5d2..6a44ffed2218 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.40
+PORTVERSION= 0.9.41
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -23,14 +23,14 @@ LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
- LIBS=-Wl,-rpath,${PREFIX}/lib/wine \
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --datadir=${DATADIR}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
EXTRA_BINARIES="wine-kthread"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
+MLINKS= winegcc.1 wineg++.1
ONLY_FOR_ARCHS= i386
USE_BISON= yes
USE_BZIP2= yes
@@ -51,9 +51,8 @@ pre-build:
cd ${WRKSRC} && make depend
post-install:
- ${RM} ${PREFIX}/man/man1/wineg++.1
${MV} -f ${PREFIX}/lib/libwine.so.1.0 ${PREFIX}/lib/libwine.so.1
- ${LN} -sf ${PREFIX}/lib/libwine.so.1 ${PREFIX}/lib/libwine.so
+ ${LN} -sf libwine.so.1 ${PREFIX}/lib/libwine.so
.if !defined(NOPORTDOCS)
-@${MKDIR} ${DOCSDIR}
.for i in README ANNOUNCE AUTHORS LICENSE