aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine-devel/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2011-07-03 23:39:11 +0800
committergerald <gerald@FreeBSD.org>2011-07-03 23:39:11 +0800
commit9e2aeae9e2de0807b14e2dde1c31acad117226ee (patch)
treed1d62cc9bd087ff6e6849be82195a6fe7cb687e6 /emulators/wine-devel/Makefile
parentfd21a60add7e4c7064e43f97fdc30d914f01fbae (diff)
downloadfreebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.tar.gz
freebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.tar.zst
freebsd-ports-gnome-9e2aeae9e2de0807b14e2dde1c31acad117226ee.zip
Update to Wine 1.3.22. This includes the following changes:
- Support for Indic text shaping. - Generation of stubless code in the IDL compiler. - Support for X files in D3DX. - 4- and 24-bit bitmap formats in the DIB engine. - Listview performance improvements. - Various bug fixes. No longer set the GNU configure datadir based on our DATADIR. This should enable this port and emulators/wine-gecko to nicely fit together.
Diffstat (limited to 'emulators/wine-devel/Makefile')
-rw-r--r--emulators/wine-devel/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index c65eb5ddd974..87e7e06a31ec 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.3.21
+DISTVERSION= 1.3.22
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
@@ -31,7 +31,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CPPFLAGS= "-I${LOCALBASE}/include"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--datadir=${DATADIR} --verbose --disable-tests \
+CONFIGURE_ARGS+=--verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
--without-mpg123 --with-oss --without-sane \
@@ -134,9 +134,11 @@ post-install:
${MAN1PREFIX}/man/de.UTF-8/man1/wineserver.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
${MAN1PREFIX}/man/fr.UTF-8/man1/winemaker.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1/wine.1
@-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1
+ ${MAN1PREFIX}/man/fr.UTF-8/man1 \
+ ${MAN1PREFIX}/man/pl.UTF-8/man1
${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
@@ -148,8 +150,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
@${MKDIR} ${DESKTOPDIR}
- ${MV} ${DATADIR}/applications/wine.desktop ${DESKTOPDIR}/
- @${RMDIR} ${DATADIR}/applications
@${ECHO}
@${CAT} ${PKGMESSAGE}