aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine-devel
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2017-12-01 19:48:12 +0800
committergerald <gerald@FreeBSD.org>2017-12-01 19:48:12 +0800
commitaeffc8ea53be64a16986ef75722f47e332f2eca5 (patch)
treeb9ba39d4aa70551e70ea1ad5660aebc38cc18260 /emulators/wine-devel
parenta2112ad383784192ea30bf367b149032a124c311 (diff)
downloadfreebsd-ports-gnome-aeffc8ea53be64a16986ef75722f47e332f2eca5.tar.gz
freebsd-ports-gnome-aeffc8ea53be64a16986ef75722f47e332f2eca5.tar.zst
freebsd-ports-gnome-aeffc8ea53be64a16986ef75722f47e332f2eca5.zip
Update to Wine 2.22. This includes the following changes:
- Source selection dialog for scanners. - Float audio formats with more than 2 channels in XAudio. - Fixes for DLL injection support. - Input methods improvements. - Various bug fixes. Mark the STAGING option, and hence the wine-staging port as well, as BROKEN. Once again that patchset still is not available yet a week after the Wine snapshot. Temporarily add a patch against dlls/advapi32/perf.c that I got accepted upstream in the meantime, so it should become obsolete with the next minor version.
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile2
-rw-r--r--emulators/wine-devel/distinfo8
-rw-r--r--emulators/wine-devel/files/patch-dlls_advapi32_perf.c44
-rw-r--r--emulators/wine-devel/pkg-plist3
4 files changed, 51 insertions, 6 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 099072b8d9e0..b12ffb69e251 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 2.21
+DISTVERSION= 2.22
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 43bbbce07fa0..2b5c78ba23c0 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1511391649
-SHA256 (wine-2.21.tar.xz) = bafa04e8cfbb3c5fbb6bb5080fb5d3f2f6816ac69518d0ed50aceadb66b4abef
-SIZE (wine-2.21.tar.xz) = 19620888
-SHA256 (v2.21.tar.gz) = 20ff258de2dcc2f886fcb804c313963da060a55c89f5265c69510a2adfd04ba6
-SIZE (v2.21.tar.gz) = 10229454
+TIMESTAMP = 1511621287
+SHA256 (wine-2.22.tar.xz) = db5c7e7f652405d927b3ba43cc09e4e2f5726a2c7cbf9445a0d01d1b335e8b73
+SIZE (wine-2.22.tar.xz) = 19635032
diff --git a/emulators/wine-devel/files/patch-dlls_advapi32_perf.c b/emulators/wine-devel/files/patch-dlls_advapi32_perf.c
new file mode 100644
index 000000000000..d99bf1f5e469
--- /dev/null
+++ b/emulators/wine-devel/files/patch-dlls_advapi32_perf.c
@@ -0,0 +1,44 @@
+From: Gerald Pfeifer <gerald@pfeifer.com>
+To: wine-devel@winehq.org, Austin English <austinenglish@gmail.com>
+Date: Sat, 25 Nov 2017 15:43:13 +0100 (CET)
+Subject: [PATCH] advapi32: Include <stdarg.h> since winbase.h expects va_list
+
+The addition of dlls/advapi32/perf.c about a week ago broke my nightly
+FreeBSD builder as follows:
+
+ In file included from perf.c:24:
+ ../../include/windef.h:106:24: error: unknown type name ‘va_list’
+ # define __ms_va_list va_list
+ ^~~~~~~
+ ../../include/winbase.h:2002:84: note: in expansion of macro ‘__ms_va_list’ in
+ WINBASEAPI DWORD WINAPI FormatMessageA(DWORD,LPCVOID,DWORD,DWORD,LPSTR,DWORD,__ms_va_list*);
+
+This is a typical failure mode I've seen on FreeBSD, which is more
+parsimonious than GNU/Linux when it comes to include files pulling
+in others, though our peak with Wine running into this was more than
+a decade ago. ;-)
+
+Investigating this case a little I found that indeed winbase.h and
+in turn windef.h assume va_list is known and indeed many other files
+in dlls/advapi32 already include stdarg.h.
+
+Gerald
+
+Signed-off-by: Gerald Pfeifer <gerald@pfeifer.com>
+---
+ dlls/advapi32/perf.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- UTC
+--- dlls/advapi32/perf.c
++++ dlls/advapi32/perf.c
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+
++#include <stdarg.h>
+ #include <stdio.h>
+
+ #include "windef.h"
+--
+2.15.0
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index d46f882acd66..f863530dfbcd 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -629,6 +629,7 @@ include/wine/windows/patchapi.h
%%STAGING%%include/wine/windows/pathcch.h
include/wine/windows/pdh.h
include/wine/windows/pdhmsg.h
+include/wine/windows/perflib.h
include/wine/windows/perhist.h
include/wine/windows/perhist.idl
include/wine/windows/physicalmonitorenumerationapi.h
@@ -667,6 +668,8 @@ include/wine/windows/rmxfguid.h
include/wine/windows/rmxftmpl.h
include/wine/windows/rmxftmpl.x
include/wine/windows/roapi.h
+include/wine/windows/roparameterizediid.h
+include/wine/windows/roparameterizediid.idl
include/wine/windows/row.idl
include/wine/windows/rowchg.idl
include/wine/windows/rowpos.idl