aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine-devel
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-09-12 01:42:25 +0800
committergerald <gerald@FreeBSD.org>2010-09-12 01:42:25 +0800
commit835511d70ed17acdb27f521233874c7fb4a6b502 (patch)
treecdca1e40ac582d50b8b4a4af4fd672bfad4f9523 /emulators/wine-devel
parentdc574f686ac4adec8ab2a9afe33648995d88369d (diff)
downloadfreebsd-ports-gnome-835511d70ed17acdb27f521233874c7fb4a6b502.tar.gz
freebsd-ports-gnome-835511d70ed17acdb27f521233874c7fb4a6b502.tar.zst
freebsd-ports-gnome-835511d70ed17acdb27f521233874c7fb4a6b502.zip
Add a new option OPENAL, off by default, that controls the use of OpenAL.
Among others, this makes Starcraft 2 work nicely. Submitted by: tijl
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 8644a1759e14..3db5d557f7c4 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
- --without-mpg123 --without-openal --without-sane \
+ --without-mpg123 --without-sane \
--without-xcomposite --without-xinerama
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -54,6 +54,7 @@ OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
LDAP "Use LDAP" Off \
LIBXSLT "Use libxslt (only used by msxml3.dll)" Off \
+ OPENAL "Use OpenAL (3D audio library)" Off \
WINEMAKER "Fully support winemaker (requires Perl)" Off
.include <bsd.port.pre.mk>
@@ -93,6 +94,13 @@ LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
CONFIGURE_ARGS+= --without-xslt
.endif
+.ifdef WITH_OPENAL
+CONFIGURE_ARGS+= --with-openal
+USE_OPENAL= yes
+.else
+CONFIGURE_ARGS+= --without-openal
+.endif
+
.ifdef WITH_WINEMAKER
RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
.endif