aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-05 03:00:06 +0800
committergerald <gerald@FreeBSD.org>2009-01-05 03:00:06 +0800
commit262724ef344e5c17ae2c39fd93dde9b17afa28a8 (patch)
treeaa17a351f0e81143cacace10f6a360f851add1c6 /emulators/wine
parent1529cbf47ed2f8d68ac383dbf9424dac2f86a8a3 (diff)
downloadfreebsd-ports-gnome-262724ef344e5c17ae2c39fd93dde9b17afa28a8.tar.gz
freebsd-ports-gnome-262724ef344e5c17ae2c39fd93dde9b17afa28a8.tar.zst
freebsd-ports-gnome-262724ef344e5c17ae2c39fd93dde9b17afa28a8.zip
Add option LDAP, off by default.
PR: 119155
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 9d8fadc7f70f..a1340d34581b 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -44,6 +44,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LDAP "Use LDAP" Off \
LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LDAP
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
.ifdef WITH_LIBXSLT
CONFIGURE_ARGS+= --with-xslt
LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt