aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2008-06-09 05:40:43 +0800
committergerald <gerald@FreeBSD.org>2008-06-09 05:40:43 +0800
commit28878bd20f6df8ce1ae80f531368124c2706d0f1 (patch)
tree45db9385f73e18e98d6a191d2027f8c53c384cc8 /emulators/wine
parent86f28b99e0ea80b59a70647cf15b72084ebe0d98 (diff)
downloadfreebsd-ports-gnome-28878bd20f6df8ce1ae80f531368124c2706d0f1.tar.gz
freebsd-ports-gnome-28878bd20f6df8ce1ae80f531368124c2706d0f1.tar.zst
freebsd-ports-gnome-28878bd20f6df8ce1ae80f531368124c2706d0f1.zip
Update to version 1.0-rc4 which brings bug fixes only, no new features.
Start adding OPTIONS for this port, the first one called CUPS to break to hard dependency on the cups-base port. PR: 119199 Submitted by: scf, Christoph Mallon <christoph.mallon@gmx.de>
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile15
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/files/patch-dlls-wininet80
3 files changed, 14 insertions, 87 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 9b3cf1b5d5c3..d00a9e75a616 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.0-rc3
-PORTREVISION= 1
+DISTVERSION= 1.0-rc4
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
@@ -18,8 +17,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gerald@FreeBSD.org
COMMENT= Microsoft Windows compatibility layer for Unix-like systems
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.9:${PORTSDIR}/graphics/jpeg \
lcms.1:${PORTSDIR}/graphics/lcms \
@@ -43,8 +41,17 @@ USE_XORG= xpm
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On
+
.include <bsd.port.pre.mk>
+.ifdef WITHOUT_CUPS
+CONFIGURE_ARGS+= --without-cups
+.else
+CONFIGURE_ARGS+= --with-cups
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index bba3e7104c78..f649f3199151 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.0-rc3.tar.bz2) = bcef2a24ed6ffaa4bb14a491e3daff31
-SHA256 (wine-1.0-rc3.tar.bz2) = b56b994e043d4a34bbda605ceba5607f699bdff68b8bbfd91e4e0701e4f6c5b6
-SIZE (wine-1.0-rc3.tar.bz2) = 13991771
+MD5 (wine-1.0-rc4.tar.bz2) = 1ce2f46b03e1484a8d0845ea5519002b
+SHA256 (wine-1.0-rc4.tar.bz2) = 72afc4184606aa8cccdb356a3923414e3f8c626d1c037cae1792d0a146600c47
+SIZE (wine-1.0-rc4.tar.bz2) = 13983809
diff --git a/emulators/wine/files/patch-dlls-wininet b/emulators/wine/files/patch-dlls-wininet
deleted file mode 100644
index 74ef7283f0c1..000000000000
--- a/emulators/wine/files/patch-dlls-wininet
+++ /dev/null
@@ -1,80 +0,0 @@
-From: Alexandre Julliard <julliard@winehq.org>
-Date: Mon, 2 Jun 2008 10:14:37 +0000 (+0200)
-Subject: wininet: Include openssl/ssl.h before Windows headers.
-X-Git-Url: http://source.winehq.org/git/wine.git/?a=commitdiff_plain;h=7c616799894faa48ee3277bc276a39bed55780e0
-
-wininet: Include openssl/ssl.h before Windows headers.
----
-
-diff --git a/dlls/wininet/internet.h b/dlls/wininet/internet.h
-index 2645686..43b8d8e 100644
---- dlls/wininet/internet.h
-+++ dlls/wininet/internet.h
-@@ -38,18 +38,6 @@
- # include <sys/types.h>
- # include <netinet/in.h>
- #endif
--#ifdef HAVE_OPENSSL_SSL_H
--#define DSA __ssl_DSA /* avoid conflict with commctrl.h */
--#undef FAR
--/* avoid conflict with wincrypt.h */
--#undef PKCS7_SIGNER_INFO
--#undef X509_NAME
--#undef X509_CERT_PAIR
--# include <openssl/ssl.h>
--#undef FAR
--#define FAR do_not_use_this_in_wine
--#undef DSA
--#endif
- #ifdef HAVE_SYS_SOCKET_H
- # include <sys/socket.h>
- #endif
-@@ -69,12 +57,10 @@ typedef struct
- {
- BOOL useSSL;
- int socketFD;
--#ifdef HAVE_OPENSSL_SSL_H
-- SSL *ssl_s;
-+ void *ssl_s;
- char *peek_msg;
- char *peek_msg_mem;
- size_t peek_len;
--#endif
- } WININET_NETCONNECTION;
-
- static inline LPWSTR WININET_strdupW( LPCWSTR str )
-diff --git a/dlls/wininet/netconnection.c b/dlls/wininet/netconnection.c
-index 9cd7917..f55fbf2 100644
---- dlls/wininet/netconnection.c
-+++ dlls/wininet/netconnection.c
-@@ -23,6 +23,7 @@
- #include "config.h"
- #include "wine/port.h"
-
-+#include <sys/types.h>
- #ifdef HAVE_POLL_H
- #include <poll.h>
- #endif
-@@ -42,6 +43,22 @@
- #ifdef HAVE_SYS_IOCTL_H
- # include <sys/ioctl.h>
- #endif
-+#include <time.h>
-+#ifdef HAVE_NETDB_H
-+# include <netdb.h>
-+#endif
-+#ifdef HAVE_NETINET_IN_H
-+# include <netinet/in.h>
-+#endif
-+#ifdef HAVE_OPENSSL_SSL_H
-+# include <openssl/ssl.h>
-+#undef FAR
-+#undef DSA
-+#endif
-+#ifdef HAVE_SYS_SOCKET_H
-+# include <sys/socket.h>
-+#endif
-+
- #include <stdarg.h>
- #include <stdlib.h>
- #include <string.h>