aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-09-26 22:58:36 +0800
committergerald <gerald@FreeBSD.org>2009-09-26 22:58:36 +0800
commit8f963628c741cf4f4e9ac7d626b2e7040943637e (patch)
tree976a2405bf19ea4628f90f48aa40daa7aa545d11 /emulators/wine
parentaedeb9b3a27456fb5e0f17b28b094414726971a7 (diff)
downloadfreebsd-ports-gnome-8f963628c741cf4f4e9ac7d626b2e7040943637e.tar.gz
freebsd-ports-gnome-8f963628c741cf4f4e9ac7d626b2e7040943637e.tar.zst
freebsd-ports-gnome-8f963628c741cf4f4e9ac7d626b2e7040943637e.zip
Update to Wine 1.1.30. Among others, this includes the following changes:
- Support for OpenAL (disabled for now). - Many improvements in HTML and JavaScript support. - Many common controls fixes and improvements. - More Direct3D 10 work. - Better MAPI support. - Various bug fixes. Explicitly disable OpenAL (new with this version of Wine) and GnuTLS (already older) to guarantee consistent builds. Feature safe: yes
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile7
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/pkg-plist3
3 files changed, 10 insertions, 6 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 16031870535b..95bf4942fc87 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.1.29
+DISTVERSION= 1.1.30
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -25,8 +25,9 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
- --without-capi --without-gphoto --without-gsm \
- --without-mpg123 --without-sane --without-xcursor
+ --without-capi --without-gnutls --without-gphoto \
+ --without-gsm --without-mpg123 --without-openal \
+ --without-sane --without-xcursor
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index ab754f625a33..c28c70a4bf51 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.1.29.tar.bz2) = c3a9218840a80b29932cee49f2d45d9d
-SHA256 (wine-1.1.29.tar.bz2) = 19ad43b9c1d8b7d0798913c81b5d8735d978b06cfc85f956f17b2d3dc4271650
-SIZE (wine-1.1.29.tar.bz2) = 15654585
+MD5 (wine-1.1.30.tar.bz2) = 3b78497f71cf6f112bac6de74e5cb29f
+SHA256 (wine-1.1.30.tar.bz2) = de5f228bf7429c283167c131d89b44aaeef8ae25132217efe7c7a6c8faba16fc
+SIZE (wine-1.1.30.tar.bz2) = 15780747
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 511ab71b5d20..5090ba9382c0 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -394,6 +394,7 @@ include/wine/windows/oleauto.h
include/wine/windows/olectl.h
include/wine/windows/oledb.h
include/wine/windows/oledb.idl
+include/wine/windows/oledberr.h
include/wine/windows/oledlg.h
include/wine/windows/oleidl.h
include/wine/windows/oleidl.idl
@@ -657,6 +658,7 @@ lib/wine/d3dx9_38.dll.so
lib/wine/d3dx9_39.dll.so
lib/wine/d3dx9_40.dll.so
lib/wine/d3dx9_41.dll.so
+lib/wine/d3dx9_42.dll.so
lib/wine/d3dxof.dll.so
lib/wine/dbghelp.dll.so
lib/wine/dciman32.dll.so
@@ -761,6 +763,7 @@ lib/wine/fakedlls/d3dx9_38.dll
lib/wine/fakedlls/d3dx9_39.dll
lib/wine/fakedlls/d3dx9_40.dll
lib/wine/fakedlls/d3dx9_41.dll
+lib/wine/fakedlls/d3dx9_42.dll
lib/wine/fakedlls/d3dxof.dll
lib/wine/fakedlls/dbghelp.dll
lib/wine/fakedlls/dciman32.dll