aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2006-05-31 06:43:06 +0800
committergerald <gerald@FreeBSD.org>2006-05-31 06:43:06 +0800
commitfe011cc052a72cd53b2dece67b54b572f6bbf6de (patch)
tree1fa1f56ef5f41d48167b31c145a1272b96dd2acb /emulators/wine
parentc4580f588d69cce696b1bdd6b83917c2f141725d (diff)
downloadfreebsd-ports-gnome-fe011cc052a72cd53b2dece67b54b572f6bbf6de.tar.gz
freebsd-ports-gnome-fe011cc052a72cd53b2dece67b54b572f6bbf6de.tar.zst
freebsd-ports-gnome-fe011cc052a72cd53b2dece67b54b572f6bbf6de.zip
Update to Wine 0.9.14 which brings the following:
- Better MS/RPC compatibility. - Many fixes to Direct3D shaders. - Several improvements to the header control. - New GPhoto backend for TWAIN. - Dynamic drive configuration using HAL. - A gazillion Direct3D fixes. - New TCP transport for RPC. - Lots of bug fixes. Add FreeType and FontForge as new dependencies, which should help with font display problems quite a bit. PR: 97792 Submitted by: sat Adjustments by: gerald
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile9
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/files/patch-configure36
-rw-r--r--emulators/wine/pkg-plist55
4 files changed, 63 insertions, 43 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index bfa2a783a79a..00ed01010200 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.12
+PORTVERSION= 0.9.14
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= http://ibiblio.org/pub/linux/system/emulators/wine/ \
@@ -19,10 +19,15 @@ COMMENT= Microsoft Windows compatibility layer for Unix-like systems
# wine/dlls/glut32/ depends on the presence of libglut.
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ gdraw.1:${PORTSDIR}/print/fontforge \
glut.4:${PORTSDIR}/graphics/libglut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib LIBS=-Wl,-rpath,${PREFIX}/lib/wine
+CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include \
+ LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
+ LIBS=-Wl,-rpath,${PREFIX}/lib/wine \
+ EXTRA_BINARIES="wine-kthread"
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/wine
USE_LDCONFIG= ${PREFIX}/lib/wine
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index b84aeeb61e8e..6ac10a4be390 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-0.9.12.tar.bz2) = f7668e17e731b59c837dfee218554171
-SHA256 (wine-0.9.12.tar.bz2) = 8c02d5153f87d20f1bbedb663fadab3a6213497a9ee944b05b2a87655744d082
-SIZE (wine-0.9.12.tar.bz2) = 10726811
+MD5 (wine-0.9.14.tar.bz2) = 503c44d7851cf4cd469410cc89bbf391
+SHA256 (wine-0.9.14.tar.bz2) = 0a27fd74276d06e6ea259e524ee1abc47c642604aa0ffa1fb80af8b456cd02a5
+SIZE (wine-0.9.14.tar.bz2) = 10910290
diff --git a/emulators/wine/files/patch-configure b/emulators/wine/files/patch-configure
deleted file mode 100644
index 0cfc324f0a86..000000000000
--- a/emulators/wine/files/patch-configure
+++ /dev/null
@@ -1,36 +0,0 @@
-Index: configure.ac
-===================================================================
-RCS file: /home/wine/wine/configure.ac,v
-retrieving revision 1.475
-diff -u -3 -p -r1.475 configure.ac
---- configure.ac 10 Apr 2006 18:49:33 -0000 1.475
-+++ configure.ac 11 Apr 2006 14:04:46 -0000
-@@ -1159,6 +1159,9 @@ case $host_cpu in
- AC_SUBST(EXTRA_BINARIES,"wine-kthread wine-pthread wine-preloader") ;;
- darwin*)
- AC_SUBST(MAIN_BINARY,"wine-pthread") ;;
-+ freebsd*)
-+ AC_SUBST(MAIN_BINARY,"wine-pthread")
-+ AC_SUBST(EXTRA_BINARIES,"wine-kthread") ;;
- *)
- AC_SUBST(MAIN_BINARY,"wine-kthread") ;;
- esac
-Index: configure
-===================================================================
-RCS file: /home/wine/wine/configure,v
-retrieving revision 1.788
-diff -u -3 -p -r1.788 configure
---- configure 10 Apr 2006 18:49:32 -0000 1.788
-+++ configure 11 Apr 2006 14:04:45 -0000
-@@ -13740,6 +13740,10 @@ case $host_cpu in
-
- EXTRA_BINARIES="wine-kthread wine-pthread wine-preloader"
- ;;
-+ freebsd*)
-+ MAIN_BINARY="wine-pthread"
-+ EXTRA_BINARIES="wine-kthread"
-+ ;;
- darwin*)
- MAIN_BINARY="wine-pthread"
- ;;
-
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 0b8cb3bef410..2f96b1093980 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -166,6 +166,7 @@ include/wine/windows/dxerr8.h
include/wine/windows/dxerr9.h
include/wine/windows/dxfile.h
include/wine/windows/dyngraph.idl
+include/wine/windows/errors.h
include/wine/windows/evcode.h
include/wine/windows/evntrace.h
include/wine/windows/excpt.h
@@ -229,6 +230,7 @@ include/wine/windows/mmreg.h
include/wine/windows/mmstream.h
include/wine/windows/mmstream.idl
include/wine/windows/mmsystem.h
+include/wine/windows/mprapi.h
include/wine/windows/msacm.h
include/wine/windows/msacmdlg.h
include/wine/windows/msacmdrv.h
@@ -257,6 +259,7 @@ include/wine/windows/nspapi.h
include/wine/windows/ntddcdrm.h
include/wine/windows/ntddscsi.h
include/wine/windows/ntddstor.h
+include/wine/windows/ntdsapi.h
include/wine/windows/ntsecapi.h
include/wine/windows/ntstatus.h
include/wine/windows/oaidl.h
@@ -340,6 +343,7 @@ include/wine/windows/tchar.h
include/wine/windows/textserv.h
include/wine/windows/tlhelp32.h
include/wine/windows/tmschema.h
+include/wine/windows/twain.h
include/wine/windows/unknwn.h
include/wine/windows/unknwn.idl
include/wine/windows/urlmon.h
@@ -474,6 +478,7 @@ lib/wine/gdi.exe16
lib/wine/gdi32.dll.so
lib/wine/glu32.dll.so
lib/wine/glut32.dll.so
+lib/wine/gphoto2.ds.so
lib/wine/hh.exe.so
lib/wine/hhctrl.ocx.so
lib/wine/iccvid.dll.so
@@ -540,6 +545,7 @@ lib/wine/liblz32.def
lib/wine/libmapi32.def
lib/wine/libmlang.def
lib/wine/libmpr.def
+lib/wine/libmprapi.def
lib/wine/libmsacm32.def
lib/wine/libmscms.def
lib/wine/libmsdmo.def
@@ -555,6 +561,7 @@ lib/wine/libmswsock.def
lib/wine/libnetapi32.def
lib/wine/libnewdev.def
lib/wine/libntdll.def
+lib/wine/libntdsapi.def
lib/wine/libodbc32.def
lib/wine/libodbccp32.def
lib/wine/libole32.def
@@ -615,7 +622,7 @@ lib/wine/mapi32.dll.so
lib/wine/mciavi32.dll.so
lib/wine/mcicda.dll.so
lib/wine/mciseq.dll.so
-lib/wine/mciwave.drv.so
+lib/wine/mciwave.dll.so
lib/wine/midimap.dll.so
lib/wine/mlang.dll.so
lib/wine/mmdevldr.vxd.so
@@ -623,9 +630,10 @@ lib/wine/mmsystem.dll16
lib/wine/monodebg.vxd.so
lib/wine/mouse.drv16
lib/wine/mpr.dll.so
-lib/wine/msacm.drv.so
+lib/wine/mprapi.dll.so
lib/wine/msacm.dll16
lib/wine/msacm32.dll.so
+lib/wine/msacm32.drv.so
lib/wine/msadp32.acm.so
lib/wine/mscms.dll.so
lib/wine/msdmo.dll.so
@@ -651,6 +659,7 @@ lib/wine/netapi32.dll.so
lib/wine/newdev.dll.so
lib/wine/notepad.exe.so
lib/wine/ntdll.dll.so
+lib/wine/ntdsapi.dll.so
lib/wine/objsel.dll.so
lib/wine/odbc32.dll.so
lib/wine/odbccp32.dll.so
@@ -686,6 +695,7 @@ lib/wine/rpcss.exe.so
lib/wine/rsabase.dll.so
lib/wine/rsaenh.dll.so
lib/wine/rundll32.exe.so
+lib/wine/sane.ds.so
lib/wine/secur32.dll.so
lib/wine/security.dll.so
lib/wine/sensapi.dll.so
@@ -785,6 +795,46 @@ share/aclocal/wine.m4
share/applications/wine.desktop
share/wine/wine.inf
share/wine/generic.ppd
+share/wine/fonts/coue1255.fon
+share/wine/fonts/coue1256.fon
+share/wine/fonts/coue1257.fon
+share/wine/fonts/coure.fon
+share/wine/fonts/couree.fon
+share/wine/fonts/coureg.fon
+share/wine/fonts/courer.fon
+share/wine/fonts/couret.fon
+share/wine/fonts/cvgasys.fon
+share/wine/fonts/hvgasys.fon
+share/wine/fonts/jsmalle.fon
+share/wine/fonts/jvgasys.fon
+share/wine/fonts/marlett.ttf
+share/wine/fonts/smae1255.fon
+share/wine/fonts/smae1256.fon
+share/wine/fonts/smae1257.fon
+share/wine/fonts/smalle.fon
+share/wine/fonts/smallee.fon
+share/wine/fonts/smalleg.fon
+share/wine/fonts/smaller.fon
+share/wine/fonts/smallet.fon
+share/wine/fonts/ssee1255.fon
+share/wine/fonts/ssee1256.fon
+share/wine/fonts/ssee1257.fon
+share/wine/fonts/ssee874.fon
+share/wine/fonts/sserife.fon
+share/wine/fonts/sserifee.fon
+share/wine/fonts/sserifeg.fon
+share/wine/fonts/sserifer.fon
+share/wine/fonts/sserifet.fon
+share/wine/fonts/svgasys.fon
+share/wine/fonts/vgas1255.fon
+share/wine/fonts/vgas1256.fon
+share/wine/fonts/vgas1257.fon
+share/wine/fonts/vgas874.fon
+share/wine/fonts/vgasys.fon
+share/wine/fonts/vgasyse.fon
+share/wine/fonts/vgasysg.fon
+share/wine/fonts/vgasysr.fon
+share/wine/fonts/vgasyst.fon
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -804,4 +854,5 @@ share/wine/generic.ppd
@dirrm include/wine
@dirrmtry man/man3w
@dirrmtry share/applications
+@dirrm share/wine/fonts
@dirrm share/wine