aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-04-07 20:38:29 +0800
committergerald <gerald@FreeBSD.org>2012-04-07 20:38:29 +0800
commit8b70657aff7dd8932abb114b7596efac415becf6 (patch)
treecd517ab25b03a545d6f2be49349e33b5e97fcafe /emulators/wine
parent59dc2c5dad2161a298ef63af2b08f92fb45b6987 (diff)
downloadfreebsd-ports-gnome-8b70657aff7dd8932abb114b7596efac415becf6.tar.gz
freebsd-ports-gnome-8b70657aff7dd8932abb114b7596efac415becf6.tar.zst
freebsd-ports-gnome-8b70657aff7dd8932abb114b7596efac415becf6.zip
Add a CONFLICT with the new emulators/wine-devel port and adjust
the COMMENT along what we did there, to make it easier to understand. Explicitly configure --without-dbus --without-opencl to make builds deterministic and reproducible. Feature safe: yes
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 9f62fec673fe..e5104ac04dea 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF/${PORTNAME}/Source \
http://ibiblio.org/pub/linux/system/emulators/wine/
MAINTAINER= gerald@FreeBSD.org
-COMMENT= Microsoft Windows compatibility layer for Unix-like systems
+COMMENT= Microsoft Windows compatibility environment
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
@@ -28,14 +28,16 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
png.6:${PORTSDIR}/graphics/png \
xml2:${PORTSDIR}/textproc/libxml2
+CONFLICTS_INSTALL= wine-1.5.*
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
- --without-alsa --without-capi --with-glu \
+ --without-alsa --without-capi --without-dbus --with-glu \
--without-gphoto --without-gsm --without-gstreamer \
- --with-opengl --without-mpg123 --with-oss \
- --without-sane --without-tiff \
+ --with-opengl --without-mpg123 --without-opencl \
+ --with-oss --without-sane --without-tiff \
--without-v4l --without-xcomposite --without-xinerama \
--with-xinput2 --with-xrandr
CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"