aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-11-02 07:32:10 +0800
committergerald <gerald@FreeBSD.org>2013-11-02 07:32:10 +0800
commitcc058e4422ad726d40c548748dd3584ff44561d7 (patch)
tree2aad2437de2cc990af648f6a3509252a5f3001f0 /emulators/wine
parente5e9fac783ac3e4d0902c66eb4c17b3f58ccc733 (diff)
downloadfreebsd-ports-gnome-cc058e4422ad726d40c548748dd3584ff44561d7.tar.gz
freebsd-ports-gnome-cc058e4422ad726d40c548748dd3584ff44561d7.tar.zst
freebsd-ports-gnome-cc058e4422ad726d40c548748dd3584ff44561d7.zip
Update to Wine 1.6 which represents 16 months of development effort and
some 10,000 individual changes (see below). [1] STAGEify, follow the new LIB_DEPENDS standard, replace USE_GMAKE by USES. == User interface - Window transparency is supported, including both color keying and alpha blending transparency. - All window rendering is done on the client-side using the DIB engine (except for OpenGL rendering). This means that rendering to windows or bitmaps gives identical results. - Common dialogs correctly scale with the screen DPI resolution. - In virtual desktop mode, shortcuts placed in the Desktop folder are displayed on the desktop, and can be used to launch applications. - The HTML Help control has better support for non-ASCII characters, and for multiple help windows. - Custom painting and images are better supported in listview controls. - Input validation is improved in the date and calendar controls. == X11 driver - X11 server-side font rendering is no longer supported. All fonts are rendered client-side using FreeType. - The big lock around all X11 calls has been removed, we rely on the X libraries internal locking for thread safety. - XRandR versions 1.2 and 1.3 are supported. == Graphics - There are significant performance improvements in the DIB engine, particularly for text rendering, bitmap stretching, alpha blending, and gradients. - Bounds tracking is supported for all graphics primitives, to enable copying only the modified portions of a bitmap. - OpenGL rendering is supported in device-independent bitmaps using libOSMesa. - Brush dithering is implemented in the DIB engine. - Path gradients are implemented in GdiPlus. - More image codecs features are implemented, including JPEG encoding, palette formats, and meta-data support for various image types. == Text and fonts - Sub-pixel font anti-aliasing is supported in the DIB engine, using the system anti-aliasing configuration from FontConfig. - Dynamic loading of scalable font resources is supported. - Text layout in Uniscribe supports character-specific position adjustments. Right-to-left text handling is also improved. - There is an initial implementation of the DirectWrite text layout engine. - Built-in fonts are more complete, with the addition of FixedSys and Wingdings fonts, more high-resolution pixel fonts, and a wider range of glyphs in the existing fonts, notably Arabic glyphs in Tahoma. - Bi-directional text support is improved in the RichEdit control. == Input devices - The raw input API is supported for keyboard and mouse input. - There is a joystick applet in the control panel, to allow configuring joysticks and testing their behavior. == Kernel - DOSBox is tried first when running a DOS application. The Wine DOS support is only used as a fallback when DOSBox cannot be found, and will be removed in a future release. - A monotonic time counter is used on platforms that support it, to make timers more robust against system time changes. - File times are reported with nanosecond resolution. - Wine can be configured to report the Windows version as 'Windows 8'. == OLE / COM - The typelib writer is reimplemented for better compatibility. - OLE DB supports more data types and conversions. - OLE automation manages a cache of string allocations for better performance and compatibility. == Internet and networking - HTTPS connections use GnuTLS. OpenSSL is no longer used. - The TLS 1.1 and TLS 1.2 protocols are enabled by default, with automatic fallback to TLS 1.0. The SSL2 protocol is disabled by default. - Security certificate validation errors are handled better. - NTLM and Negotiate authentication protocols are supported. - ActiveX controls can be downloaded and installed automatically. - Internet proxy bypass is supported, and can be enabled either through the registry or with the no_proxy environment variable. - Broadcast packets can be received on interface-bound sockets, which is needed for some networked multi-player games. - The Server Name Indication TLS extension is supported. - Persistent cookies are supported, and URL cache files are managed better. The Internet control panel allows clearing saved cookies and cache files. - Punycode encoding for Internationalized Domain Names is supported. - JavaScript performance is improved. The built-in JavaScript engine is preferred over the Gecko one in most cases. - Many more built-in functions of VBScript are implemented. Regular expressions are also supported. == Direct3D - The Direct3D 9Ex implementation is more complete. In particular: - IDirect3DDevice9Ex::PresentEx is implemented. - IDirect3DDevice9Ex::ResetEx is implemented. - Various Direct3D 9Ex display mode handling functions are implemented. - Direct3D 9Ex style video memory accounting is implemented. - Like the X11 driver, WineD3D no longer uses the big X11 lock when making GL calls. - The WineD3D graphics card database is updated to recognize more graphics cards. - The fallback card detection code for unrecognized graphics cards is improved. This results in a more reasonable card being reported when the graphics card is not already in the WineD3D database. - WineD3D has GLSL based implementations of Direct3D fixed-function vertex and fragment processing. In some cases this allows functionality that's not present in fixed-function OpenGL to be implemented, in other cases it allows functionality to be implemented in a more efficient way. - On drivers that support it, GL_ARB_debug_output is used to get more detailed debugging output from the OpenGL driver. - On drivers that support it, GL_ARB_framebuffer_sRGB is used for rendering to frame buffers in the sRGB color space. - On drivers that support it, GL_ARB_instanced_arrays is used for more efficient instanced drawing. - On drivers that support it, and return useful information, GL_ARB_internalformat_query2 is used for more accurate reporting of surface / texture format capabilities. - There is an initial implementation of a HLSL compiler. - Improvements to various parts of the D3DX9 implementation, including: - The surface and texture handling functions. This includes code for loading, saving, filling, and rendering to surfaces and textures. - The effects framework. - The constant table implementation. - A number of spherical harmonics functions have been implemented. - Support for .x files. - Improvements to the Direct3D 10 implementation, including: - Support for more shader model 4 opcodes and register types. - Support for shader model 4 indirect addressing. - Initial geometry shader support. - Improved binary effect parsing. - Support for Direct3D 10 style instanced draws, using GL_ARB_draw_instanced. == DirectDraw - Vertex buffers are created with WINED3DUSAGE_DYNAMIC when locked with DDLOCK_DISCARDCONTENTS, resulting in improved performance in some cases. - The 2D-only fallback in WineD3D for using DirectDraw without a working OpenGL implementation is more robust. Note that this still isn't a recommended configuration. == Audio and video - DirectSound has a better resampler. - Audio device enumeration is improved, and multi-channel devices are better supported. - VMR-9 video rendering is implemented. == Printer support - The PPD files of already installed printers are automatically refreshed when needed. - Printing resolution can be configured from the print dialog. - Simulated italic fonts can be printed. == Internationalization - Japanese vertical text is correctly supported. - Translated font names are used when there is a match for the current language. == Built-in applications - The new 'netstat' application displays information about active network connections. - The 'cabarc' application supports multi-cabinet archives. - The 'attrib' application supports recursing in sub-directories. - The 'ipconfig' application can display IPv6 addresses. - The 'start' application allows setting process priority and affinity. - The 'cmd' application support arithmetic variable expansion, comparison operators, and various extra features in 'for' loops. - The Winedump tool can display the contents of typelib files. - The Fnt2bdf tool has been removed since X11 server-side fonts are no longer used. == Miscellaneous - XML namespaces are better supported. XML parsing is also implemented in the XMLLite library. - Windows Management Instrumentation (WMI) is implemented, with a wide range of WBEM system classes. - A number of forwarding libraries are added to support the API Sets feature added in Windows 8. - More of the latest functions of the C runtime are implemented, particularly the locale functions. Exception handling and RTTI are supported on 64-bit. - The standard C++ class libraries are more complete, particularly the math functions and the stream classes. PR: 182099 [1]
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile57
-rw-r--r--emulators/wine/distinfo4
-rw-r--r--emulators/wine/pkg-plist150
3 files changed, 170 insertions, 41 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index bb66501eb5a1..23db92b8f7f8 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 1.4.1
-PORTREVISION= 2
+DISTVERSION= 1.6
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -17,12 +16,12 @@ LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
CONFLICTS_INSTALL= i386-wine-* wine-1.5* wine-1.7*
@@ -43,16 +42,9 @@ WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
.endif
-MAN1= msiexec.1 notepad.1 regedit.1 regsvr32.1 widl.1 wine.1 \
- wineboot.1 winebuild.1 winecfg.1 wineconsole.1 winedbg.1 \
- winedump.1 winefile.1 winegcc.1 winemaker.1 winemine.1 \
- winepath.1 wineserver.1 wmc.1 wrc.1
-MLINKS= winegcc.1 winecpp.1 \
- winegcc.1 wineg++.1
ONLY_FOR_ARCHS= i386
-USES= bison
+USES= bison gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GL= glu
USE_XORG= xcursor xi xpm xrandr xrender
@@ -70,12 +62,11 @@ PORTDATA= fonts/ generic.ppd l_intl.nls wine.inf
PORTSCOUT= limitw:1,even
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+= --with-cups
-LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
.else
CONFIGURE_ARGS+= --without-cups
.endif
@@ -86,14 +77,14 @@ RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
.if ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+= --with-gnutls
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+= --without-gnutls
.endif
.if ${PORT_OPTIONS:MHAL}
CONFIGURE_ARGS+= --with-hal
-LIB_DEPENDS+= hal:${PORTSDIR}/sysutils/hal
+LIB_DEPENDS+= libhal.so:${PORTSDIR}/sysutils/hal
.else
CONFIGURE_ARGS+= --without-hal
.endif
@@ -107,7 +98,7 @@ CONFIGURE_ARGS+= --without-ldap
.if ${PORT_OPTIONS:MLIBXSLT}
CONFIGURE_ARGS+= --with-xslt
-LIB_DEPENDS+= xslt:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS+= libxslt.so:${PORTSDIR}/textproc/libxslt
.else
CONFIGURE_ARGS+= --without-xslt
.endif
@@ -141,27 +132,17 @@ pre-build:
cd ${WRKSRC} && ${GMAKE} depend
post-install:
- @${RM} -f ${MAN1PREFIX}/man/de.UTF-8/man1/wine.1 \
- ${MAN1PREFIX}/man/de.UTF-8/man1/winemaker.1 \
- ${MAN1PREFIX}/man/de.UTF-8/man1/wineserver.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wine.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/winemaker.1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1/wineserver.1 \
- ${MAN1PREFIX}/man/pl.UTF-8/man1/wine.1
- @-${RMDIR} -p ${MAN1PREFIX}/man/de.UTF-8/man1 \
- ${MAN1PREFIX}/man/fr.UTF-8/man1 \
- ${MAN1PREFIX}/man/pl.UTF-8/man1
- @${MV} -f ${WINELIBDIR}/libwine.so.1.0 ${WINELIBDIR}/libwine.so.1
- @${LN} -sf libwine.so.1 ${WINELIBDIR}/libwine.so
+ @${MV} -f ${STAGEDIR}${WINELIBDIR}/libwine.so.1.0 \
+ ${STAGEDIR}${WINELIBDIR}/libwine.so.1
+ @${LN} -sf libwine.so.1 ${STAGEDIR}/${WINELIBDIR}/libwine.so
.if !defined(NOPORTDOCS)
- -@${MKDIR} ${DOCSDIR}
+ -@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README ANNOUNCE AUTHORS
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
- @${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${DOCSDIR}/README.winedbg
- @${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
+ @${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${STAGEDIR}${DOCSDIR}/README.winedbg
+ @${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${STAGEDIR}${DOCSDIR}/README.winedump
.endif
- @${MKDIR} ${DESKTOPDIR}
@${ECHO}
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index a664adc9b471..e34ce573b849 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wine-1.4.1.tar.bz2) = 3c233e3811e42c2f3623413783dbcd0f2288014b5645211f669ffd0ba6ae1856
-SIZE (wine-1.4.1.tar.bz2) = 20104401
+SHA256 (wine-1.6.tar.bz2) = e1f130efbdcbfa211ca56ee03357ccd17a31443889b4feebdcb88248520b42ae
+SIZE (wine-1.6.tar.bz2) = 21124403
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 567a0002d9bd..2bbe35532703 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -86,13 +86,16 @@ include/wine/windows/amstream.h
include/wine/windows/amstream.idl
include/wine/windows/amvideo.h
include/wine/windows/amvideo.idl
+include/wine/windows/appcompatapi.h
include/wine/windows/appmgmt.h
include/wine/windows/asptlb.h
include/wine/windows/asptlb.idl
include/wine/windows/asynot.idl
include/wine/windows/asysta.idl
+include/wine/windows/atlbase.h
include/wine/windows/atliface.h
include/wine/windows/atliface.idl
+include/wine/windows/atlwin.h
include/wine/windows/audevcod.h
include/wine/windows/audioclient.h
include/wine/windows/audioclient.idl
@@ -197,6 +200,7 @@ include/wine/windows/dbs.idl
include/wine/windows/dbt.h
include/wine/windows/dciddi.h
include/wine/windows/dciman.h
+include/wine/windows/dcommon.h
include/wine/windows/dde.h
include/wine/windows/dde.rh
include/wine/windows/ddeml.h
@@ -211,6 +215,7 @@ include/wine/windows/devicetopology.h
include/wine/windows/devicetopology.idl
include/wine/windows/devpkey.h
include/wine/windows/devpropdef.h
+include/wine/windows/difxapi.h
include/wine/windows/digitalv.h
include/wine/windows/dimm.h
include/wine/windows/dimm.idl
@@ -224,6 +229,7 @@ include/wine/windows/dls1.h
include/wine/windows/dls2.h
include/wine/windows/dmdls.h
include/wine/windows/dmerror.h
+include/wine/windows/dmksctrl.h
include/wine/windows/dmo.h
include/wine/windows/dmoreg.h
include/wine/windows/dmort.h
@@ -252,6 +258,10 @@ include/wine/windows/dsound.h
include/wine/windows/dsrole.h
include/wine/windows/dvdmedia.h
include/wine/windows/dwmapi.h
+include/wine/windows/dwrite.h
+include/wine/windows/dwrite.idl
+include/wine/windows/dwrite_1.h
+include/wine/windows/dwrite_1.idl
include/wine/windows/dxdiag.h
include/wine/windows/dxerr8.h
include/wine/windows/dxerr9.h
@@ -402,6 +412,8 @@ include/wine/windows/msctf.idl
include/wine/windows/msdadc.h
include/wine/windows/msdadc.idl
include/wine/windows/msdaguid.h
+include/wine/windows/msdasc.h
+include/wine/windows/msdasc.idl
include/wine/windows/mshtmcid.h
include/wine/windows/mshtmdid.h
include/wine/windows/mshtmhst.h
@@ -410,6 +422,8 @@ include/wine/windows/mshtml.h
include/wine/windows/mshtml.idl
include/wine/windows/msi.h
include/wine/windows/msidefs.h
+include/wine/windows/msident.h
+include/wine/windows/msident.idl
include/wine/windows/msinkaut.h
include/wine/windows/msinkaut.idl
include/wine/windows/msiquery.h
@@ -526,6 +540,7 @@ include/wine/windows/rpcsal.h
include/wine/windows/rstbas.idl
include/wine/windows/rstinf.idl
include/wine/windows/rstloc.idl
+include/wine/windows/rstnot.idl
include/wine/windows/rtutils.h
include/wine/windows/scarderr.h
include/wine/windows/schannel.h
@@ -588,8 +603,20 @@ include/wine/windows/tmschema.h
include/wine/windows/tom.h
include/wine/windows/tom.idl
include/wine/windows/traffic.h
+include/wine/windows/transact.h
+include/wine/windows/transact.idl
include/wine/windows/twain.h
+include/wine/windows/txcoord.h
+include/wine/windows/txcoord.idl
+include/wine/windows/txdtc.h
+include/wine/windows/txdtc.idl
include/wine/windows/udpmib.h
+include/wine/windows/uiautomation.h
+include/wine/windows/uiautomationclient.h
+include/wine/windows/uiautomationclient.idl
+include/wine/windows/uiautomationcore.h
+include/wine/windows/uiautomationcore.idl
+include/wine/windows/uiautomationcoreapi.h
include/wine/windows/unknwn.h
include/wine/windows/unknwn.idl
include/wine/windows/urlhist.h
@@ -612,6 +639,8 @@ include/wine/windows/vsstyle.h
include/wine/windows/vssym32.h
include/wine/windows/wbemcli.h
include/wine/windows/wbemcli.idl
+include/wine/windows/wbemprov.h
+include/wine/windows/wbemprov.idl
include/wine/windows/werapi.h
include/wine/windows/wfext.h
include/wine/windows/wia.h
@@ -632,6 +661,7 @@ include/wine/windows/windns.h
include/wine/windows/windows.h
include/wine/windows/windowsx.h
include/wine/windows/winerror.h
+include/wine/windows/winevt.h
include/wine/windows/wingdi.h
include/wine/windows/winhttp.h
include/wine/windows/wininet.h
@@ -663,6 +693,12 @@ include/wine/windows/winuser.h
include/wine/windows/winuser.rh
include/wine/windows/winver.h
include/wine/windows/wmistr.h
+include/wine/windows/wmiutils.h
+include/wine/windows/wmiutils.idl
+include/wine/windows/wmsbuffer.h
+include/wine/windows/wmsbuffer.idl
+include/wine/windows/wmsdkidl.h
+include/wine/windows/wmsdkidl.idl
include/wine/windows/wnaspi32.h
include/wine/windows/wownt32.h
include/wine/windows/wpcapi.h
@@ -713,10 +749,26 @@ lib/wine/actxprxy.dll.so
lib/wine/advapi32.dll.so
lib/wine/advpack.dll.so
lib/wine/amstream.dll.so
+lib/wine/api-ms-win-core-localregistry-l1-1-0.dll.so
+lib/wine/api-ms-win-core-processthreads-l1-1-0.dll.so
+lib/wine/api-ms-win-core-winrt-error-l1-1-0.dll.so
+lib/wine/api-ms-win-core-winrt-string-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-advapi32-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-advapi32-l2-1-0.dll.so
+lib/wine/api-ms-win-downlevel-normaliz-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-ole32-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-shell32-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-shlwapi-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-shlwapi-l2-1-0.dll.so
+lib/wine/api-ms-win-downlevel-user32-l1-1-0.dll.so
+lib/wine/api-ms-win-downlevel-version-l1-1-0.dll.so
+lib/wine/api-ms-win-security-base-l1-1-0.dll.so
lib/wine/apphelp.dll.so
lib/wine/appwiz.cpl.so
lib/wine/aspnet_regiis.exe.so
lib/wine/atl.dll.so
+lib/wine/atl100.dll.so
+lib/wine/atl80.dll.so
lib/wine/attrib.exe.so
lib/wine/authz.dll.so
lib/wine/avicap32.dll.so
@@ -741,6 +793,7 @@ lib/wine/comm.drv16.so
lib/wine/commdlg.dll16.so
lib/wine/compobj.dll16.so
lib/wine/compstui.dll.so
+lib/wine/conhost.exe.so
lib/wine/control.exe.so
lib/wine/credui.dll.so
lib/wine/crtdll.dll.so
@@ -756,6 +809,7 @@ lib/wine/ctl3d32.dll.so
lib/wine/ctl3dv2.dll16.so
lib/wine/d3d10.dll.so
lib/wine/d3d10core.dll.so
+lib/wine/d3d11.dll.so
lib/wine/d3d8.dll.so
lib/wine/d3d9.dll.so
lib/wine/d3dcompiler_33.dll.so
@@ -811,6 +865,7 @@ lib/wine/ddraw.dll.so
lib/wine/ddrawex.dll.so
lib/wine/devenum.dll.so
lib/wine/dhcpcsvc.dll.so
+lib/wine/difxapi.dll.so
lib/wine/dinput.dll.so
lib/wine/dinput8.dll.so
lib/wine/dispdib.dll16.so
@@ -838,6 +893,7 @@ lib/wine/dsound.dll.so
lib/wine/dssenh.dll.so
lib/wine/dswave.dll.so
lib/wine/dwmapi.dll.so
+lib/wine/dwrite.dll.so
lib/wine/dxdiag.exe.so
lib/wine/dxdiagn.dll.so
lib/wine/dxgi.dll.so
@@ -853,10 +909,26 @@ lib/wine/fakedlls/actxprxy.dll
lib/wine/fakedlls/advapi32.dll
lib/wine/fakedlls/advpack.dll
lib/wine/fakedlls/amstream.dll
+lib/wine/fakedlls/api-ms-win-core-localregistry-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-core-processthreads-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-core-winrt-error-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-core-winrt-string-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-advapi32-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-advapi32-l2-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-normaliz-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-ole32-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-shell32-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-shlwapi-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-shlwapi-l2-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-user32-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-downlevel-version-l1-1-0.dll
+lib/wine/fakedlls/api-ms-win-security-base-l1-1-0.dll
lib/wine/fakedlls/apphelp.dll
lib/wine/fakedlls/appwiz.cpl
lib/wine/fakedlls/aspnet_regiis.exe
lib/wine/fakedlls/atl.dll
+lib/wine/fakedlls/atl100.dll
+lib/wine/fakedlls/atl80.dll
lib/wine/fakedlls/attrib.exe
lib/wine/fakedlls/authz.dll
lib/wine/fakedlls/avicap32.dll
@@ -881,6 +953,7 @@ lib/wine/fakedlls/comm.drv16
lib/wine/fakedlls/commdlg.dll16
lib/wine/fakedlls/compobj.dll16
lib/wine/fakedlls/compstui.dll
+lib/wine/fakedlls/conhost.exe
lib/wine/fakedlls/control.exe
lib/wine/fakedlls/credui.dll
lib/wine/fakedlls/crtdll.dll
@@ -896,6 +969,7 @@ lib/wine/fakedlls/ctl3d32.dll
lib/wine/fakedlls/ctl3dv2.dll16
lib/wine/fakedlls/d3d10.dll
lib/wine/fakedlls/d3d10core.dll
+lib/wine/fakedlls/d3d11.dll
lib/wine/fakedlls/d3d8.dll
lib/wine/fakedlls/d3d9.dll
lib/wine/fakedlls/d3dcompiler_33.dll
@@ -951,6 +1025,7 @@ lib/wine/fakedlls/ddraw.dll
lib/wine/fakedlls/ddrawex.dll
lib/wine/fakedlls/devenum.dll
lib/wine/fakedlls/dhcpcsvc.dll
+lib/wine/fakedlls/difxapi.dll
lib/wine/fakedlls/dinput.dll
lib/wine/fakedlls/dinput8.dll
lib/wine/fakedlls/dispdib.dll16
@@ -978,6 +1053,7 @@ lib/wine/fakedlls/dsound.dll
lib/wine/fakedlls/dssenh.dll
lib/wine/fakedlls/dswave.dll
lib/wine/fakedlls/dwmapi.dll
+lib/wine/fakedlls/dwrite.dll
lib/wine/fakedlls/dxdiag.exe
lib/wine/fakedlls/dxdiagn.dll
lib/wine/fakedlls/dxgi.dll
@@ -987,6 +1063,7 @@ lib/wine/fakedlls/explorer.exe
lib/wine/fakedlls/explorerframe.dll
lib/wine/fakedlls/extrac32.exe
lib/wine/fakedlls/faultrep.dll
+lib/wine/fakedlls/findstr.exe
lib/wine/fakedlls/fltlib.dll
lib/wine/fakedlls/fusion.dll
lib/wine/fakedlls/fwpuclnt.dll
@@ -1026,6 +1103,7 @@ lib/wine/fakedlls/ipconfig.exe
lib/wine/fakedlls/iphlpapi.dll
lib/wine/fakedlls/itircl.dll
lib/wine/fakedlls/itss.dll
+lib/wine/fakedlls/joy.cpl
lib/wine/fakedlls/jscript.dll
lib/wine/fakedlls/kernel32.dll
lib/wine/fakedlls/keyboard.drv16
@@ -1044,6 +1122,7 @@ lib/wine/fakedlls/mcicda.dll
lib/wine/fakedlls/mciqtz32.dll
lib/wine/fakedlls/mciseq.dll
lib/wine/fakedlls/mciwave.dll
+lib/wine/fakedlls/mgmtapi.dll
lib/wine/fakedlls/midimap.dll
lib/wine/fakedlls/mlang.dll
lib/wine/fakedlls/mmcndmgr.dll
@@ -1073,12 +1152,14 @@ lib/wine/fakedlls/mshta.exe
lib/wine/fakedlls/mshtml.dll
lib/wine/fakedlls/mshtml.tlb
lib/wine/fakedlls/msi.dll
+lib/wine/fakedlls/msident.dll
lib/wine/fakedlls/msiexec.exe
lib/wine/fakedlls/msimg32.dll
lib/wine/fakedlls/msimsg.dll
lib/wine/fakedlls/msimtf.dll
lib/wine/fakedlls/msisip.dll
lib/wine/fakedlls/msisys.ocx
+lib/wine/fakedlls/msls31.dll
lib/wine/fakedlls/msnet32.dll
lib/wine/fakedlls/mspatcha.dll
lib/wine/fakedlls/msrle32.dll
@@ -1086,13 +1167,17 @@ lib/wine/fakedlls/mssign32.dll
lib/wine/fakedlls/mssip32.dll
lib/wine/fakedlls/mstask.dll
lib/wine/fakedlls/msvcirt.dll
+lib/wine/fakedlls/msvcm80.dll
+lib/wine/fakedlls/msvcm90.dll
lib/wine/fakedlls/msvcp100.dll
+lib/wine/fakedlls/msvcp110.dll
lib/wine/fakedlls/msvcp60.dll
lib/wine/fakedlls/msvcp70.dll
lib/wine/fakedlls/msvcp71.dll
lib/wine/fakedlls/msvcp80.dll
lib/wine/fakedlls/msvcp90.dll
lib/wine/fakedlls/msvcr100.dll
+lib/wine/fakedlls/msvcr110.dll
lib/wine/fakedlls/msvcr70.dll
lib/wine/fakedlls/msvcr71.dll
lib/wine/fakedlls/msvcr80.dll
@@ -1114,6 +1199,7 @@ lib/wine/fakedlls/nddeapi.dll
lib/wine/fakedlls/net.exe
lib/wine/fakedlls/netapi32.dll
lib/wine/fakedlls/netsh.exe
+lib/wine/fakedlls/netstat.exe
lib/wine/fakedlls/newdev.dll
lib/wine/fakedlls/ngen.exe
lib/wine/fakedlls/normaliz.dll
@@ -1126,6 +1212,7 @@ lib/wine/fakedlls/ntprint.dll
lib/wine/fakedlls/objsel.dll
lib/wine/fakedlls/odbc32.dll
lib/wine/fakedlls/odbccp32.dll
+lib/wine/fakedlls/odbccu32.dll
lib/wine/fakedlls/ole2.dll16
lib/wine/fakedlls/ole2conv.dll16
lib/wine/fakedlls/ole2disp.dll16
@@ -1190,7 +1277,9 @@ lib/wine/fakedlls/sc.exe
lib/wine/fakedlls/scarddlg.dll
lib/wine/fakedlls/sccbase.dll
lib/wine/fakedlls/schannel.dll
+lib/wine/fakedlls/schtasks.exe
lib/wine/fakedlls/scrrun.dll
+lib/wine/fakedlls/scsiport.sys
lib/wine/fakedlls/secedit.exe
lib/wine/fakedlls/secur32.dll
lib/wine/fakedlls/security.dll
@@ -1249,6 +1338,8 @@ lib/wine/fakedlls/usp10.dll
lib/wine/fakedlls/uxtheme.dll
lib/wine/fakedlls/vbscript.dll
lib/wine/fakedlls/vcomp.dll
+lib/wine/fakedlls/vcomp100.dll
+lib/wine/fakedlls/vcomp90.dll
lib/wine/fakedlls/vdhcp.vxd
lib/wine/fakedlls/vdmdbg.dll
lib/wine/fakedlls/ver.dll16
@@ -1262,13 +1353,16 @@ lib/wine/fakedlls/vwin32.vxd
lib/wine/fakedlls/w32skrnl.dll
lib/wine/fakedlls/w32sys.dll16
lib/wine/fakedlls/wbemprox.dll
+lib/wine/fakedlls/webservices.dll
lib/wine/fakedlls/wer.dll
+lib/wine/fakedlls/wevtapi.dll
lib/wine/fakedlls/wiaservc.dll
lib/wine/fakedlls/win32s16.dll16
lib/wine/fakedlls/win87em.dll16
lib/wine/fakedlls/winaspi.dll16
lib/wine/fakedlls/windebug.dll16
lib/wine/fakedlls/windowscodecs.dll
+lib/wine/fakedlls/windowscodecsext.dll
lib/wine/fakedlls/wineboot.exe
lib/wine/fakedlls/winebrowser.exe
lib/wine/fakedlls/winecfg.exe
@@ -1310,6 +1404,7 @@ lib/wine/fakedlls/wldap32.dll
lib/wine/fakedlls/wmi.dll
lib/wine/fakedlls/wmic.exe
lib/wine/fakedlls/wmiutils.dll
+lib/wine/fakedlls/wmvcore.dll
lib/wine/fakedlls/wnaspi32.dll
lib/wine/fakedlls/wordpad.exe
lib/wine/fakedlls/wow32.dll
@@ -1317,10 +1412,12 @@ lib/wine/fakedlls/write.exe
lib/wine/fakedlls/ws2_32.dll
lib/wine/fakedlls/wscript.exe
lib/wine/fakedlls/wshom.ocx
+lib/wine/fakedlls/wsnmp32.dll
lib/wine/fakedlls/wsock32.dll
lib/wine/fakedlls/wtsapi32.dll
lib/wine/fakedlls/wuapi.dll
lib/wine/fakedlls/wuaueng.dll
+lib/wine/fakedlls/wusa.exe
lib/wine/fakedlls/xapofx1_1.dll
lib/wine/fakedlls/xcopy.exe
lib/wine/fakedlls/xinput1_1.dll
@@ -1330,7 +1427,9 @@ lib/wine/fakedlls/xinput9_1_0.dll
lib/wine/fakedlls/xmllite.dll
lib/wine/fakedlls/xolehlp.dll
lib/wine/fakedlls/xpsprint.dll
+lib/wine/fakedlls/xpssvcs.dll
lib/wine/faultrep.dll.so
+lib/wine/findstr.exe.so
lib/wine/fltlib.dll.so
lib/wine/fusion.dll.so
lib/wine/fwpuclnt.dll.so
@@ -1370,6 +1469,7 @@ lib/wine/ipconfig.exe.so
lib/wine/iphlpapi.dll.so
lib/wine/itircl.dll.so
lib/wine/itss.dll.so
+lib/wine/joy.cpl.so
lib/wine/jscript.dll.so
lib/wine/kernel32.dll.so
lib/wine/keyboard.drv16.so
@@ -1381,6 +1481,8 @@ lib/wine/libadsiid.a
lib/wine/libadvapi32.def
lib/wine/libadvpack.def
lib/wine/libatl.def
+lib/wine/libatl100.def
+lib/wine/libatl80.def
lib/wine/libavicap32.def
lib/wine/libavifil32.def
lib/wine/libavrt.def
@@ -1422,6 +1524,7 @@ lib/wine/libdplayx.def
lib/wine/libdpnet.def
lib/wine/libdsound.def
lib/wine/libdwmapi.def
+lib/wine/libdwrite.def
lib/wine/libdxerr8.a
lib/wine/libdxerr9.a
lib/wine/libdxgi.def
@@ -1432,6 +1535,7 @@ lib/wine/libgdiplus.def
lib/wine/libglu32.def
lib/wine/libhid.def
lib/wine/libhlink.def
+lib/wine/libhtmlhelp.def
lib/wine/libieframe.def
lib/wine/libimagehlp.def
lib/wine/libimm32.def
@@ -1504,6 +1608,7 @@ lib/wine/libspoolss.def
lib/wine/libsti.def
lib/wine/libstrmbase.a
lib/wine/libstrmiids.a
+lib/wine/libsxs.def
lib/wine/libtapi32.def
lib/wine/libunicows.def
lib/wine/liburl.def
@@ -1516,8 +1621,10 @@ lib/wine/libuuid.a
lib/wine/libuxtheme.def
lib/wine/libvdmdbg.def
lib/wine/libversion.def
+lib/wine/libwebservices.def
lib/wine/libwer.def
lib/wine/libwindowscodecs.def
+lib/wine/libwindowscodecsext.def
lib/wine/libwinecrt0.a
lib/wine/libwined3d.def
lib/wine/libwinhttp.def
@@ -1548,6 +1655,7 @@ lib/wine/mcicda.dll.so
lib/wine/mciqtz32.dll.so
lib/wine/mciseq.dll.so
lib/wine/mciwave.dll.so
+lib/wine/mgmtapi.dll.so
lib/wine/midimap.dll.so
lib/wine/mlang.dll.so
lib/wine/mmcndmgr.dll.so
@@ -1577,12 +1685,14 @@ lib/wine/mshta.exe.so
lib/wine/mshtml.dll.so
lib/wine/mshtml.tlb.so
lib/wine/msi.dll.so
+lib/wine/msident.dll.so
lib/wine/msiexec.exe.so
lib/wine/msimg32.dll.so
lib/wine/msimsg.dll.so
lib/wine/msimtf.dll.so
lib/wine/msisip.dll.so
lib/wine/msisys.ocx.so
+lib/wine/msls31.dll.so
lib/wine/msnet32.dll.so
lib/wine/mspatcha.dll.so
lib/wine/msrle32.dll.so
@@ -1590,13 +1700,17 @@ lib/wine/mssign32.dll.so
lib/wine/mssip32.dll.so
lib/wine/mstask.dll.so
lib/wine/msvcirt.dll.so
+lib/wine/msvcm80.dll.so
+lib/wine/msvcm90.dll.so
lib/wine/msvcp100.dll.so
+lib/wine/msvcp110.dll.so
lib/wine/msvcp60.dll.so
lib/wine/msvcp70.dll.so
lib/wine/msvcp71.dll.so
lib/wine/msvcp80.dll.so
lib/wine/msvcp90.dll.so
lib/wine/msvcr100.dll.so
+lib/wine/msvcr110.dll.so
lib/wine/msvcr70.dll.so
lib/wine/msvcr71.dll.so
lib/wine/msvcr80.dll.so
@@ -1618,6 +1732,7 @@ lib/wine/nddeapi.dll.so
lib/wine/net.exe.so
lib/wine/netapi32.dll.so
lib/wine/netsh.exe.so
+lib/wine/netstat.exe.so
lib/wine/newdev.dll.so
lib/wine/ngen.exe.so
lib/wine/normaliz.dll.so
@@ -1630,6 +1745,7 @@ lib/wine/ntprint.dll.so
lib/wine/objsel.dll.so
lib/wine/odbc32.dll.so
lib/wine/odbccp32.dll.so
+lib/wine/odbccu32.dll.so
lib/wine/ole2.dll16.so
lib/wine/ole2conv.dll16.so
lib/wine/ole2disp.dll16.so
@@ -1694,7 +1810,9 @@ lib/wine/sc.exe.so
lib/wine/scarddlg.dll.so
lib/wine/sccbase.dll.so
lib/wine/schannel.dll.so
+lib/wine/schtasks.exe.so
lib/wine/scrrun.dll.so
+lib/wine/scsiport.sys.so
lib/wine/secedit.exe.so
lib/wine/secur32.dll.so
lib/wine/security.dll.so
@@ -1753,6 +1871,8 @@ lib/wine/usp10.dll.so
lib/wine/uxtheme.dll.so
lib/wine/vbscript.dll.so
lib/wine/vcomp.dll.so
+lib/wine/vcomp100.dll.so
+lib/wine/vcomp90.dll.so
lib/wine/vdhcp.vxd.so
lib/wine/vdmdbg.dll.so
lib/wine/ver.dll16.so
@@ -1766,13 +1886,16 @@ lib/wine/vwin32.vxd.so
lib/wine/w32skrnl.dll.so
lib/wine/w32sys.dll16.so
lib/wine/wbemprox.dll.so
+lib/wine/webservices.dll.so
lib/wine/wer.dll.so
+lib/wine/wevtapi.dll.so
lib/wine/wiaservc.dll.so
lib/wine/win32s16.dll16.so
lib/wine/win87em.dll16.so
lib/wine/winaspi.dll16.so
lib/wine/windebug.dll16.so
lib/wine/windowscodecs.dll.so
+lib/wine/windowscodecsext.dll.so
lib/wine/wineboot.exe.so
lib/wine/winebrowser.exe.so
lib/wine/winecfg.exe.so
@@ -1814,6 +1937,7 @@ lib/wine/wldap32.dll.so
lib/wine/wmi.dll.so
lib/wine/wmic.exe.so
lib/wine/wmiutils.dll.so
+lib/wine/wmvcore.dll.so
lib/wine/wnaspi32.dll.so
lib/wine/wordpad.exe.so
lib/wine/wow32.dll.so
@@ -1821,10 +1945,12 @@ lib/wine/write.exe.so
lib/wine/ws2_32.dll.so
lib/wine/wscript.exe.so
lib/wine/wshom.ocx.so
+lib/wine/wsnmp32.dll.so
lib/wine/wsock32.dll.so
lib/wine/wtsapi32.dll.so
lib/wine/wuapi.dll.so
lib/wine/wuaueng.dll.so
+lib/wine/wusa.exe.so
lib/wine/xapofx1_1.dll.so
lib/wine/xcopy.exe.so
lib/wine/xinput1_1.dll.so
@@ -1834,7 +1960,29 @@ lib/wine/xinput9_1_0.dll.so
lib/wine/xmllite.dll.so
lib/wine/xolehlp.dll.so
lib/wine/xpsprint.dll.so
-share/applications/wine.desktop
+lib/wine/xpssvcs.dll.so
+man/man1/msiexec.1.gz
+man/man1/notepad.1.gz
+man/man1/regedit.1.gz
+man/man1/regsvr32.1.gz
+man/man1/widl.1.gz
+man/man1/wine.1.gz
+man/man1/wineboot.1.gz
+man/man1/winebuild.1.gz
+man/man1/winecfg.1.gz
+man/man1/wineconsole.1.gz
+man/man1/winecpp.1.gz
+man/man1/winedbg.1.gz
+man/man1/winedump.1.gz
+man/man1/winefile.1.gz
+man/man1/wineg++.1.gz
+man/man1/winegcc.1.gz
+man/man1/winemaker.1.gz
+man/man1/winemine.1.gz
+man/man1/winepath.1.gz
+man/man1/wineserver.1.gz
+man/man1/wmc.1.gz
+man/man1/wrc.1.gz
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README