aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /emulators/wine
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index c4d207792e50..3f278370a351 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
png.6:${PORTSDIR}/graphics/png \
xml2:${PORTSDIR}/textproc/libxml2
-CPPFLAGS= "-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --with-glu \
@@ -36,8 +37,7 @@ CONFIGURE_ARGS+=--verbose --disable-tests \
--with-opengl --without-mpg123 --with-oss --without-sane \
--without-v4l --without-xcomposite --without-xinerama \
--with-xinput2 --with-xrandr
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- FLEX="${LOCALBASE}/bin/flex"
+CONFIGURE_ENV= FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine