aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>1995-10-07 08:25:10 +0800
committerse <se@FreeBSD.org>1995-10-07 08:25:10 +0800
commitabf8c1e329deedf4dd327005c44f21877e2dde96 (patch)
tree289b457278843cd9ca97eee8db87abe9b0db89d4 /emulators/wine
parent6b993ff3e1d39791c8dfb33d8ce5d40ef605ed18 (diff)
downloadfreebsd-ports-gnome-abf8c1e329deedf4dd327005c44f21877e2dde96.tar.gz
freebsd-ports-gnome-abf8c1e329deedf4dd327005c44f21877e2dde96.tar.zst
freebsd-ports-gnome-abf8c1e329deedf4dd327005c44f21877e2dde96.zip
Correct MASTER_SITES, add pre-configure and install targets.
Reviewed by: hsu (Jeffrey Hsu)
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile27
1 files changed, 19 insertions, 8 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index e3c4bcdda340..d5ab4771f754 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -1,28 +1,39 @@
# New ports collection makefile for: wine
# Version required: 951003
-# Date created: Sun Feb 5 16:12:09 1995
-# Whom: hsu
+# Date created: Fri Oct 6 23:43:28 MET 1995
+# Whom: se
#
-# $Id: Makefile,v 1.9 1995/07/13 01:13:20 asami Exp $
+# $Id: Makefile,v 1.10 1995/10/05 20:50:32 hsu Exp $
#
DATE= 951003
DISTNAME= Wine-${DATE}
PKGNAME= Wine-95.10.03
CATEGORIES+= emulation x11
-MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/ALPHA/wine/ \
+MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/ALPHA/wine/ \
ftp://aris.com/pub/linux/ALPHA/Wine/development/ \
ftp://tsx-11.mit.edu/pub/linux/ALPHA/Wine/development/ \
ftp://ftp.funet.fi/pub/OS/Linux/ALPHA/Wine/ \
- ftp://ftp.wonderland.org/Wine/
+ ftp://ftp.infomagic.com/pub/mirrors/linux/wine/development/
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= se@FreeBSD.ORG
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
WRKSRC= ${WRKDIR}/wine${DATE}
GNU_CONFIGURE= yes
-# wine doesn't come w/ an install rule
-NO_INSTALL= yes
+
+pre-configure:
+ @echo "WINE_INI_GLOBAL \"${PREFIX}/etc/wine.conf\"" \
+ >> ${WRKSRC}/autoconf.h
+
+install:
+ install -cs ${WRKSRC}/wine ${PREFIX}/bin
+ -@mkdir ${PREFIX}/etc 2>/dev/null
+ [ -f ${PREFIX}/etc/wine.conf ] \
+ || cp ${WRKSRC}/wine.ini ${PREFIX}/etc/wine.conf
+ cp ${WRKSRC}/wine.sym ${PREFIX}/etc
+ cp ${WRKSRC}/Wine.man ${PREFIX}/man/man1/wine.1
+ gzip -9f ${PREFIX}/man/man1/wine.1
.include <bsd.port.mk>