aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/wine
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-11-26 22:19:50 +0800
committergerald <gerald@FreeBSD.org>2013-11-26 22:19:50 +0800
commitce4fc35f3a42d718bb4d53a0c7afefe43f478f11 (patch)
tree8f048d2b6e46114ed8aa30d8da26d6a541473762 /emulators/wine
parent823a1ff1d377fcaa16f8db20e42c02ac0012919f (diff)
downloadfreebsd-ports-gnome-ce4fc35f3a42d718bb4d53a0c7afefe43f478f11.tar.gz
freebsd-ports-gnome-ce4fc35f3a42d718bb4d53a0c7afefe43f478f11.tar.zst
freebsd-ports-gnome-ce4fc35f3a42d718bb4d53a0c7afefe43f478f11.zip
Replace USE_GCC by USES=compiler:c11. [1]
Process two scripts installed with USES=shebangfix. [2] Wine 1.6 actually depends on lcms, not lcms2. [3] Suggested by: dbn [1] Reported by: dbn [2], fiziologus@gmail.com [3]
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 7812f81f7fe2..d9b5a8e87bf9 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
libpng15.so:${PORTSDIR}/graphics/png \
libxml2.so:${PORTSDIR}/textproc/libxml2
@@ -27,7 +27,6 @@ CONFLICTS_INSTALL= i386-wine-* wine-1.5* wine-1.7*
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--verbose --disable-tests \
--without-alsa --without-capi --without-dbus \
@@ -43,7 +42,8 @@ WINELIBDIR?= ${PREFIX}/lib
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine
.endif
ONLY_FOR_ARCHS= i386
-USES= bison gmake
+USES= bison compiler:c11 gmake shebangfix
+SHEBANG_FILES= tools/winemaker tools/winedump/function_grep.pl
USE_BZIP2= yes
USE_GL= glu
USE_XORG= xcursor xi xpm xrandr xrender