aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/xcpc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 05:20:28 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 05:20:28 +0800
commit0a21cb686357d0c6c0c66b1980acd9c7c9bc7949 (patch)
tree17f3405d36f74dd57d11bda9e7ecc80c2929914c /emulators/xcpc
parent394c57853a58fa1d046fd083ec8bb59d504821e6 (diff)
downloadfreebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.tar.gz
freebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.tar.zst
freebsd-ports-gnome-0a21cb686357d0c6c0c66b1980acd9c7c9bc7949.zip
Convert emulators to new options framework
Diffstat (limited to 'emulators/xcpc')
-rw-r--r--emulators/xcpc/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 3f3fef5556c0..131fef2865ee 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -23,33 +23,34 @@ LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
pcre.3:${PORTSDIR}/devel/pcre \
dsk.5:${PORTSDIR}/emulators/libdsk
-OPTIONS= MOTIF "With Motif widget set" on \
- ATHENA "With Athen widget set" off \
- XSHM "With XShm support" on \
- DEBUG "Turn debugging on" off
+OPTIONS_DEFINE= MOTIF ATHENA XSHM DEBUG
+OPTIONS_DEFAULT= MOTIF XSHM
+MOTIF_DESC= With Motif widget set
+ATHENA_DESC= With Athen widget set
+XSHM_DESC= With XShm support
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.else
CONFIGURE_ARGS+=--disable-debug
.endif
-.if defined(WITH_XSHM)
+.if ${PORT_OPTIONS:MXSHM}
CONFIGURE_ARGS+=--enable-xshm
.else
CONFIGURE_ARGS+=--disable-xshm
.endif
-.if defined(WITH_MOTIF)
+.if ${PORT_OPTIONS:MMOTIF}
USE_MOTIF=yes
CONFIGURE_ARGS+=--with-motif1
.else
CONFIGURE_ARGS+=--without-motif1
.endif
-.if defined(WITH_ATHENA)
+.if ${PORT_OPTIONS:MATHENA}
LIB_DEPENDS+= Xaw.8:${PORTSDIR}/x11-toolkits/libXaw
CONFIGURE_ARGS+=--with-athena
.else