aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/yabause
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /emulators/yabause
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'emulators/yabause')
-rw-r--r--emulators/yabause/Makefile2
-rw-r--r--emulators/yabause/files/patch-src__core.h2
2 files changed, 2 insertions, 2 deletions
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index 6d71b51b54cd..7c5eb8b866a2 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -12,7 +12,7 @@ COMMENT= Sega Saturn system emulator
LICENSE= GPLv2+
USES= cmake dos2unix openal:soft pkgconfig
-DOS2UNIX_FILES= src/qt/YabauseThread.cpp
+DOS2UNIX_FILES= src/qt/YabauseThread.cpp src/core.h
USE_XORG= xmu xrandr
USE_GL= gl glu glut
diff --git a/emulators/yabause/files/patch-src__core.h b/emulators/yabause/files/patch-src__core.h
index 30820f6aa7f6..fd63e919d7ca 100644
--- a/emulators/yabause/files/patch-src__core.h
+++ b/emulators/yabause/files/patch-src__core.h
@@ -9,5 +9,5 @@
#endif
+#endif
- #ifdef _MSC_VER
+ #ifdef _MSC_VER
# define BSWAP16(x) ((_byteswap_ushort((x) >> 16) << 16) | _byteswap_ushort((x)))