aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/zsnes
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
committernaddy <naddy@FreeBSD.org>2010-06-07 04:39:21 +0800
commita7e23ef2423b94523671d838b70763ecfea3ca60 (patch)
tree3d3fdf131c6f5d30a25430d16a62f0d82e33445f /emulators/zsnes
parent14d2f864caf57bceba3f0ac72ea827fafd27743d (diff)
downloadfreebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.gz
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.tar.zst
freebsd-ports-gnome-a7e23ef2423b94523671d838b70763ecfea3ca60.zip
Bump PORTREVISION after libao update and handle API incompatibility.
Diffstat (limited to 'emulators/zsnes')
-rw-r--r--emulators/zsnes/Makefile4
-rw-r--r--emulators/zsnes/files/patch-linux_audio.c10
2 files changed, 12 insertions, 2 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 747f09e2e6a0..02316eedb770 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsnes
PORTVERSION= 1.51
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ZSNES%20v${PORTVERSION}
@@ -78,7 +78,7 @@ CONFIGURE_ARGS+= --disable-opengl
.endif
.if defined(WITH_LIBAO)
-LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+= --enable-libao
.else
CONFIGURE_ARGS+= --disable-libao
diff --git a/emulators/zsnes/files/patch-linux_audio.c b/emulators/zsnes/files/patch-linux_audio.c
new file mode 100644
index 000000000000..a88985a34fa5
--- /dev/null
+++ b/emulators/zsnes/files/patch-linux_audio.c
@@ -0,0 +1,10 @@
+--- linux/audio.c.orig 2010-06-06 14:56:20.000000000 +0200
++++ linux/audio.c 2010-06-06 14:56:41.000000000 +0200
+@@ -166,6 +166,7 @@ static int SoundInit_ao()
+ if (driver_id < 0) { driver_id = ao_default_driver_id(); }
+
+ ao_sample_format driver_format;
++ memset(&driver_format, 0, sizeof(driver_format));
+ driver_format.bits = 16;
+ driver_format.channels = StereoSound+1;
+ driver_format.rate = freqtab[SoundQuality = ((SoundQuality > 6) ? 1 : SoundQuality)];