aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
committerseanc <seanc@FreeBSD.org>2003-02-07 10:44:21 +0800
commit029b18cf87aedbf71e33f8d866f6df8c14ff7289 (patch)
tree2315898546b50fdde5fb0c2b3b87a246f37d3136 /emulators
parent1f6ee4fb3acab07e5bf5542a77600b7f2b044939 (diff)
downloadfreebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.gz
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.tar.zst
freebsd-ports-gnome-029b18cf87aedbf71e33f8d866f6df8c14ff7289.zip
Correct ports that were abusing the FORBIDDEN variable and replace with
either IGNORE or BROKEN. Since there seems to be some confusion, for the record: BROKEN is reserved for ports that don't work. This will prevent users from installing the port, but please note that ports marked as BROKEN will still be built by bento IGNORE is reserved for ports that should not be built for one reason or another (including bento). Users and bento will not build ports marked as IGNORE. FORBIDDEN is reserved for security breakages only!!! Only mark a port as FORBIDDEN if there is a security issue with the port at the time. Reviewed by: kris (portmgr)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/snes9x/Makefile2
-rw-r--r--emulators/vmware-guestd/Makefile2
-rw-r--r--emulators/vmware-guestd3/Makefile2
-rw-r--r--emulators/vmware-guestd4/Makefile2
-rw-r--r--emulators/vmware-guestd5/Makefile2
-rw-r--r--emulators/vmware-guestd6/Makefile2
-rw-r--r--emulators/vmware-tools3/Makefile2
-rw-r--r--emulators/vmware-tools4/Makefile2
-rw-r--r--emulators/vmware-tools5/Makefile2
-rw-r--r--emulators/vmware-tools6/Makefile2
-rw-r--r--emulators/vmware_xf4mod/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index ec3c158bbafa..486467c92329 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= green@FreeBSD.org
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.elif ${MACHINE_ARCH} == alpha
MAKEFILE= Makefile.alpha
-FORBIDDEN= currently does not work on alpha
+BROKEN= currently does not work on alpha
.endif
USE_GMAKE= YES
diff --git a/emulators/vmware-guestd/Makefile b/emulators/vmware-guestd/Makefile
index aa0049306b7b..b12ef107f005 100644
--- a/emulators/vmware-guestd/Makefile
+++ b/emulators/vmware-guestd/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-guestd3/Makefile b/emulators/vmware-guestd3/Makefile
index aa0049306b7b..b12ef107f005 100644
--- a/emulators/vmware-guestd3/Makefile
+++ b/emulators/vmware-guestd3/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-guestd4/Makefile b/emulators/vmware-guestd4/Makefile
index aa0049306b7b..b12ef107f005 100644
--- a/emulators/vmware-guestd4/Makefile
+++ b/emulators/vmware-guestd4/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index aa0049306b7b..b12ef107f005 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index aa0049306b7b..b12ef107f005 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -24,7 +24,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index eee6600450fa..38905ed41bd7 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -26,7 +26,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-tools4/Makefile b/emulators/vmware-tools4/Makefile
index eee6600450fa..38905ed41bd7 100644
--- a/emulators/vmware-tools4/Makefile
+++ b/emulators/vmware-tools4/Makefile
@@ -26,7 +26,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-tools5/Makefile b/emulators/vmware-tools5/Makefile
index eee6600450fa..38905ed41bd7 100644
--- a/emulators/vmware-tools5/Makefile
+++ b/emulators/vmware-tools5/Makefile
@@ -26,7 +26,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware-tools6/Makefile b/emulators/vmware-tools6/Makefile
index eee6600450fa..38905ed41bd7 100644
--- a/emulators/vmware-tools6/Makefile
+++ b/emulators/vmware-tools6/Makefile
@@ -26,7 +26,7 @@ NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
-FORBIDDEN= "Can't build this port since it requires VMware."
+IGNORE= "Can't build this port since it requires VMware."
.endif
VMWARE_VER= 3.1.1
diff --git a/emulators/vmware_xf4mod/Makefile b/emulators/vmware_xf4mod/Makefile
index 38fbdf19219b..e44c673c86ed 100644
--- a/emulators/vmware_xf4mod/Makefile
+++ b/emulators/vmware_xf4mod/Makefile
@@ -25,7 +25,7 @@ USE_X_PREFIX= yes
ONLY_FOR_ARCHS= i386
RESTRICTED= "Not sure if we can redistribute it"
-FORBIDDEN= "This module is now part of XFree86 as of 4.1.0"
+IGNORE= "This module is now part of XFree86 as of 4.1.0"
do-extract:
${MKDIR} ${WRKSRC}