aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-08-08 07:55:13 +0800
committergerald <gerald@FreeBSD.org>2012-08-08 07:55:13 +0800
commit1413ffdd040e797a32ed1346a0b45213af95effc (patch)
tree5758e74f421dc41c6571ea9944f0f7ce179e2feb /emulators
parent1129d8733041616d3c2e0ae66aa505d645ee1456 (diff)
downloadfreebsd-ports-gnome-1413ffdd040e797a32ed1346a0b45213af95effc.tar.gz
freebsd-ports-gnome-1413ffdd040e797a32ed1346a0b45213af95effc.tar.zst
freebsd-ports-gnome-1413ffdd040e797a32ed1346a0b45213af95effc.zip
Mono is an Open Source and cross-platform implementation of the .NET
framework. Wine can use a Windows build of Mono to run .NET applications. This new ports provides such a build. PR: 169747 Submitted by: David Naylor <naylor.b.david@gmail.com>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/wine-mono/Makefile31
-rw-r--r--emulators/wine-mono/distinfo2
-rw-r--r--emulators/wine-mono/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 79df10b1c634..b8466c119f62 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -193,6 +193,7 @@
SUBDIR += wine-doors
SUBDIR += wine-gecko
SUBDIR += wine-gecko-devel
+ SUBDIR += wine-mono
SUBDIR += wxmupen64plus
SUBDIR += x48
SUBDIR += xbraitenberg
diff --git a/emulators/wine-mono/Makefile b/emulators/wine-mono/Makefile
new file mode 100644
index 000000000000..47d15fd4e13c
--- /dev/null
+++ b/emulators/wine-mono/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wine-mono-devel
+# Date created: 2012-08-08
+# Whom: David Naylor <naylor.b.david@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= wine-mono
+DISTVERSION= 0.0.4
+CATEGORIES= emulators
+MASTER_SITES= SF/wine/Wine%20Mono/${DISTVERSION}
+EXTRACT_SUFX= .msi
+EXTRACT_ONLY=
+
+MAINTAINER= naylor.b.david@gmail.com
+COMMENT= Mono .NET implementation for Wine development branch (HTML support)
+
+LICENSE= MIT GPLv2 LGPL20
+LICENSE_COMB= multi
+
+NO_BUILD= yes
+PLIST_SUB+= MONO_VERSION="${DISTVERSION}"
+DATADIR= ${PREFIX}/share/wine
+PLIST_FILES= %%DATADIR%%/mono/wine-mono-%%MONO_VERSION%%.msi
+PLIST_DIRSTRY= %%DATADIR%%/mono %%DATADIR%%
+
+do-install:
+ @${MKDIR} ${DATADIR}/mono
+ ${INSTALL_DATA} ${DISTDIR}/wine-mono-${DISTVERSION}.msi \
+ ${DATADIR}/mono
+
+.include <bsd.port.mk>
diff --git a/emulators/wine-mono/distinfo b/emulators/wine-mono/distinfo
new file mode 100644
index 000000000000..d7f9496036b2
--- /dev/null
+++ b/emulators/wine-mono/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wine-mono-0.0.4.msi) = 15d8a612cdeca4eff3137353f29fdeb7a99e055cd633844c91cd00e0186b8882
+SIZE (wine-mono-0.0.4.msi) = 44408320
diff --git a/emulators/wine-mono/pkg-descr b/emulators/wine-mono/pkg-descr
new file mode 100644
index 000000000000..74d69e7660a7
--- /dev/null
+++ b/emulators/wine-mono/pkg-descr
@@ -0,0 +1,4 @@
+Mono is an Open Source and cross-platform implementation of the .NET
+framework. Wine can use a Windows build of Mono to run .NET applications.
+
+WWW: http://wiki.winehq.org/Mono