aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-10 15:31:54 +0800
committerpawel <pawel@FreeBSD.org>2014-04-10 15:31:54 +0800
commit1702a619ac7f2527ca702ecc9bbf1f89b3365235 (patch)
treef798d0f4513ac4c229fdba0db88f542b0de489ef /emulators
parent6febba62bb31a343764b2e459647d3c90500fe51 (diff)
downloadfreebsd-ports-gnome-1702a619ac7f2527ca702ecc9bbf1f89b3365235.tar.gz
freebsd-ports-gnome-1702a619ac7f2527ca702ecc9bbf1f89b3365235.tar.zst
freebsd-ports-gnome-1702a619ac7f2527ca702ecc9bbf1f89b3365235.zip
- Add staging support
- Convert to new options framework, USES=gmake
Diffstat (limited to 'emulators')
-rw-r--r--emulators/quasi88/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/emulators/quasi88/Makefile b/emulators/quasi88/Makefile
index 45a788e3bdf6..53e386440e90 100644
--- a/emulators/quasi88/Makefile
+++ b/emulators/quasi88/Makefile
@@ -12,25 +12,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PC-8801 emulator for X
USE_XORG= x11 xext
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= DATADIR="${DATADIR}" _CC="${CC}" _CFLAGS="${CFLAGS}" \
_CXX="${CXX}" LD="${CXX}" PROGRAM="${PORTNAME}"
MAKE_ARGS= ARCH="freebsd"
PORTDOCS= FAQ.TXT FORMAT.TXT GET-IMAGE.TXT HISTORY.TXT MANUAL.TXT \
QUASI88.TXT
-PLIST_FILES= bin/quasi88 %%EXAMPLESDIR%%/keyconf.rc \
- %%EXAMPLESDIR%%/quasi88.rc
-PLIST_DIRS= %%EXAMPLESDIR%%
+PORTEXAMPLES= *
+PLIST_FILES= bin/quasi88
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES SDL
+
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
MAKE_ENV+= LSB_FIRST=1
.endif
-.if defined(WITH_SDL)
+.if ${PORT_OPTIONS:MSDL}
USE_SDL= sdl
MAKE_ENV+= SDL_VERSION=1 JOYSTICK="joy_sdl"
.else
@@ -52,14 +52,11 @@ post-patch:
s|^PROGRAM|# PROGRAM|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/quasi88 ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.rc ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/document/${file} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
+ ${INSTALL_PROGRAM} ${WRKSRC}/quasi88 ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.rc ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/document && ${INSTALL_DATA} ${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>