aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 01:56:22 +0800
committermarino <marino@FreeBSD.org>2016-09-11 01:56:22 +0800
commit33408a91d204e71c5a15a632913442b8807ca7c2 (patch)
tree76ab93a190f0bc74c5bc5a8a5844545e63b5d0bc /emulators
parent8509cabd13fec878cfce38c6cca7a7ec62c5f73f (diff)
downloadfreebsd-ports-gnome-33408a91d204e71c5a15a632913442b8807ca7c2.tar.gz
freebsd-ports-gnome-33408a91d204e71c5a15a632913442b8807ca7c2.tar.zst
freebsd-ports-gnome-33408a91d204e71c5a15a632913442b8807ca7c2.zip
emulators/qemu-devel: Document SSL requirement and set LDFLAGS for it
Approved by: SSL blanket
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 8cc2b7880dfd..e0fc0971b363 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -14,7 +14,7 @@ COMMENT= QEMU CPU Emulator - development version
LICENSE= GPLv2
HAS_CONFIGURE= yes
-USES= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
+USES= cpe gmake pkgconfig bison perl5 python:2,build ssl tar:bzip2
USE_PERL5= build
USE_XORG= pixman
USE_GNOME+= cairo glib20
@@ -72,6 +72,7 @@ PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto
CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
--disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \