aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2003-10-21 06:54:23 +0800
committergerald <gerald@FreeBSD.org>2003-10-21 06:54:23 +0800
commit4076ad5420928beaba8bccf99be3e77030043ce3 (patch)
tree6eba38746347f19ca0338ddf9e2ef56f7f8dfa85 /emulators
parent0e97fb63f57ada4a07ace1616d5629e9d4558b11 (diff)
downloadfreebsd-ports-gnome-4076ad5420928beaba8bccf99be3e77030043ce3.tar.gz
freebsd-ports-gnome-4076ad5420928beaba8bccf99be3e77030043ce3.tar.zst
freebsd-ports-gnome-4076ad5420928beaba8bccf99be3e77030043ce3.zip
Strip binaries by default, as this reduces the size of packages from 40+ MB
to 8- MB. Change the name of the knob to control debugging information from NDEBUG to DEBUG and shorten the pre-extract output. Triggered by: Ivan Leo Murray-Smith <puoti@inwind.it>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile18
-rw-r--r--emulators/wine/Makefile18
2 files changed, 14 insertions, 22 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 36fd389d552d..99c6bea648ed 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -36,20 +36,16 @@ USE_REINPLACE= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.x"
.endif
-.if !defined(NDEBUG)
+.if defined(DEBUG)
STRIP=
-CFLAGS+= -g
.else
+CFLAGS= -O2
+
pre-extract:
- @${ECHO} "NDEBUG has been set, building without debug info..."
- @${ECHO} "This will save diskspace but it makes debugging harder."
- @${ECHO} "If for example wine crashes and you would like to send"
- @${ECHO} "the backtrace it then dumps to the developers (or"
- @${ECHO} "comp.emulators.ms-windows.wine) it will be much more useful"
- @${ECHO} "to them if you first rebuild without this and generate it again."
- @${ECHO} "(If you're _not_ low on diskspace there is not really a reason to"
- @${ECHO} "use this flag, the resulting wine won't use more VM or anything like"
- @${ECHO} "that when running, only when it has to enter the debugger...)"
+ @${ECHO} "DEBUG has not been set, building without debug info."
+ @${ECHO} "This makes the disk footprint and packages much smaller,"
+ @${ECHO} "but debugging harder. If Wine crashes and you need to"
+ @${ECHO} "generate a backtrace, please rebuild with DEBUG defined."
.endif
post-extract:
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 36fd389d552d..99c6bea648ed 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -36,20 +36,16 @@ USE_REINPLACE= yes
BROKEN= "Not supported on systems prior to FreeBSD 4.x"
.endif
-.if !defined(NDEBUG)
+.if defined(DEBUG)
STRIP=
-CFLAGS+= -g
.else
+CFLAGS= -O2
+
pre-extract:
- @${ECHO} "NDEBUG has been set, building without debug info..."
- @${ECHO} "This will save diskspace but it makes debugging harder."
- @${ECHO} "If for example wine crashes and you would like to send"
- @${ECHO} "the backtrace it then dumps to the developers (or"
- @${ECHO} "comp.emulators.ms-windows.wine) it will be much more useful"
- @${ECHO} "to them if you first rebuild without this and generate it again."
- @${ECHO} "(If you're _not_ low on diskspace there is not really a reason to"
- @${ECHO} "use this flag, the resulting wine won't use more VM or anything like"
- @${ECHO} "that when running, only when it has to enter the debugger...)"
+ @${ECHO} "DEBUG has not been set, building without debug info."
+ @${ECHO} "This makes the disk footprint and packages much smaller,"
+ @${ECHO} "but debugging harder. If Wine crashes and you need to"
+ @${ECHO} "generate a backtrace, please rebuild with DEBUG defined."
.endif
post-extract: