aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-01-17 23:02:40 +0800
committergerald <gerald@FreeBSD.org>2009-01-17 23:02:40 +0800
commit407b8ca7d8d2a83019461175509db897e7024570 (patch)
treee8b8aa1e75a0ef8ea4ff1d97b9d988bc350b19a6 /emulators
parent97349260b7eb40284e9f42a7c00adcd3fcb08544 (diff)
downloadfreebsd-ports-gnome-407b8ca7d8d2a83019461175509db897e7024570.tar.gz
freebsd-ports-gnome-407b8ca7d8d2a83019461175509db897e7024570.tar.zst
freebsd-ports-gnome-407b8ca7d8d2a83019461175509db897e7024570.zip
Update to Wine 1.1.13. Among others, this includes the following changes:
- Freedesktop.org-compliant startup notifications. - Improved graphics support in Internet Explorer. - Various Richedit improvements. - Better certificate manager dialog. - Various bug fixes (including two fixes we carried ourselves).
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile3
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/files/patch-server-debugger.c21
-rw-r--r--emulators/wine-devel/files/patch-tools-widl-write_msft.c77
-rw-r--r--emulators/wine-devel/pkg-plist9
-rw-r--r--emulators/wine/Makefile3
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/files/patch-server-debugger.c21
-rw-r--r--emulators/wine/files/patch-tools-widl-write_msft.c77
-rw-r--r--emulators/wine/pkg-plist9
10 files changed, 26 insertions, 206 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 211274a5483f..8c74cd748794 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.1.12
-PORTREVISION= 1
+DISTVERSION= 1.1.13
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 5fa78c7ae8e2..0aa490976420 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.1.12.tar.bz2) = f5270b0d2f0fca5852b5bc649c3e796d
-SHA256 (wine-1.1.12.tar.bz2) = 3c43fd3b4a4bb776710052daec5ef239f90c3f74e254fc62fc665adeeb2dc89d
-SIZE (wine-1.1.12.tar.bz2) = 14794095
+MD5 (wine-1.1.13.tar.bz2) = e505e6c9792b453b576bfba17300b811
+SHA256 (wine-1.1.13.tar.bz2) = 503928a1f4cfb933f983820744c4cc582aeb6a3897238b222883967fcb401156
+SIZE (wine-1.1.13.tar.bz2) = 14875035
diff --git a/emulators/wine-devel/files/patch-server-debugger.c b/emulators/wine-devel/files/patch-server-debugger.c
deleted file mode 100644
index 38e0cc87e6d1..000000000000
--- a/emulators/wine-devel/files/patch-server-debugger.c
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/server/debugger.c b/server/debugger.c
-index a865ebb..d8d425d 100644
---- server/debugger.c
-+++ server/debugger.c
-@@ -129,7 +129,7 @@ static int fill_create_thread_event( struct debug_event *event, const void *arg
- if (!(handle = alloc_handle( debugger, thread, THREAD_ALL_ACCESS, 0 ))) return 0;
- event->data.info.create_thread.handle = handle;
- event->data.info.create_thread.teb = thread->teb;
-- event->data.info.create_thread.start = *entry;
-+ if (entry) event->data.info.create_thread.start = *entry;
- return 1;
- }
-
-@@ -389,6 +389,7 @@ static struct debug_event *alloc_debug_event( struct thread *thread, int code,
- event->state = EVENT_QUEUED;
- event->sender = (struct thread *)grab_object( thread );
- event->debugger = (struct thread *)grab_object( debugger );
-+ memset( &event->data, 0, sizeof(event->data) );
- event->data.code = code;
-
- if (!fill_debug_event[code-1]( event, arg ))
diff --git a/emulators/wine-devel/files/patch-tools-widl-write_msft.c b/emulators/wine-devel/files/patch-tools-widl-write_msft.c
deleted file mode 100644
index abe48e214344..000000000000
--- a/emulators/wine-devel/files/patch-tools-widl-write_msft.c
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/tools/widl/write_msft.c b/tools/widl/write_msft.c
-index 01e98a6..fd237dc 100644
---- tools/widl/write_msft.c
-+++ tools/widl/write_msft.c
-@@ -2191,6 +2191,30 @@ static void add_module_typeinfo(msft_typelib_t *typelib, type_t *module)
- msft_typeinfo->typeinfo->size = idx;
- }
-
-+static void add_type_typeinfo(msft_typelib_t *typelib, type_t *type)
-+{
-+ switch (type->kind) {
-+ case TKIND_INTERFACE:
-+ case TKIND_DISPATCH:
-+ add_interface_typeinfo(typelib, type);
-+ break;
-+ case TKIND_RECORD:
-+ add_structure_typeinfo(typelib, type);
-+ break;
-+ case TKIND_ENUM:
-+ add_enum_typeinfo(typelib, type);
-+ break;
-+ case TKIND_COCLASS:
-+ add_coclass_typeinfo(typelib, type);
-+ break;
-+ case TKIND_PRIMITIVE:
-+ break;
-+ default:
-+ error("add_entry: unhandled type %d for %s\n", type->kind, type->name);
-+ break;
-+ }
-+}
-+
- static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- {
- switch(stmt->type) {
-@@ -2206,9 +2230,14 @@ static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- case STMT_TYPEDEF:
- {
- const type_list_t *type_entry = stmt->u.type_list;
-- for (; type_entry; type_entry = type_entry->next)
-+ for (; type_entry; type_entry = type_entry->next) {
-+ /* if the type is public then add the typedef, otherwise attempt
-+ * to add the aliased type */
- if (is_attr(type_entry->type->attrs, ATTR_PUBLIC))
- add_typedef_typeinfo(typelib, type_entry->type);
-+ else
-+ add_type_typeinfo(typelib, type_entry->type->orig);
-+ }
- break;
- }
- case STMT_MODULE:
-@@ -2218,24 +2247,7 @@ static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- case STMT_TYPEREF:
- {
- type_t *type = stmt->u.type;
-- switch (type->kind) {
-- case TKIND_INTERFACE:
-- case TKIND_DISPATCH:
-- add_interface_typeinfo(typelib, type);
-- break;
-- case TKIND_RECORD:
-- add_structure_typeinfo(typelib, type);
-- break;
-- case TKIND_ENUM:
-- add_enum_typeinfo(typelib, type);
-- break;
-- case TKIND_COCLASS:
-- add_coclass_typeinfo(typelib, type);
-- break;
-- default:
-- error("add_entry: unhandled type %d\n", type->kind);
-- break;
-- }
-+ add_type_typeinfo(typelib, type);
- break;
- }
- }
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 6cbc5826608d..68507ce083ab 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -120,6 +120,8 @@ include/wine/windows/corhdr.h
include/wine/windows/cpl.h
include/wine/windows/cryptdlg.h
include/wine/windows/cryptuiapi.h
+include/wine/windows/ctxtcall.h
+include/wine/windows/ctxtcall.idl
include/wine/windows/custcntl.h
include/wine/windows/cvconst.h
include/wine/windows/d3d.h
@@ -244,6 +246,7 @@ include/wine/windows/hlink.idl
include/wine/windows/htiframe.h
include/wine/windows/htiframe.idl
include/wine/windows/htmlhelp.h
+include/wine/windows/http.h
include/wine/windows/i_cryptasn1tls.h
include/wine/windows/iads.h
include/wine/windows/iads.idl
@@ -285,6 +288,7 @@ include/wine/windows/lmstats.h
include/wine/windows/lmuse.h
include/wine/windows/lmuseflg.h
include/wine/windows/lmwksta.h
+include/wine/windows/loadperf.h
include/wine/windows/lzexpand.h
include/wine/windows/mapi.h
include/wine/windows/mapicode.h
@@ -505,6 +509,7 @@ include/wine/windows/winnt.h
include/wine/windows/winperf.h
include/wine/windows/winreg.h
include/wine/windows/winresrc.h
+include/wine/windows/winsafer.h
include/wine/windows/winscard.h
include/wine/windows/winsmcrd.h
include/wine/windows/winsock.h
@@ -570,6 +575,7 @@ lib/wine/avifil32.dll.so
lib/wine/avifile.dll16
lib/wine/browseui.dll.so
lib/wine/cabinet.dll.so
+lib/wine/cacls.exe.so
lib/wine/capi2032.dll.so
lib/wine/cards.dll.so
lib/wine/cfgmgr32.dll.so
@@ -667,6 +673,7 @@ lib/wine/hhctrl.ocx.so
lib/wine/hid.dll.so
lib/wine/hlink.dll.so
lib/wine/hnetcfg.dll.so
+lib/wine/httpapi.dll.so
lib/wine/iccvid.dll.so
lib/wine/icinfo.exe.so
lib/wine/icmp.dll.so
@@ -834,6 +841,7 @@ lib/wine/libws2_32.def
lib/wine/libwsock32.def
lib/wine/libwtsapi32.def
lib/wine/libxinput.def
+lib/wine/loadperf.dll.so
lib/wine/localspl.dll.so
lib/wine/localui.dll.so
lib/wine/lz32.dll.so
@@ -986,6 +994,7 @@ lib/wine/twain_32.dll.so
lib/wine/typelib.dll16
lib/wine/unicows.dll.so
lib/wine/uninstaller.exe.so
+lib/wine/updspapi.dll.so
lib/wine/url.dll.so
lib/wine/urlmon.dll.so
lib/wine/user.exe16
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 211274a5483f..8c74cd748794 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.1.12
-PORTREVISION= 1
+DISTVERSION= 1.1.13
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index 5fa78c7ae8e2..0aa490976420 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.1.12.tar.bz2) = f5270b0d2f0fca5852b5bc649c3e796d
-SHA256 (wine-1.1.12.tar.bz2) = 3c43fd3b4a4bb776710052daec5ef239f90c3f74e254fc62fc665adeeb2dc89d
-SIZE (wine-1.1.12.tar.bz2) = 14794095
+MD5 (wine-1.1.13.tar.bz2) = e505e6c9792b453b576bfba17300b811
+SHA256 (wine-1.1.13.tar.bz2) = 503928a1f4cfb933f983820744c4cc582aeb6a3897238b222883967fcb401156
+SIZE (wine-1.1.13.tar.bz2) = 14875035
diff --git a/emulators/wine/files/patch-server-debugger.c b/emulators/wine/files/patch-server-debugger.c
deleted file mode 100644
index 38e0cc87e6d1..000000000000
--- a/emulators/wine/files/patch-server-debugger.c
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/server/debugger.c b/server/debugger.c
-index a865ebb..d8d425d 100644
---- server/debugger.c
-+++ server/debugger.c
-@@ -129,7 +129,7 @@ static int fill_create_thread_event( struct debug_event *event, const void *arg
- if (!(handle = alloc_handle( debugger, thread, THREAD_ALL_ACCESS, 0 ))) return 0;
- event->data.info.create_thread.handle = handle;
- event->data.info.create_thread.teb = thread->teb;
-- event->data.info.create_thread.start = *entry;
-+ if (entry) event->data.info.create_thread.start = *entry;
- return 1;
- }
-
-@@ -389,6 +389,7 @@ static struct debug_event *alloc_debug_event( struct thread *thread, int code,
- event->state = EVENT_QUEUED;
- event->sender = (struct thread *)grab_object( thread );
- event->debugger = (struct thread *)grab_object( debugger );
-+ memset( &event->data, 0, sizeof(event->data) );
- event->data.code = code;
-
- if (!fill_debug_event[code-1]( event, arg ))
diff --git a/emulators/wine/files/patch-tools-widl-write_msft.c b/emulators/wine/files/patch-tools-widl-write_msft.c
deleted file mode 100644
index abe48e214344..000000000000
--- a/emulators/wine/files/patch-tools-widl-write_msft.c
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/tools/widl/write_msft.c b/tools/widl/write_msft.c
-index 01e98a6..fd237dc 100644
---- tools/widl/write_msft.c
-+++ tools/widl/write_msft.c
-@@ -2191,6 +2191,30 @@ static void add_module_typeinfo(msft_typelib_t *typelib, type_t *module)
- msft_typeinfo->typeinfo->size = idx;
- }
-
-+static void add_type_typeinfo(msft_typelib_t *typelib, type_t *type)
-+{
-+ switch (type->kind) {
-+ case TKIND_INTERFACE:
-+ case TKIND_DISPATCH:
-+ add_interface_typeinfo(typelib, type);
-+ break;
-+ case TKIND_RECORD:
-+ add_structure_typeinfo(typelib, type);
-+ break;
-+ case TKIND_ENUM:
-+ add_enum_typeinfo(typelib, type);
-+ break;
-+ case TKIND_COCLASS:
-+ add_coclass_typeinfo(typelib, type);
-+ break;
-+ case TKIND_PRIMITIVE:
-+ break;
-+ default:
-+ error("add_entry: unhandled type %d for %s\n", type->kind, type->name);
-+ break;
-+ }
-+}
-+
- static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- {
- switch(stmt->type) {
-@@ -2206,9 +2230,14 @@ static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- case STMT_TYPEDEF:
- {
- const type_list_t *type_entry = stmt->u.type_list;
-- for (; type_entry; type_entry = type_entry->next)
-+ for (; type_entry; type_entry = type_entry->next) {
-+ /* if the type is public then add the typedef, otherwise attempt
-+ * to add the aliased type */
- if (is_attr(type_entry->type->attrs, ATTR_PUBLIC))
- add_typedef_typeinfo(typelib, type_entry->type);
-+ else
-+ add_type_typeinfo(typelib, type_entry->type->orig);
-+ }
- break;
- }
- case STMT_MODULE:
-@@ -2218,24 +2247,7 @@ static void add_entry(msft_typelib_t *typelib, const statement_t *stmt)
- case STMT_TYPEREF:
- {
- type_t *type = stmt->u.type;
-- switch (type->kind) {
-- case TKIND_INTERFACE:
-- case TKIND_DISPATCH:
-- add_interface_typeinfo(typelib, type);
-- break;
-- case TKIND_RECORD:
-- add_structure_typeinfo(typelib, type);
-- break;
-- case TKIND_ENUM:
-- add_enum_typeinfo(typelib, type);
-- break;
-- case TKIND_COCLASS:
-- add_coclass_typeinfo(typelib, type);
-- break;
-- default:
-- error("add_entry: unhandled type %d\n", type->kind);
-- break;
-- }
-+ add_type_typeinfo(typelib, type);
- break;
- }
- }
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 6cbc5826608d..68507ce083ab 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -120,6 +120,8 @@ include/wine/windows/corhdr.h
include/wine/windows/cpl.h
include/wine/windows/cryptdlg.h
include/wine/windows/cryptuiapi.h
+include/wine/windows/ctxtcall.h
+include/wine/windows/ctxtcall.idl
include/wine/windows/custcntl.h
include/wine/windows/cvconst.h
include/wine/windows/d3d.h
@@ -244,6 +246,7 @@ include/wine/windows/hlink.idl
include/wine/windows/htiframe.h
include/wine/windows/htiframe.idl
include/wine/windows/htmlhelp.h
+include/wine/windows/http.h
include/wine/windows/i_cryptasn1tls.h
include/wine/windows/iads.h
include/wine/windows/iads.idl
@@ -285,6 +288,7 @@ include/wine/windows/lmstats.h
include/wine/windows/lmuse.h
include/wine/windows/lmuseflg.h
include/wine/windows/lmwksta.h
+include/wine/windows/loadperf.h
include/wine/windows/lzexpand.h
include/wine/windows/mapi.h
include/wine/windows/mapicode.h
@@ -505,6 +509,7 @@ include/wine/windows/winnt.h
include/wine/windows/winperf.h
include/wine/windows/winreg.h
include/wine/windows/winresrc.h
+include/wine/windows/winsafer.h
include/wine/windows/winscard.h
include/wine/windows/winsmcrd.h
include/wine/windows/winsock.h
@@ -570,6 +575,7 @@ lib/wine/avifil32.dll.so
lib/wine/avifile.dll16
lib/wine/browseui.dll.so
lib/wine/cabinet.dll.so
+lib/wine/cacls.exe.so
lib/wine/capi2032.dll.so
lib/wine/cards.dll.so
lib/wine/cfgmgr32.dll.so
@@ -667,6 +673,7 @@ lib/wine/hhctrl.ocx.so
lib/wine/hid.dll.so
lib/wine/hlink.dll.so
lib/wine/hnetcfg.dll.so
+lib/wine/httpapi.dll.so
lib/wine/iccvid.dll.so
lib/wine/icinfo.exe.so
lib/wine/icmp.dll.so
@@ -834,6 +841,7 @@ lib/wine/libws2_32.def
lib/wine/libwsock32.def
lib/wine/libwtsapi32.def
lib/wine/libxinput.def
+lib/wine/loadperf.dll.so
lib/wine/localspl.dll.so
lib/wine/localui.dll.so
lib/wine/lz32.dll.so
@@ -986,6 +994,7 @@ lib/wine/twain_32.dll.so
lib/wine/typelib.dll16
lib/wine/unicows.dll.so
lib/wine/uninstaller.exe.so
+lib/wine/updspapi.dll.so
lib/wine/url.dll.so
lib/wine/urlmon.dll.so
lib/wine/user.exe16