aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2013-12-18 05:44:58 +0800
committerdecke <decke@FreeBSD.org>2013-12-18 05:44:58 +0800
commit48063ec9e302d882ba11a419f33e0588b24e55b7 (patch)
tree6b07d558bf4d2b1651061ef7416a52b4dd7c4ee5 /emulators
parenta93c6b1fc4b13c8bcbbb548f0f65bebee38be3af (diff)
downloadfreebsd-ports-gnome-48063ec9e302d882ba11a419f33e0588b24e55b7.tar.gz
freebsd-ports-gnome-48063ec9e302d882ba11a419f33e0588b24e55b7.tar.zst
freebsd-ports-gnome-48063ec9e302d882ba11a419f33e0588b24e55b7.zip
- Disable stripping away RPATH on FreeBSD for Hardened-R3 binaries.
This fixes the remaining compat9x problems because the virtualbox buildsystem did remove our RPATH on some binaries if hardening is enabled. The hardening is a collection of additional safety checks for all virtualbox suid binaries and is always enabled. Reported by: many FreeBSD 10 users
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile1
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-Config.kmk23
2 files changed, 17 insertions, 7 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 0baa4a0c8707..0ab51ee4a7da 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.2.20
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${DISTVERSION}/ \
http://tmp.chruetertee.ch/ \
diff --git a/emulators/virtualbox-ose-legacy/files/patch-Config.kmk b/emulators/virtualbox-ose-legacy/files/patch-Config.kmk
index 4c5387eeaee2..ad27fa4684e3 100644
--- a/emulators/virtualbox-ose-legacy/files/patch-Config.kmk
+++ b/emulators/virtualbox-ose-legacy/files/patch-Config.kmk
@@ -1,6 +1,6 @@
---- Config.kmk.orig 2013-10-15 13:01:31.000000000 +0200
-+++ Config.kmk 2013-10-20 14:43:19.015746151 +0200
-@@ -3387,16 +3387,16 @@
+--- Config.kmk.orig 2013-11-28 19:29:52.000000000 +0100
++++ Config.kmk 2013-12-17 20:15:54.000000000 +0100
+@@ -3260,16 +3260,16 @@
$(VBOX_GCC_WARN) -Wpointer-arith -Winline $(VBOX_GCC_Wno-pointer-sign) $(VBOX_GCC_fdiagnostics-show-option) \
-Wstrict-prototypes -Wmissing-prototypes -Wstrict-prototypes \
-Wimplicit-function-declaration -Werror-implicit-function-declaration \
@@ -20,7 +20,7 @@
$(VBOX_GCC_fno-stack-protector) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) \
-nostdinc
TEMPLATE_VBOXR0DRV_CXXFLAGS.x86 = $(TEMPLATE_VBOXR0DRV_CFLAGS.x86)
-@@ -3630,8 +3630,6 @@
+@@ -3486,8 +3486,6 @@
/usr/X11R6/include \
/usr/local/include
TEMPLATE_VBOXR3EXE_LIBPATH += \
@@ -29,7 +29,16 @@
/usr/local/lib
else ifeq ($(KBUILD_TARGET),solaris)
TEMPLATE_VBOXR3EXE_TOOL = GXX3PLAIN
-@@ -4206,8 +4204,6 @@
+@@ -3670,7 +3668,7 @@
+ # not necessary except USE_LIB_PCAP is defined in SUPR3HardenedMain.cpp
+ # TEMPLATE_VBOXR3HARDENEDEXE_LIBS += cap
+ endif
+-ifn1of ($(KBUILD_TARGET), win os2)
++ifn1of ($(KBUILD_TARGET), win os2 freebsd)
+ TEMPLATE_VBOXR3HARDENEDEXE_LDFLAGS = $(filter-out '$(VBOX_GCC_RPATH_OPT)%,$(TEMPLATE_VBOXR3EXE_LDFLAGS))
+ TEMPLATE_VBOXR3HARDENEDEXE_LDFLAGS.linux = $(filter-out $(VBOX_GCC_ORIGIN_OPT),$(TEMPLATE_VBOXR3EXE_LDFLAGS.linux))
+ endif
+@@ -3976,8 +3974,6 @@
/usr/X11R6/include \
/usr/local/include
TEMPLATE_VBOXMAINEXE_LIBPATH += \
@@ -38,7 +47,7 @@
/usr/local/lib
else ifeq ($(KBUILD_TARGET),solaris)
TEMPLATE_VBOXMAINEXE_TOOL = GXX3PLAIN
-@@ -4673,8 +4669,6 @@
+@@ -4392,8 +4388,6 @@
/usr/X11R6/include \
/usr/local/include
TEMPLATE_VBOXQT4GUIEXE_LIBPATH += \
@@ -47,7 +56,7 @@
/usr/local/lib
endif
ifeq ($(KBUILD_TARGET),solaris)
-@@ -4869,8 +4863,6 @@
+@@ -4576,8 +4570,6 @@
/usr/X11R6/include \
/usr/local/include
TEMPLATE_VBOXBLDPROG_LIBPATH += \