aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2012-07-03 23:35:31 +0800
committerskreuzer <skreuzer@FreeBSD.org>2012-07-03 23:35:31 +0800
commit4d49dd761162f06d6f9edd8136c8c175cba078bf (patch)
treee934decb133d1f44bfac3a50d0be0243b585e81b /emulators
parent84794ce11ee1976a64e310e7ac26f38ec211f113 (diff)
downloadfreebsd-ports-gnome-4d49dd761162f06d6f9edd8136c8c175cba078bf.tar.gz
freebsd-ports-gnome-4d49dd761162f06d6f9edd8136c8c175cba078bf.tar.zst
freebsd-ports-gnome-4d49dd761162f06d6f9edd8136c8c175cba078bf.zip
Imagine this nightmare scenario: your boss tells you about a legacy system you
have to support. How bad could it be? COBOL? Fortran? Worse: it's an embedded 6502 system run by a family of squirrels. Fortunately there's a pure Perl 6502 emulator that works so well the squirrels will never know the difference. WWW: http://search.cpan.org/dist/Acme-6502/
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/p5-Acme-6502/Makefile26
-rw-r--r--emulators/p5-Acme-6502/distinfo2
-rw-r--r--emulators/p5-Acme-6502/pkg-descr6
-rw-r--r--emulators/p5-Acme-6502/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 74889a41fb55..57ab96b86420 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -129,6 +129,7 @@
SUBDIR += open-vm-tools-nox11
SUBDIR += openmsx
SUBDIR += osmose
+ SUBDIR += p5-Acme-6502
SUBDIR += parallels-tools
SUBDIR += pcemu
SUBDIR += pcsxr
diff --git a/emulators/p5-Acme-6502/Makefile b/emulators/p5-Acme-6502/Makefile
new file mode 100644
index 000000000000..ca79897c7cd6
--- /dev/null
+++ b/emulators/p5-Acme-6502/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Acme-6502
+# Date created: 2012-07-03
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Acme-6502
+PORTVERSION= 0.76
+CATEGORIES= emulators perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Pure Perl 65C02 simulator
+
+RUN_DEPENDS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-version>=0.98:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Acme::6502.3 \
+ Acme::6502::Tube.3
+
+.include <bsd.port.mk>
diff --git a/emulators/p5-Acme-6502/distinfo b/emulators/p5-Acme-6502/distinfo
new file mode 100644
index 000000000000..ed9d5c5b30cd
--- /dev/null
+++ b/emulators/p5-Acme-6502/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Acme-6502-0.76.tar.gz) = 8bd1cf12e703890d9366230c002e5baa32c4bc9ba560e1b0a735d743dd5088e1
+SIZE (Acme-6502-0.76.tar.gz) = 40293
diff --git a/emulators/p5-Acme-6502/pkg-descr b/emulators/p5-Acme-6502/pkg-descr
new file mode 100644
index 000000000000..a96ac4694a9f
--- /dev/null
+++ b/emulators/p5-Acme-6502/pkg-descr
@@ -0,0 +1,6 @@
+Imagine this nightmare scenario: your boss tells you about a legacy system you
+have to support. How bad could it be? COBOL? Fortran? Worse: it's an embedded
+6502 system run by a family of squirrels. Fortunately there's a pure Perl 6502
+emulator that works so well the squirrels will never know the difference.
+
+WWW: http://search.cpan.org/dist/Acme-6502/
diff --git a/emulators/p5-Acme-6502/pkg-plist b/emulators/p5-Acme-6502/pkg-plist
new file mode 100644
index 000000000000..028d36653e87
--- /dev/null
+++ b/emulators/p5-Acme-6502/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Acme/6502.pm
+%%SITE_PERL%%/Acme/6502/Tube.pm
+@dirrm %%SITE_PERL%%/Acme/6502/
+@dirrmtry %%SITE_PERL%%/Acme/