aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2007-10-09 15:43:55 +0800
committeracm <acm@FreeBSD.org>2007-10-09 15:43:55 +0800
commit76ec616ced94b3ddb8c6c409b660148ada6d6ba5 (patch)
treec1cb1a32843ea017c8c93651b3609612de472e84 /emulators
parent3930300eec74b4c70c502a244e59236be7b374d2 (diff)
downloadfreebsd-ports-gnome-76ec616ced94b3ddb8c6c409b660148ada6d6ba5.tar.gz
freebsd-ports-gnome-76ec616ced94b3ddb8c6c409b660148ada6d6ba5.tar.zst
freebsd-ports-gnome-76ec616ced94b3ddb8c6c409b660148ada6d6ba5.zip
- New port: emulators/mupen64-tr64
A graphics plugin for Mupen64 emulator
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64-tr64/Makefile24
-rw-r--r--emulators/mupen64-tr64/distinfo3
-rw-r--r--emulators/mupen64-tr64/files/patch-Makefile39
4 files changed, 67 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c0ff7702ce22..5ad5793d8c1b 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -101,6 +101,7 @@
SUBDIR += mupen64-sdlinput
SUBDIR += mupen64-softgfx
SUBDIR += mupen64-sound
+ SUBDIR += mupen64-tr64
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader
diff --git a/emulators/mupen64-tr64/Makefile b/emulators/mupen64-tr64/Makefile
new file mode 100644
index 000000000000..d23586a666a2
--- /dev/null
+++ b/emulators/mupen64-tr64/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mupen64-tr64
+# Date created: 2007-10-09
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTVERSION= 0.7.8
+PKGNAMESUFFIX= -tr64
+
+COMMENT= Tr64 graphics plugin for Mupen64
+
+USE_SDL= sdl
+USE_GL= yes
+
+FIXFILES= display.c sdlgl.c
+
+PLUGIN_NAME= tr64gl
+
+MASTERDIR= ${.CURDIR}/../mupen64-base
+
+OPTIONS= #
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64-tr64/distinfo b/emulators/mupen64-tr64/distinfo
new file mode 100644
index 000000000000..7079a391ccaf
--- /dev/null
+++ b/emulators/mupen64-tr64/distinfo
@@ -0,0 +1,3 @@
+MD5 (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = 2e1a65dead4b11d023756e0a2a4478d5
+SHA256 (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = cdc69be9adb3df8cd2a92f7df388930ec11b6d6dceef2aab0e831521346e8bc2
+SIZE (mupen64/tr64_ogl_gtk2-0.7.8.tar.bz2) = 165504
diff --git a/emulators/mupen64-tr64/files/patch-Makefile b/emulators/mupen64-tr64/files/patch-Makefile
new file mode 100644
index 000000000000..f72c828572da
--- /dev/null
+++ b/emulators/mupen64-tr64/files/patch-Makefile
@@ -0,0 +1,39 @@
+--- Makefile.orig 2005-08-26 14:11:28.000000000 -0500
++++ Makefile 2007-10-09 01:55:17.000000000 -0500
+@@ -1,26 +1,26 @@
+ ifneq ("$(shell grep GTK2 config.h)","\#define GTK2_SUPPORT 1")
+-GTK_FLAGS = `gtk-config --cflags`
+-GTK_LIBS = `gtk-config --libs`
++GTK_FLAGS = `${GTK_CONFIG} --cflags`
++GTK_LIBS = `${GTK_CONFIG} --libs`
+ else
+ GTK_FLAGS = `pkg-config gtk+-2.0 --cflags` -D_GTK2
+ GTK_LIBS = `pkg-config gtk+-2.0 --libs`
+ endif
+
+-CC = gcc
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` $(GTK_FLAGS) -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer
+-LD = gcc
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib `sdl-config --libs`
++CC ?= gcc
++CFLAGS += -DUSE_GTK `${SDL_CONFIG} --cflags` $(GTK_FLAGS) -ffast-math -funroll-loops -fomit-frame-pointer
++LD = ${CXX}
++LDFLAGS = -lGL -lGLU -L${LOCALBAASE}/lib `${SDL_CONFIG} --libs`
+
+ OBJECTS = 3dmath.o autodet.o combine1.o debug.o display.o driver.o lighting.o rdp.o rdp_gl.o render.o sdlgl.o texture.o
+
+-all: tr64gl.so instruction
++all: plugins/tr64gl.so instruction
+
+-tr64gl.so: $(OBJECTS)
++plugins/tr64gl.so: $(OBJECTS)
++ mkdir -p plugins
+ $(LD) -shared -Wl,-Bsymbolic $(GTK_LIBS) $(LDFLAGS) -o $@ $(OBJECTS)
+- strip --strip-all $@
+
+ instruction:
+- $(warning please copy tr64gl.so in plugins/ folder of the emulator)
++ $(warning please copy plugins/tr64gl.so in plugins/ folder of the emulator)
+
+ .o: .c
+ $(CC) $(CFLAGS) -o $@ $<