aboutsummaryrefslogtreecommitdiffstats
path: root/emulators
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-19 16:18:03 +0800
committerkrion <krion@FreeBSD.org>2004-05-19 16:18:03 +0800
commit7d7d580e2d3f44845f614b846654fa6fd93a3078 (patch)
tree89cd9035d5c9bdf65947c8f8feaea5be649e2ca6 /emulators
parent534e83ff267b5b2758f8b2001f99b09b27898e4a (diff)
downloadfreebsd-ports-gnome-7d7d580e2d3f44845f614b846654fa6fd93a3078.tar.gz
freebsd-ports-gnome-7d7d580e2d3f44845f614b846654fa6fd93a3078.tar.zst
freebsd-ports-gnome-7d7d580e2d3f44845f614b846654fa6fd93a3078.zip
- Update to version 0.98.10
PR: ports/66847 Submitted by: maintainer
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fceu/Makefile6
-rw-r--r--emulators/fceu/distinfo4
-rw-r--r--emulators/fceu/files/patch-src-drivers-pc-unix-netplay.c20
-rw-r--r--emulators/fceux/Makefile6
-rw-r--r--emulators/fceux/distinfo4
-rw-r--r--emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c20
6 files changed, 52 insertions, 8 deletions
diff --git a/emulators/fceu/Makefile b/emulators/fceu/Makefile
index 1d1398a90371..8310eb7406c3 100644
--- a/emulators/fceu/Makefile
+++ b/emulators/fceu/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.8
+PORTVERSION= 0.98.10
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -19,6 +20,7 @@ USE_SDL= sdl
MAN6= fceu.6
WRKSRC= ${WRKDIR}/fceu
USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/emulators/fceu/distinfo b/emulators/fceu/distinfo
index ac68286bb6b5..36bfa681216f 100644
--- a/emulators/fceu/distinfo
+++ b/emulators/fceu/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.8.src.tar.gz) = cffb95097a256da18748865e52a828d8
-SIZE (fceu-0.98.8.src.tar.gz) = 666950
+MD5 (fceu-0.98.10.src.tar.bz2) = e0b396955b3ef4c7e4b5cc518cdec39f
+SIZE (fceu-0.98.10.src.tar.bz2) = 559750
diff --git a/emulators/fceu/files/patch-src-drivers-pc-unix-netplay.c b/emulators/fceu/files/patch-src-drivers-pc-unix-netplay.c
new file mode 100644
index 000000000000..dbf70d19e1a1
--- /dev/null
+++ b/emulators/fceu/files/patch-src-drivers-pc-unix-netplay.c
@@ -0,0 +1,20 @@
+--- src/drivers/pc/unix-netplay.c.orig Sun May 16 22:28:06 2004
++++ src/drivers/pc/unix-netplay.c Tue May 18 12:57:05 2004
+@@ -24,7 +24,7 @@
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <arpa/inet.h>
+@@ -42,6 +42,8 @@
+ #ifndef socklen_t
+ #define socklen_t int
+ #endif
++
++#define SOL_TCP IPPROTO_TCP
+
+ char *netplayhost=0;
+ char *netplaynick=0;
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 1d1398a90371..8310eb7406c3 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.8
+PORTVERSION= 0.98.10
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -19,6 +20,7 @@ USE_SDL= sdl
MAN6= fceu.6
WRKSRC= ${WRKDIR}/fceu
USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index ac68286bb6b5..36bfa681216f 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.8.src.tar.gz) = cffb95097a256da18748865e52a828d8
-SIZE (fceu-0.98.8.src.tar.gz) = 666950
+MD5 (fceu-0.98.10.src.tar.bz2) = e0b396955b3ef4c7e4b5cc518cdec39f
+SIZE (fceu-0.98.10.src.tar.bz2) = 559750
diff --git a/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c b/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c
new file mode 100644
index 000000000000..dbf70d19e1a1
--- /dev/null
+++ b/emulators/fceux/files/patch-src-drivers-pc-unix-netplay.c
@@ -0,0 +1,20 @@
+--- src/drivers/pc/unix-netplay.c.orig Sun May 16 22:28:06 2004
++++ src/drivers/pc/unix-netplay.c Tue May 18 12:57:05 2004
+@@ -24,7 +24,7 @@
+ #include <sys/socket.h>
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <arpa/inet.h>
+@@ -42,6 +42,8 @@
+ #ifndef socklen_t
+ #define socklen_t int
+ #endif
++
++#define SOL_TCP IPPROTO_TCP
+
+ char *netplayhost=0;
+ char *netplaynick=0;